Fall Creators Update Resulting in High CPU Use By Service Host

Hi,

After updating to the new version, I am seeing high CPU use from two processes:

Any ideas on how to make them not use a lot of CPU so that my laptop cools down and the fan stops blowing?

 

Question Info


Last updated November 18, 2018 Views 25,293 Applies to:
Answer

Hi all, 

Had the same problem myself and found the solution which is quite simple :

Go to settings -> update & security -> Windows Defender -> Open Windows Defender -> Firewall & Network protection

Then you need to disable the firewall for all the types of networks

once that's done click on restore settings

That should do the trick and you're cpu usage should return to normal.

Hope it helps, it did for me.

393 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.