Fall Creators Update BSOD at 33% storport.sys NDIS.sys driver_irql_not_less_or_equal

Hello I have a problem with Fall Creators Update. (Normal stable environment not the insider) The update itself goes fine until one specific monent (tried 3 times within' the last week) does normal reboots and all but after second reboot when it goes to 33% then loads up drivers how do I know? Because it starts to show the screen on my tv (BTW device is a laptop ASUS K501LX connected to TV) then after 1-2 minutes shows BSOD message (pic in end link) and reverts previous system. To be precise with all devices unplugged it behaves the same.

Well picture shows NDIS.sys so I started to search web for an answers what it could be so it turned out that it may be a network driver. I've used Intel Driver Support & Assistant to find out that I don't have newest WiFi driver - well cool but after the install nothing has changed still the same BSOD. Screen of ID&SA at end.

Then I found on some thread about dump from revert so I went to $WINDOWS.~BT\Sources\Rollback I found setupmem.dmp. I have opened it with Notepad++ and used search for .sys. There was only one thing matching: storport.sys. (link with file at end).

In all forums on the internet the solution is: update IRST (Intel Rapid Storage Technology driver). After clean install of Creators Update a year ago I've installed it's Version V14.6.0.1029 from official asus site. It installed fine (tried reinstalling yesterday also with success) but in the Device Manager (in end link) it does not and I remember never had shown at storage controllers tab. Windows driver 10.0.15063.0 dated for 21-Jun-06 (I know that it's fake date for reason). *The new IRST driver doesn't want to install because it says that this platform is not supported*

What more can I do? Some driver reinstallations? For the final try I was thinking about setting up second Win10 with Fall Creators next to this one to test if it could work (probably yes) but it will take some time..

Also reinstall of current Windows is bad for me: a lot of applications to reinstall, tweak settings 700GB.. again valuable time passes (times two because of HDD not SSD)

Click here to open link for folder with all mentioned files

Installation of update was made with clean boot so this option also does not change anything.

I know that the description of the problem is very long but because some inaccuracies: there is ndis and there is storport I wanted to show full path that I've taken.

~Michael

[Moved from: Windows/Windows 10/Windows update, recovery, & backup]

 

Question Info


Last updated October 27, 2018 Views 2,030 Applies to:
Answer
Answer

Hi,

Opening the setupmem.dmp with the WinDbg Preview (available from the Microsoft Store) shows the rt640x64.sys is causing the crash:

BugCheck D1, {ffff8280ac185660, 2, 0, fffff80e6c210870}

*** WARNING: Unable to verify timestamp for rt640x64.sys
*** ERROR: Module load completed but symbols could not be loaded for rt640x64.sys
Probably caused by : rt640x64.sys ( rt640x64+167c4 )

The rt640x64.sys, which appears to be dated from 2016, is the Realtek network adapter driver so try updating the Realtek network adapter driver to the latest version for Windows 10 available from Realtek (presently 10.021):

http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.