2nd Monitor won't wake up in dual monitor Windows 10 setup

First, I've had a dual monitor setup with two Asus VH238H 23" monitors for a couple years now. Until the last month they've worked flawlessly. The first is connected to an AMD Radeon HD 6570 card (Sapphire brand, I think) via an HDMI cable, the second to the same card with a DVI cable. The DVI is the one I'm abruptly having trouble with:

If I put the computer to sleep or just switch the monitors off for a time while I'm out of the office, when I bring everything back to life the 2nd (DVI) monitor remains blank, while the power indicator blinks on & off. Sometimes it abruptly turns on after a few minutes, sometimes it just blinks & blinks until I switch the system entirely off & then reboot. (A simple restart doesn't always correct the problem.) When it's on it works flawlessly, but getting it to come back on is a pain.

I've tried switching the cables to attach #2 via HDMI & #1 via DVI, but the same monitor does the same thing, so I'm deducing the problem isn't with the cable. Likewise, I can unplug the monitor for some length of time then plug it back in, but the problem continues. I originally thought the monitor might be dying, but that would seem to suggest the problem is with the signal coming from the computer.

This is a custom-built computer with an AMD A8-3580 APU on a Gigabyte GA-A75-UD4H motherboard, with 16 megs Corsair Vengeance memory (4x4), using 64-bit Windows 10 Pro.

I have updated to the latest display software/drivers offered by AMD. As I've noticed several others with a similar problem, I'm tentatively concluding this is a software issue with one of the mystery Win 10 updates, since shutting down altogether then starting up fresh alleviates the issue - until the computer goes to sleep again. I can't find any troubleshooting technique, software switch or registry item that might deal with it on a more permanent basis.

Any suggestions?

 

Question Info


Last updated December 8, 2019 Views 90,066 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

I appreciate you for trying some steps in order to get the issue fixed.

You can run the Power troubleshooter to adjust your computer's power settings. The Power troubleshooter checks things like your computer's timeout settings, which determine how long the computer waits before turning off the monitor display or entering sleep mode. Adjusting these settings can help you conserve power and extend your computer's battery life.

Perform the steps mentioned below and see if it helps.

  1. Press Windows key + X, select Control panel.
  2. Change the view by option on the top right to Large icons
  3. Click on troubleshooting and click on the view all option on the left panel
  4. Run the Power troubleshooter.

Please revert if you face any issues with the monitor.

Thank you.

27 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the reply. I ran the Power troubleshooter & came up with two "problems":

1) Power plan set to High Performance.

That one's fine. I have my computer set to never automatically go to sleep. Since it's a laptop I'm not concerned about that, & prefer to manually control sleep mode.

2) Screen saver is enabled.

But screen saver ISN"T enabled, or shouldn't be. I can't find any switch involving screen savers that's in on mode. Am guessing this might be the issue. Any thoughts?

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Also, even though I have my power profile set for the monitor to not shut off after x amount of minutes, I find it does anyway. (Not sure when, as I'm never around when it happens; it only happens when I've left the room for some time & the system hasn't been used... but nothing should power down aside from the hard drives...) If there's some way to put a stop to that behavior, that would go a long way toward keeping my 2nd monitor from freaking out...

After I posted, by the way, the situation with the monitor worsened & it completely refused to wake up all the way, instead blinking the light & momentarily flashing the ASUS warmup screen before going back again, over & over & over until I had to unplug it altogether...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Latest update:

Have changed my conclusion that it's a hardware problem. I'm now back to suspecting something within Win 10, possibly due to there being no specific drivers from Asus for my monitors; they use the generic drivers.

Unable to immediately replace the monitor, I switched back to a one-monitor setup, cutting any feed to the second monitor. This caused Monitor 2 (not immediately) to switch from a blinking blue power light (as it attempted to connect with the system) to an amber light (no signal available). Once that happened, I was able to switch back to a 2-monitor setup. As I have too much to do to waste time experimenting right now, I've taken to leaving the computer on once it's on without letting the screens blank out or putting the system to sleep, & when I shut off in the evening I first switch back to a one-monitor system. This sets the M2 power to amber. When I switch on in the morning, the light comes on amber & after loading I switch back to a two-monitor system.

This is a pain, but better than being without the monitor. I'd still like to get things working so I can put the system to sleep when necessary again. But the monitor works flawlessly when it's on & shows no signs of power or video trouble, so I've no reason to think it's a mechanical problem with the monitor anymore.

(By the way, among other things I did was to swap out the power cord, in case there was some problem there. Didn't affect anything in any way.)

Just so's you know...

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Are the resolutions on both monitors different? If yes, you might want to ensure that the resolutions on both monitors are the same. Try that and let's see.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Both monitors were identical in every respect: brand, model, size, resolution, etc.

The monitor that was giving me trouble eventually died altogether, so at this point I'm checking it all up to slow hardware failure, though I can't be sure of exactly what triggered what. The dead monitor has since been replaced by a newer model with the same size & resolution from the same manufacturer. When they "wake up" now (after I've had them turned off while leaving the computer on) they come back up at slightly different rates, but nothing serious & they both do come back up effortlessly. I no longer can use Windows' sleep function due to a problem between the most recent major Windows update & my video card; I can't update the drivers because the card goes a couple generations back & the manufacturer no longer supports it, so that's on my Black Friday shopping list. If I still get the same problem with a new card & up-to-date drivers, I'll be back...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Both monitors were identical in every respect: brand, model, size, resolution, etc.

The monitor that was giving me trouble eventually died altogether, so at this point I'm checking it all up to slow hardware failure, though I can't be sure of exactly what triggered what. The dead monitor has since been replaced by a newer model with the same size & resolution from the same manufacturer. When they "wake up" now (after I've had them turned off while leaving the computer on) they come back up at slightly different rates, but nothing serious & they both do come back up effortlessly. I no longer can use Windows' sleep function due to a problem between the most recent major Windows update & my video card; I can't update the drivers because the card goes a couple generations back & the manufacturer no longer supports it, so that's on my Black Friday shopping list. If I still get the same problem with a new card & up-to-date drivers, I'll be back...

Hello,

We need to gather more information about the 2nd monitor.
Have you tried using the monitor into a different PC running Windows 10 as well?
When had the issue first occurred? Is it after an upgrade/update?

You've mentioned that you tried to switch the DVI and HDMI cables, also, how about switching their ports?

Keep us posted.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did try the monitor on another computer (the one I was originally having problems with, not the replacement, which works fine) & it is dead. End of problem, end of story.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there,

I have exactly the same problem as mentioned above.

What i can add is that previously i was using Windows 7 pro without a problem

after installing windows 10 Enterprise this issue start to occur.

Are there any solution?

My configuration is Nvidia GTX750 Graphics card attach to TV via HDMI(1920*1080, SONY) + Monitor attached via DVI(Samsung, 1680*1050).

Issue is with my Monitor, it won't turn on after wake up from sleep. This not occur always only time to time, I have to figure it out what is the trigger...

any suggestion will be helpful.

Thanks

M.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there,

I have exactly the same problem as mentioned above.

What i can add is that previously i was using Windows 7 pro without a problem

after installing windows 10 Enterprise this issue start to occur.

Are there any solution?

My configuration is Nvidia GTX750 Graphics card attach to TV via HDMI(1920*1080, SONY) + Monitor attached via DVI(Samsung, 1680*1050).

Issue is with my Monitor, it won't turn on after wake up from sleep. This not occur always only time to time, I have to figure it out what is the trigger...

any suggestion will be helpful.

Thanks

M.

Hi,

Check the cable connections. Try this solution:
1. Open Device Manager.
2. Find and expand the Mouse drop down menu and click on the Mouse.
3. Click Properties, select Power Management Tab.
4. Uncheck "Allow the computer to turn off the device to save power".
5. Check "Allow the device to wake the computer".
Note: Do the same for the keyboard. If you still can't wake up your PC, then go to Human Interface Devices and check the "Allow this device to wake the computer" for every USB port.

Regards.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.