Windows 10 Creators Update broke my LAN port

I have a Dell Inspiron 1720. It has a Broadcom 440x 10/100 LAN port and an Intel Wireless WiFi Link 4965AGN.

Windows 10 LAN Driver = 10/14/2008 v4.60.0.2

Windows 10 WiFi Driver = 8/15/2010 v13.3.0.137

Hardware ID: PCI\VEN_14E4&DEV_170C&SUBSYS_01F21028&REV_02

I installed Windows 10 AU about 2 weeks ago and everything worked okay. I was using the LAN port for internet connectivity. I had the bright idea of updating to Creators Update so I made my USB drive on 4/11/17 using the Media Creation Tool which created build 15063. I proceeded to "upgrade" the OS to CU.

During the install it got stuck at the "Just a Moment" phase. I had to boot to the BIOS and disable the wireless and LAN port. Then it proceeded to update the OS. But after enabling the wireless and LAN it doesn't like the LAN port anymore. If it's enabled it locks up and freezes the OS when you try to use it or disable it. It only shows the computer LAN icon with an X, and the wireless doesn't work even though it works when the LAN is disabled. After disabling the LAN port and rebooting (forcing it to shut down because it locks up) the WiFi works okay.

Since it was a new AU install, I decided to do a fresh CU install. But still the same issues. Locks up at "Just A Moment". Now while in the OS anytime I enable the LAN port the WiFi doesn't work and it even locks up the OS when I try to disable the LAN driver, even with not cable plugged in. And I can't even reboot after the computer tries to access the LAN, as it locks up at the "Restarting" screen. I've tried to install a 64bit version of QuickSet, but didn't do anything.

Why does Microsoft mess with the networking so much? Anyone have any ideas to get my LAN working? I've tried the drivers from Dell, but they error out stating they're not for the 64bit platform. I've also tried the 64bit drivers from Broadcom, but they don't work either.

EDIT: When I do plug a network cable in I get the yellow exclamation mark over the network icon and it's stuck at "Identifying..."

[Post moved by the moderator to the appropriate forum category]

 

Answer
Answer

Hello.  I am an Engineer in the Windows Networking team.  I can confirm that there is a bug in the Creators Update that affects the compatibility with the Broadcom 440x driver.  We are working on resolving this until it is resolved.  

Thank you for reporting this!  I will post any updates on this issue on thread:

https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/problems-with-creators-update/d5117f36-b66f-4590-b2f3-a64b92445385?rtAction=1492183836572

Meanwhile following the steps mentioned in this thread will work around the issue (if you can call disabling Ethernet a valid workaround) until we have a real fix available.

If you have any questions please let me know.

94 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated May 1, 2019 Views 5,874 Applies to: