Shell Infrastructure Host has been using about 50% cpu usage and total cpu usage is 100%

Hello, im using a windows 10 laptop, and i restored it to a previous system restore point. Since then Shell Infrastructure Host has been using about 50% cpu usage and total cpu usage is 100%. How can i resolve this issue? Restarting has not helped.

OP - Shell Infrastructure Host high cpu

Hi Russel,

Thanks for posting your query on Microsoft community.

We understand the inconvenience caused and we will try our best to resolve the issue.

As per your query, I like to inform you that; Shellexperiencehost.exe contains information about single file with specific attributes, it is an executable file. You could face the high CPU usage due to any third party application which is trying to use this process.

As an initial steps, I suggest you to Run Maintenance task.

The Run maintenance task checks issues that might slow down your computer's, such as how many users are currently logged on to the computer, whether multiple programs are running at the same time and which application is using more CPU usage.

Follow the below steps.

  1. Press Windows + X on the keyboard.

  2. Select Control Panel.

  3. Select Troubleshooting.

  4. Click on Run maintenance task under System and Security.

If the issue persists, perform Clean boot and check if it helps.

Clean boot is performed to start Windows by using a minimal set of drivers and startup programs. This helps eliminate software conflicts that occur when you install a program.

https://support.microsoft.com/en-us/kb/929135

Note: Steps mentioned for Windows 8/8.1, will work fine with Windows 10.

Disclaimer: Please go through the section: How to reset the computer to start as usual after troubleshooting with clean boot of the Kb article to boot the computer in normal startup after fixing the issue.

Hope it helps, reply to us with the status of your issue. We will be happy to assist you.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks you for the reply, but in the time it took you to reply, i just reset my pc, and everything seems to be fine. Thanks for the help.

Hi Russel,

Thanks for posting your query on Microsoft community.

We understand the inconvenience caused and we will try our best to resolve the issue.

As per your query, I like to inform you that; Shellexperiencehost.exe contains information about single file with specific attributes, it is an executable file. You could face the high CPU usage due to any third party application which is trying to use this process.

As an initial steps, I suggest you to Run Maintenance task.

The Run maintenance task checks issues that might slow down your computer's, such as how many users are currently logged on to the computer, whether multiple programs are running at the same time and which application is using more CPU usage.

Follow the below steps.

  1. Press Windows + X on the keyboard.

  2. Select Control Panel.

  3. Select Troubleshooting.

  4. Click on Run maintenance task under System and Security.

If the issue persists, perform Clean boot and check if it helps.

Clean boot is performed to start Windows by using a minimal set of drivers and startup programs. This helps eliminate software conflicts that occur when you install a program.

https://support.microsoft.com/en-us/kb/929135

Note: Steps mentioned for Windows 8/8.1, will work fine with Windows 10.

Disclaimer: Please go through the section: How to reset the computer to start as usual after troubleshooting with clean boot of the Kb article to boot the computer in normal startup after fixing the issue.

Hope it helps, reply to us with the status of your issue. Wewill be happy to assist you.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Russel,

 

Thanks for replying to us with the status of your issue and good to know that your issue has been resolved.

For any query related to Windows Operating System, feel free to post on Microsoft Community. We will be happy to assist you.

 

Thank you,

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hey there Santosh_Rai,

I'm having the same issue with Shell Infrastructure Host or sihost.exe, not Shellexperiencehost.exe like you mentioned above. I have already did a system file scan and have done maintenance and reset my entire computer.  For some reason, it'll go from 0% cpu to 65-70% after about 20 mins on my laptop? When I check on the process, it shows 2 sihost.exe running, one doing what looks like nothing at all and the other at 65-75% cpu. And when that happens, window explorer always goes bonkers too with about 40% cpu and memory out the wazoo. Ive also scanned with Malwarebytes and windows defender, no viruses? This is so mind boggling? I also seem to have an unusually high memory consumption too? And oh, I just ended the sihost.exe process, 1 of the two, and now my laptop is running smoother?  For about 20 mins probably....Any help would be awesome!      

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Have you done the clean boot as stated above? :D

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Reviving old thread to say that the same problem happens in the following Windows 10 versions and there's no exact way to reproduce it:

1) Windows 10 Pro 64-bit Build 16299

2) Windows 10 Pro 64-bit Build 17046

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is becoming more of an issue. Intermittently on Dell Latituded E6430 model laptops. CPU shows 100%, clean boot is not helping as it occurs randomly, or once you reboot and wait on some machines.  We see shell infrastructure host running about 25% but nothing really showing what's causing the processor to run 100% cpu.  Maybe this is the chipset being hacked we have known about for years, but It's causing us many issues.  We have reinstalled, reimaged, started from scratch. It always comes back.  Latest drivers don't help.  Any suggestions?  We have run the ms scan and fix, nothing found wrong, even though cpu is 100% while running.. 

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 23, 2020 Views 35,872 Applies to: