Service host: local system continuous 100% disk usage

I have a windows 10 64bit system. My disc usage is always at 100% in task manager. Service host:local systems is constantly high so i tried stopping services listed one by one to try to figure out which one it is. This did not help. I suspect it is windows update service because when i right click it and open "services", it always says the status is stopping. Also, I cannot open the "update & security panel" in my settings. Rebooting does not help also. What can I do to solve this? My computer runs hot and seems like its running slower than before... any advice would be much appreciated!!!
 

Question Info


Last updated December 15, 2018 Views 30,330 Applies to:

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are many ways to fix this issue, One of most working here is -

Fix via Disable Superfetch Service 
  1. Just press windows + R.
  2. Now type services.msc” command.
  3. now find “Superfetch”.
  4. Edit Superfetch clicking on property.
  5. Now “Stop” for stopping the service superfetch service.
  6. Superfetch to be Disabled
  7. and apply

You can try manually with more ways.

https://www.howtoseeks.org/service-host-local-system-high-disk/

Thanks

69 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.