Multiple BSOD on new Ryzen build

So I've spent the last 3 days trying to troubleshoot my new Ryzen 1700x build. Getting BSODs about every hour, sometimes multiples in the hour. PC specs that are worth mentioning.

Ryzen 1700x (no OC just trying to get stock to work to start)

MSI x370 Pro Carbon

Sapphire nitro R9 390 

PNY Anarchy 2400 cas15 DDR4 2x8

Crucial MX300 750g SSD

Windows 10 home 

I'm getting almost entirely memory management BSODs but also have seen irql not less or equal, Faulty hardware corrupted page, critical structure corruption and unexpected store exception. All basically point at ntoskrnl.exe

I'll include a link at the bottom to my onedrive at the bottom with minidump files in hopes someone more capable than myself can read them. Who Crashed is giving very basic info so that has been no help.

It's been suggested in other forums that it may be driver related. I've tried multiple fresh WIndows 10 installs, made sure drivers are up to date through MSI live update 6, manually downloading and installing, as well as only through the device manager and windows. All come back with more or less the same BSODs. It doesn't matter if I'm gaming or just browsing, and there is nothing that really triggers it, as sometimes it takes 2 hours and sometimes it happens a minute after start up.

Other suggestions point to ram, ssd or GPU. I've tested ram with both memtest86 with up to 5 passes, as well as with windows memory diagnostic both normal and with the extended option. I've also tried them one at a time, and in different ram slots to rule out a faulty slot. I've tested my GPU with Heaven Benchmark and had no issues, no overheating or hiccuping of any kind. My PC did BSOD during this, but I feel it would have done it had I not been benchmarking either as bluescreen reader didn't report anything GPU related from the crash. I tested the SSD with both check disk and seatools and everything passed. FInally for my own piece of mind I tested my new Ryzen 1700x on prime95 blend test for about 9 hours with no failures, results showing everything passed all night. Also BIOS is up to date and I've even tried the current beta BIOS with no luck.

As stated above here is my onedrive link (first time uploading something like this so please let me know if there are any issues and I'll fix it asap). https://1drv.ms/f/s!ApOT9jMfaCBAgmcpaQ7gfOmQuq27

Any info would be greatly appreciated. Since I'm currently at the end of my troubleshooting ability and knowledge leaning towards returning the Mobo and going with an Asus or something and hoping to not run into the same issues as they have more recently updated bios for their AM4 boards. If anyone has a suggestion or possible solution to this issue I'm more than happy to try it. I'm not insanely tech savvy but I'm very capable at following most instructions. 

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated November 1, 2019 Views 7,606 Applies to:
Answer
Answer
I had the same problem and i fixed it by moving the 6th screw bystander to the one below it. It turns out that my gpu wasn't getting signal because the motherboard got pushed in by the svrew bystander

24 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.