LoadLibary failed with error 87: The parameter is incorrect

Hi everyone,

So I have just updated my AMD drivers to the crimson edition. Now when I try to play Minecraft.

I get this error.

I think that I have tried everything suggested by other posts in the community like, registry edits and updates but I just can't get this to work.

Specifications:

Thanks in advance

 

Question Info


Last updated April 7, 2020 Views 3,671 Applies to:

Hi,

Thank you for posting your query in Microsoft Community.

Sorry for the inconvenience caused.

To better understand the issue please let us know did you download the Mine craft game from Windows store?

The issue might have occurred while  installing graphics driver and it might not have updated the OpenGL Vendor name which is crucial for OpenGL for Mine craft to run.

I would suggest you to update the java and .NET Frame work and see if It helps:

Please refer the link below to update Java software.

http://www.java.com/en/download/windows_ie.jsp

Also refer the link below to update to the latest version of .NET Framework.

https://www.microsoft.com/en-us/download/details.aspx?id=49981

Hope this helps.

Please get back to us with the updated status and we will be glad to help you further.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for answering

I updated Java and the problem was still there.

I already had the updated version of .Net framework.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Sorry for the delay in response.

I would suggest you to download the graphics card drivers from the manufacturers website and install it in compatibility mode and see if it helps to solve the issue:

Now, to install in Compatibility Mode, follow these steps:


a. Locate the executable file (.exe file) for the driver installation program.
b. Right-click the file, and then click Properties.
c. In the Package Name Properties dialog box, click the Compatibility tab.
d. Click to select the Run this program in compatibility mode for check box, click Windows 8 with which it is compatible with in the Run this program in compatibility mode for list, and then click OK.
e. Double-click the executable file to start the installation program.

Hope this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thanks for trying

I updated Java and I am also running a newer version of .NET software.  I still have the problem, I am trying to load Garmin Basecamp and I still have the "load library failed with error 87: the parameter is incorrect"

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Jay,

We would like to know more about this issue that you're encountering with your application. Kindly answer the following:

  • Which Windows operating system and version are you using to run Garmin Basecamp?
  • Have you checked the system requirements for this application?
  • Have you made any changes on your computer prior to this issue?

In the meantime, you can refer to this article for more information about .NET Framework.

We'll be waiting for your response.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,  I am trying to load it Basecamp on my computer with Windows 10 Home 64 bit with AMD FX(tm)-Six Core Processor 3.50 GHz with 8 GB RAM.  The system requirements are Microsoft Windows 7+ (64-bit Windows 7, 8, 8.1, 10 — 32-bit not supported).

I had an old version of Office and there was a calendar template that I use all of the time, I purchased a new version of Office and wanted to keep the old version so I wouldn't lose the calendar template.  I think that is the only change I have made.  I do not use the computer for any games.  The error message comes up when I try to install Garmin Basecamp so at this moment I have not been able to run it.  Basecamp was installed and operating in the past.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Due to the advanced programming and configuration on the build of Windows 10 that you're running, you may need to contact the developer of the application for further assistance. They will check necessary updates so you can run Garmin Basecamp without any issues on your computer.

Regards.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.