Windows 10 - VPN - first list connect and sort alphabetically

After upgrading to Windows 10 (from 8.1) I have small problem with VPN connections.

Win 8.1 - click on network icon in task bar, scroll the list of VPN connection, double click customer (of click connect) and that's it.

Win 10 - click on network icon in task bar, scroll thru non-alphabetically sorted list (list as per VPN was added in), click on client then another window appear with exactly same not sorted VPN connection list where I need to scroll up and down to find customer again and then click connect.

When connected - active connection don't appear on the top of list as it was before ...

To disconnect - need to click first list then search customer on second (non-alphabeticall) list to disconnect.

Anyone found on how to resolve this ??

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Thank you for the workaround - I too am dumbfounded as to why they would screw up the original functionality of accessing the VPN connections from the taskbar, completely idiotic.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same problems here... The file which you can copy is nice though, but its a pain in the **** to manage it of you have a lot of connection. Also I'm unable to enable split-tunneling, forced to go through the VPN with my connections..

When i go to lan connection to disable the checkmark : "Use remote gateway on external network" the buttons don't work.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same problems here... The file which you can copy is nice though, but its a pain in the **** to manage it of you have a lot of connection. Also I'm unable to enable split-tunneling, forced to go through the VPN with my connections..

When i go to lan connection to disable the checkmark : "Use remote gateway on external network" the buttons don't work.

Hey Ron,

I feel your pain. It's asinine and extremely frustrating that you can't even modify the TCP/IP properties of VPN connections.

As a workaround, edit your PBK file with a text editor and look for the entry "IpPrioritizeRemote=1". This is the equivalent of the "Use remote gateway on external network", so you'll find this entry under each VPN connection. The default setting is "1" (on), so if you want to enable split-tunneling, change the setting to "0" (off).

You can verify the setting is working after connecting the VPN by doing a "route print" from command line. With the setting at "1" and the VPN connected, you'll see the remote network has been set to the default gateway (0.0.0.0) with a lower metric.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think I've found a better solution:

  1. Open regedit (WIN+R and type regedit.exe)
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Control Panel\Settings\Network
  3. Take ownership of the “Network” key/folder (right click, Permissions)
  4. Select “Advanced” in the Permissions window
  5. In the Advanced window, select “Change” where the owner field is (at the top of the window)
  6. Type in your username and save your changes.
  7. Close the advanced window
  8. Now select “Administrators” in the security tab
  9. Make sure “Full control” is selected, then apply changes
  10. Now that’s done, double click “ReplaceVan”
  11. Change it’s value to 2

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi This did nothing for me, but thanks for the suggestion :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ignore last comment it is working thanks so much

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think I've found a better solution:

  1. Open regedit (WIN+R and type regedit.exe)
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Control Panel\Settings\Network
  3. Take ownership of the “Network” key/folder (right click, Permissions)
  4. Select “Advanced” in the Permissions window
  5. In the Advanced window, select “Change” where the owner field is (at the top of the window)
  6. Type in your username and save your changes.
  7. Close the advanced window
  8. Now select “Administrators” in the security tab
  9. Make sure “Full control” is selected, then apply changes
  10. Now that’s done, double click “ReplaceVan”
  11. Change it’s value to 2

Ahh I see what this does...it basically reverts the Network icon flyout to the Windows 8/8.1 style. It still doesn't give me the ability to edit the connection, but this at least allows me to connect directly from it, and it's automatically alphabetized. The consequence is that it's an ugly blue background color instead of the translucent black :P

In either case, thanks for posting this. It still needs to be fixed IMO, but this makes it better than the stock Windows 10 design.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think I've found a better solution:

  1. Open regedit (WIN+R and type regedit.exe)
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Control Panel\Settings\Network
  3. Take ownership of the “Network” key/folder (right click, Permissions)
  4. Select “Advanced” in the Permissions window
  5. In the Advanced window, select “Change” where the owner field is (at the top of the window)
  6. Type in your username and save your changes.
  7. Close the advanced window
  8. Now select “Administrators” in the security tab
  9. Make sure “Full control” is selected, then apply changes
  10. Now that’s done, double click “ReplaceVan”
  11. Change it’s value to 2

Aha Quality!!!!! it works , Perfect

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Every time that we want to feel good about Microsoft, they go and commit this type of unspeakable idiocy.  Who has been designing, testing, and approving Windows 10, or for that matter, Windows 8?  Certainly not IT professionals.  It is absolutely unthinkable that someone who makes his/her living from IT would have signed their name to such ghastly examples of technical ineptitude!  Nobody has requested that Microsoft "improve" the way that Network Connections are displayed.  Ironically, if (not necessarily "when") Microsoft decides to fix this problem, it will probably be described as an "improvement", not a "correction".  Unbelievable.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

See this and fix it!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated August 6, 2020 Views 12,727 Applies to: