Windows 10 upgrade from 8.1 - 99% RAM usage and inability to shut down

I upgraded to Windows 10 on July 30 and since then I have experienced problems on two occasions where the RAM reaches 99% usage which then slows the system down and results in an inability to shut down correctly.  Shut down appears to happen but I believe it goes into sleep mode despite choosing 'Shut Down'.  There is no output to the monitor but the hard drive continues (blue light showing).  Even when the computer comes out of sleep it still shows 99% RAM usage.  The only way to sort this out is to hold the power button in until full shut down occurs.

Although the RAM is showing at 99%, the actual usage is nowhere near that figure.  The first time the problem occurred, I was playing GTA V and thought that this was the cause however the second time it happened I was using Internet Explorer with very little else running.

I have 16Gb of RAM so it is a bit worrying that all of this can be used especially with very little running.

After searching the web, I found that users of Windows 7 and 8.1 have experienced similar problems in the past and in most cases this appears to be a memory management leak problem related to the 'ndu' (Windows Network Data Usage Monitor).  Amending the registry solved the problem by changing a setting (Start value) to 4 which disabled some part of the ndu.

Sorry if this does not make much sense.

I was wondering if anyone else has experienced this problem following the upgrade and if so whether changing the ndu setting would work.  I have not tried chaging the setting in case it creates more problems as I do not fully undersatnd the significance of the above solution and more importantly why the problem occurs in the first place.  I never experienced this problem when running Windows 8.1.

It might be a case of going back to 8.1.

 

Question Info


Last updated May 24, 2019 Views 35,633 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,
 

Thank you for posting on Microsoft Community. I apologies for delay in response. I understand the inconvenience you are facing. I will certainly help you with this.

If you suspect a computer has a memory problem that isn’t being automatically detected, you can run the Windows Memory Diagnostics utility by completing the following steps:

  • Press Windows      key + R, type mdsched.exe in the Run, and then press Enter.
  • Choose whether to restart the computer and run the  tool immediately or schedule the tool to run at the next restart.
  • Windows Memory Diagnostics runs automatically after the computer restarts and performs a standard memory test automatically.      If you want to perform fewer or more tests, press F1, use the Up and Down      arrow keys to set the Test Mix as Basic, Standard, or Extended, and then press F10 to apply the desired settings and resume testing.

When testing is completed, the computer restarts automatically. You’ll see the test results when you log on.

Note: If a computer crashes because of failing memory, and Windows Memory Diagnostics detects this, the system will prompt you to schedule a memory test the next time the computer is restarted.

For shutdown issue, I suggest you to disable Turn on fast start up and check if it helps. To do so kindly follow the below given steps:

  • Press Windows key + X key and click on Control Panel.
  • Under all Control Panel items select Power Option.
  • Click or tab on Choose what the Power button does in left panel
  • Uncheck Turn on fast start up and click on Save Changes.

Check if this resolves the issue.

Hope this information is helpful. Please feel free to reply in case you face any other issues with Windows in future.

Thank you.

 

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

me too, I have 16gb RAM and upgraded to window 10 from windows 8.1. After a while using Chrome or even Opera Broswer, my computer get at risk, its slowly works. Then I saw my Ram 99% in used through Task Manager. It's also problem with shutting down but I got normal after restart computer.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

The memory test tells me there are NO problems with it. Previously i tried some other stuff to get it working but also no solution.

Never had any problems with 8.1, since upgrade to W10. Memory usage is getting higher and higher until 99% while all processes in task manager are not 8GB using!!!

It's happend more then 10 times no after upgrade and i did spend some hours to fix it while its not my job!!! 

PLZ help......

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Further to your request, I solved the problem by editing the Registry.  You will notice that I mentioned this in my original post but I had not tried it at that time.

The registry edit worked for me prior to Parth P Patel's entry so I never tried the memory test.

I am no expert so I do not know the full implications of the Registry edit but it did work and it does not appear to have had any adverse effects.

My Non-paged pool has not risen higher than 200Mb since I edited the ndu setting.  Even running GTA V does not result in any stutter now.

If you want to try it, right click the Start logo, choose Run and type regedit.

Once in the Registry Editor, you will need to navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Ndu and then from the right hand section of the window double click Start in order to be able to edit the Value data setting.  It will probably be 2 but changing this to 4 will disable the ndu.

I would suggest that a backup of the registry is performed prior to the change and this can be done by choosing File, Export to create the backup although it is a simple matter to change the setting back to the original number.

For more information, please search the web using 'disable ndu in windows'.  You will get quite a few hits, just work your way through them for peace of mind.

I hope this helps.

If anyone can explain in simple terms the effect of disabling ndu, it would be appreciated.

66 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

NDU stands for Network Diagnostic Usage, it is a monitoring tool. What it monitors for, I do not know. It could be statistics or something. I had the same issue with Windows 8 and I've had no issues disabling it there either.

For future users, I have made a video for how to do this, instead of just text, making it easier for some people.

Video Link located here

I hope this helps people,

Jesse.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Me 2 have this same problem.

it started hanging when you dont use pc for 15 to 20 mins. and starting to gives error for risk msg.

what is the solution ??

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Disabling ndu sorted it for me (see above).

In my case, I believe the problem resulted from downloads which caused the non-paged pool to continue increasing and never reduce even when a restart was initiated.  Somehow the RAM was not being flushed correctly (probably due to a program/driver).  Only completely shutting down Windows reset the non-paged pool but it quickly built up again until I disabled ndu.

Since disabling ndu, my non-paged pool is usually less than 300Mb and I have had no problems with anything else.

Give it a go, disabling the ndu takes less than a minute and you can always change the setting back again if it does not work for you.  You might even find that the start process speeds up slightly, maybe due to the low usage figure in the non-paged pool.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Further to the above, since I received the Windows 10 update (Version 1511) yesterday, the problem returned because the setting in the registry had been reset to 2.  I have once again changed it to 4 (see entry 14 August above for full details) in the hope that it will sort things out.

Obviously Microsoft has not looked into the problem and I cannot believe that I am the only person who is experiencing this.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi im having the same problem all of a sudden after an update to windows 10. All weird problems but this ones a bugger. I noticed it while streaming games to my TV. 99% of memory usage with no actual usage seen in the task manager. I see paging file being written all the time and hope that my ssd dont crash caz of this stupid bug.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi amiTiSO.

If Killer Network Manager is running on your computer (possibly came with an MSI motherboard) the following might help you in conjunction with my previous notes.

Since my note of 30 April, the problem did not totally go away so I also removed or disabled Killer Network Manager and then changed the ndu setting once again to 4 in the registry.  My non-paged pool dropped to less than 200Mb and has remained there ever since and as far as I can tell without affecting any other programs.

If you search on Google re the Killer Network Manager, there are some pages that suggest updating the Killer Network Driver directly from the Killer website rather than from MSI.  I haven't tried that as I haven't experienced any problems following my action but you might want to try that first.

I can't remember if I simply disabled Killer Network Manager or removed it.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.