Windows 10 Time ALWAYS wrong

My date is always correct, but my time is always wrong.  Example:  Right now it is 8:50 am, but my clock in Windows says 1:50 pm. Here is the situation:

My system is dual bootable, Ubuntu or Windows 10.  Ubuntu shows the correct time.  I think this rules out a bad cmos battery.

Windows 10 always shows the wrong time.  Location settings are correct, time zone settings are correct.

When I select to keep time manually, (turning off the autosync) It is fine.  When I reboot, it is wrong again.  When I select to automatically have windows set my time, it is fine.  When I reboot, it is wrong again.

I've gotten to where I keep a clock next to my computer, and fix the time each time I boot into windows..... but there has to be an actual solution.
 

Question Info


Last updated October 16, 2018 Views 272,426 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Welcome to Microsoft Community and thank you for your interest in Windows 10.

I suggest you to follow the below steps to change the settings of time and time zone:

  1. Press “Windows+X” and click on “control panel”.
  2. On the left hand side click on “clock, language and region”.
  3. Click on “change time zone”.
  4. And then click on the tab “internet time” and click on “change settings”.
  5. Check the box “synchronize with an internet time server” and also select the option “time.windows.com” from the drop down and click on “ok” and check if the issue persists.

Hope this information was helpful and do let us know if you need further assistance. We will be glad to assist.

1526 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yup, Thanks for your reply, but I have already done that.

When I do that, I get an error that says 

"An error occurred getting the status of the last synchronization.  The interface is unknown." 

The time corrects until I reboot.  Then it is off again.

97 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have a very similar issue. I will be using my computer and notice that my time has changed to something crazy off. I go in and have to force a time update then it corrects itself. Does yours just stop syncing and when it does throw it way off? I think that is what is happening to mine.

56 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have been waiting for around a year for this simple problem to get fixed and it's still not fixed. I have both windows and Mac machines and I am very close to saying goodbye to windows for good.

156 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thanks for sharing your concern on Microsoft Community.

If you are facing issue related to Windows time setting then I suggest you to try the below steps and check if helps.

  1. Press Windows key + r and type services.msc.

  2. Check for the Windows Time service and select Windows time service.

  3. On the left panel, check if the service is start or not.

  4. If service is not started then start the service, by clicking on the Start option.

  5. If the service is started the restart the service by clicking on Restart option.

 

Hope it helps, reply to us with the status of your issue. We will be happy to assist you.

Thanks and Regards,
Santosh Kumar Rai.
Microsoft Support Engineer.

386 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you go to the Windows Time service as suggested, right click on it, and click Properties, for me it appeared to be set to manual startup.

131 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello, I've tried the above and still not working.

Very Frustrating!

74 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Even I face same issue. No clue to resolve this till now.

35 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Please go to the services again and make the changes for the Windows Time Service to start automatically.

If the issue persists.

Run the System File Checker tool (SFC.exe)

System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files. It will scan your system files and to repair missing or corrupted system files in Windows. To run the SFC scan, refer to the Microsoft article below.

http://support.microsoft.com/kb/929833

 

If the issue still persists,

Crete a new User account

To create a new user account, refer to the steps mentioned in the following Microsoft link:

Set up accounts

 

Hope this information is helpful.

Regards,
Sahil Bali

19 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is a common problem when dual booting with Ubuntu/Linux. Linux gets it's time from BIOS assuming it is UTC while Windows does it assuming it is your regional time. So each OS keeps messing the time for each other. The easier way is to change time in Linux. 

In linux, go to:

/etc/default/rcS

Change:

UTC=yes to UTC=no

389 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.