Windows 10 only use half of max cpu speed

I have just upgraded my windows 7 laptop (HP Pavilion dm1-4000AU) to windows 10, everything seems OK. But when I open task manager, it shows that my laptop only use half of cpu speed even if the cpu load is full.

But, during first few minute after wake up from hibernate, the speed can reach the maximum speed. Only for few minute, then it stuck to half speed again.

I already tried to disabled cpu parking, but it did't work.

And now, I can't play youtube smoothly because it seem it's too heavy to play youtube.

Please help

Thanks

 

Question Info


Last updated September 22, 2018 Views 37,766 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Sulhan,

 

What exactly happens when you try to play YouTube videos?

 

If you are seeing issues with playing online videos, it might be due to Internet Connections also. I would suggest you to check if you have any other issues with performance in Windows 10.

 

A high percentage means that the programs or processes that are running require a lot of CPU resources, which can slow your computer. If the percentage appears frozen at or near 100%, then a program might not be responding.

Refer to the article for more information:

View CPU utilization and other performance information

http://windows.microsoft.com/en-in/windows/view-cpu-utilization-performance-information#1TC=windows-7

The article is for Windows 7 but the information applies to Windows 10 also.

 

You may follow these steps and try to run the System Maintenance troubleshooter:

Press Windows key + X on the keyboard.

Click on Control panel.

Type “Troubleshooting” without quotes in the Control panel search box.

Click on Troubleshooting and click on View all.

Click on System Maintenance troubleshooter and follow the on-screen instructions.

 

Let us know the results.

Rohit S

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have the exact same problem on my Dell A860 laptop. Windows correctly reports the max CPU speed at 1.8GHz but limits it to 0.9GHz with total CPU activity maxing out at 50% (CONSISTENTLY).

Have tried forcing maximum performance mode, and disabling SpeedStep in the BIOS; still have the same problem.

Also, temps stay at around 50 degrees C as I recently cleaned out the fan & heatsink and applied new paste.

This problem did not exist in windows 7 when it was running on this laptop this morning.

The laptop is barely usable.

These were taken whilst simulating high CPU use...

520 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's not because of internet connection, since the downloaded mark is already far beyond playing position. Beside, I also try to run two instance of microcontroller simulator to make cpu busy and it's also stuck at half speed. The simulator is always try to eat all of the rest of cpu time, so when it run at normal system, cpu load will become 100%. But here, cpu is still stuck at no more than 49%.

Troubleshooting -> not helping.

http://windows.microsoft.com/en-in/windows/view-cpu-utilization-performance-information#1TC=windows-7 

-> not helping too.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi OP,

Came across this thread and it seems to have solved my problem for now.

https://social.technet.microsoft.com/Forums/windows/en-US/b95d3e0e-4d86-458b-a719-a02c0b22677f/windows-8-is-throttling-my-cpu-pentium-4?forum=w8itproperf

 "

Finally I compared the bootlogs of safe vs. normal mode, and the culprit turned out to be"intelppm.sys".

Here's what worked for me:

- Boot into recovery console from install medium

- Type "regedit"

- Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Intelppm and set the 'Start' value to '4' (=> disabled).

- Leave regedit

- Change directory to c:\windows\system32\drivers (<- in my case, the "C:" drive was somehow mapped to "D:")

- Type "rename intelppm.sys intelppm.sys.old", just in case you need it later on

- Exit console and reboot

Note: You could probably do this in Safe Mode as well.

...and I'm not sure if it's necessary to change the registry settings if you renamed the driver file, maybe someone else can test that out...

Hope this helps..."

Props to @sterlingwolfe

69 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It works for me. But, since my processor is amd, then I have to change amdppm.sys instead of intelppm.sys

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I try to only set the 'Start' value to '4' of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AmdPPM and rename the amdppm.sys.old file bakc to amdppm.sys, and the cpu speed still be able to reach 100%. So, I think, it's better to only modify the registry.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This will make cpu speed always at max speed, even if there is no activity. And my laptop become overheat quickly. So, this is not the solution for my problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same problem here, at 0.91GHz always, even with benchmark software stressing the cpu

Is obviously a fault Intel PPM driver, but nobody cares from MSFT or Intel, the usual "throubleshooting" never works (since Windows 1.0, of course :D)

I dont want to touch the registry, i still want to keep my battery working for a few hours, if i change the config is obvious i'll be at 2.7GHz all the time, do someone knows if Intel has an update for this? Microsoft? my notebook is useless with this issue

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

for intel processors, try this instead. go into your device manager and open up the processor tree, and update the driver to the one labeled 'processor'. you must do this for every core listed in the tree, or it will not work. the CPU will still be identified the same in the device manager, but instead of using intelppm.sys it will use processor.sys instead. after reboot on my system, instead of .90 Ghz, my system is now running at 1.60Ghz. my system still isn't turbo boosting to 2.8 Ghz, yet but it's a step in the right direction.

I assume that for those with AMD CPU's in the update driver screen instead of the two option being intel process and processor, it would be AMD processor, and processor. if this is the case, then this operation should work for AMD cpu's as well

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

just discovered something interesting after switching over to the processor.sys driver. BIOS setup was not coming up when summoned. before we go any farther let me state, that my system has a traditional BIOS/CMOS setup and not UEFI. back to what I found..... when I pressed the bios setup key (F2 in my case) the screen would display a message saying entering setup, but instead of bios setup, windows would start loading. several reboots did not resolve to issue. I finally returned access of the bios setup by removing the power cord and pressing and holding the power button for 15 seconds. afterwards, for testing purposes, I switched back to the intelppm.sys driver, and when I rebooted the variable clock and turbo boosting was working again. IDK how long the bios was like that, since I rarely have a need to access it. last access was probably when I was still running windows 7. I don't know if a condition like this is even possible with UEFI, but I thought I would report it. the only reason I even went into BIOS setup, was to confirm the speed step and turbo boost setting were set to on (enabled, yes, etc.). but now the clock is going from between 1.6 Ghz to 2.8 Ghz as it should be. and the utilization now matches what I saw under windows 7. between 5% and 18% with peaks at 30%. I'm now back to using the 'intel processor' driver for the time being.

Toshiba Satellite  P500-ST6844

PSPGSU-0Q2012

1st gen i7-720QM

GT330M 1gb dedicated GDDR3

8Gb DDR3

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.