Windows 10 keyboard language changes on its own

My Windows 10 keyboard language will keep changing from whatever I set it to. I want it set as English (United States) US keyboard so I go ahead and make it that. Later on I will be typing and notice it has automatically been changed to English (United Kingdom) which is different to what my real life keyboard is.

How do I prevent this from happening?

***Post moved by moderator to the appropriate category.***

Answer
Answer

Hi Matty,

One possible reason that is causing the changing of keyboard language on your computer, may be due to some shortcut keys on your keyboard. To disable automatic keyboard layout change, kindly follow the steps below:

  1. Press Windows key + X on your keyboard.
  2. Choose Control Panel.
  3. Under View by, select Small icon.
  4. Click Language.
  5. On the left side, choose Advance settings.
  6. Under Switching input methods, uncheck Let me set a different input method for each app window.
  7. Click Save.
  8. Restart your computer.

Accidentally pressing some shortcut keys may cause some unwanted changes on your computer. Kindly view the samples below:

Windows Key + Space key = Changes language/keyboard pairs.
Alt + Shift = Change Language.
Ctrl + Shift = Changes keyboard.

Let us know how it goes.

134 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 5, 2020 Views 103,523 Applies to: