Windows 10 keeps waking up from sleep in the middle of the night!

Hello all,

So I just upgraded to windows 10 over the weekend, and immediately I get the age-old problems of sleep that I got when I installed windows 8... the computer wakes up during the night as I am sleeping and does not go back to sleep. So here is what I have done...

First thing was to try this....

powercfg/lastwake

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>powercfg/lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

so apparently no source woke up the computer? weird... so I decided to go into the event viewer to see what event caused the wake up...

Event Viewer > Windows Logs > System > Right Click: Filter Current Log > Event Sources : "Power Troubleshooter"

I  checked the last wake event and got this:

So... the wake source was still unknown... OK. dead end there...

powercfg/devicequery wake_armed

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>powercfg/devicequery wake_armed
Lenovo ThinkPad PS/2 keyboard

Nothing out of the ordinary there... but just to make sure I'll check some other things...:

Device Manager

I made sure all of my power options for all devices had "allow this device to wake up the computer" unchecked... and even went so far as to make sure that the "Wake on Pattern Match" AND "Wake on Magic Packet" for my network adapter were already disabled.. which they were:

PowerOptions > Advanced Settings > Sleep > Allow Wake Timers > Setting: Disabled

Supposedly this should prevent the computer from waking up, but it hasn't.

But the closest I got was here...

powercfg/waketimers

And I get this:

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>powercfg -waketimers
Timer set by [SERVICE] \Device\HarddiskVolume2\Windows\System32\svchost.exe (SystemEventsBroker) expires at 6:11:40 AM on 8/11/2015.
  Reason: Windows will execute 'Maintenance Activator' scheduled task that requested waking the computer.

events log

So I go back to the events log... and I find NOTHING listed that is a maintenance activator...

Scheduled tasks

So then I check scheduled tasks... and there are no tasks there that would indicate a maintenance thing... but for good measure, I make sure nothing can wake up the computer anyway by going to each task and unchecking the box that reads, "wake the computer to run this task"

but they were all already unchecked!! SO, back into the abyss of forums I go and I find that I could do the following...

Control Panel > System and Security > Security and Maintenance >

Under the maintenance tab... I went to change the automatic maintenance settings

And I changed the time and unchecked "allow scheduled maintenance to wake up my computer at the scheduled time" and for good measure, I figured I'd change the time to 12:00pm to see if wakes up later...

and after all of this.. it STILL doesn't work!

So after working on these issues for 3 and half hours, and scouring forums for answers, I have finally succumbed to writing this lengthy catalog and asking for help..... so, suggestions anyone?

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated September 19, 2018 Views 120,696 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Due to excess thread volume, we are trying to respond to the queries as soon as possible, please bear with us. Inconvenience regretted.

Please wait.

Vinz

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for your interest in Windows 10 and sorry to hear about the inconvenience caused.

We might have to check with the computer manufacturer website for updated BIOS and chipset drivers.

http://support.lenovo.com/us/en/

If you don't find it in computer manufacturer website, try to visit the mother board manufacturer website and check for updated drivers.

BIOS Disclaimer:

Modifying BIOS/ complementary metal oxide semiconductor (CMOS) settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of BIOS/CMOS settings can be solved. Modifications of the settings are at your own risk. 

Hope this information helps, for further assistance please reply.

Vinz

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Actually, after another day, it appears that the very last step in the control panel has done the trick... no more unexpected wakings.

However, I think I need to move on to step two for me. I need to look into the computer actually going to sleep on the appropriate timer now, since it just stays awake.

Thank you so much for responding to my query!

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If it is any consolation (and I'm sure it isn't) I have almost exactly and precisely the same problem with

Windows 10 keeps waking up from sleep in the middle of the night

and I've taken the same steps as you did with no solution.

I've isolated the problem down to:

C:\WINDOWS\system32>powercfg /waketimers

Timer set by [SERVICE] \Device\HarddiskVolume1\Windows\System32\svchost.exe (SystemEventsBroker) expires at 03:29:30 on 13/08/2015.

  Reason: Windows will execute 'NT TASK\Microsoft\Windows\UpdateOrchestrator\Reboot' scheduled task that requested waking the computer.

P.S. I really like your phrase "abyss of forums". 

Any pointers from knowledgeable folks appreciated.

Steve

13 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Windows 10 was somehow loaded without permission.

I removed Win 10 and now I have the problem with my PC waking up in sleep mode with Win 7.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Windows 10 was somehow loaded without permission.

I removed Win 10 and now I have the problem with my PC waking up in sleep mode with Win 7.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If it is any consolation (and I'm sure it isn't) I have almost exactly and precisely the same problem with

Windows 10 keeps waking up from sleep in the middle of the night

and I've taken the same steps as you did with no solution.

I've isolated the problem down to:

C:\WINDOWS\system32>powercfg /waketimers

Timer set by [SERVICE] \Device\HarddiskVolume1\Windows\System32\svchost.exe (SystemEventsBroker) expires at 03:29:30 on 13/08/2015.

  Reason: Windows will execute 'NT TASK\Microsoft\Windows\UpdateOrchestrator\Reboot' scheduled task that requested waking the computer.

I've got the EXACT same issue with the exact same message showing up under wake timers. I didn't have this problem with my computer waking itself up in Windows 8.1.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The automatic windows updates restarts are the cause and you can change the restart time from 3:30am to a more reasonable hour in Windows Update Settings. The best fix is just to turn the computer off at night instead of using Sleep.

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found the solution. Open task scheduler, go to Task Scheduler Library > Microsoft > Windows > UpdateOrchestrator

Click on Reboot, go to the conditions tab, and uncheck "Wake the computer to run this task". Might want to check all the other items in this section to make sure that is unchecked as well. This ought to do it.

387 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That must have taken some finding.

It looks very promising.

Many thanks.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.