Windows 10 HDMI audio not working?

After much forum-exploration, I've found that many people have had either a similar problem as me and solved it, or the same exact one and not solved it:

For audio, I use HDMI out -> converter (to optic) -> receiver -> speakers.  Just recently (for no obvious reason) my laptop stopped recognizing the HDMI cable plugged into it. All of my drivers are up to date, and if I unplug the HDMI cable, my laptop makes a sound letting me know that something's been unplugged. I've tested the receiver, multiple cables, the converter -everything- but no dice (it must be my computer, eh?). I've tried "Show Disabled Devices," checking the Device Manager, and every other solution that the internet has offered, but I don't know what's up. This is my Sound settings with the HDMI cable plugged in:


When the problem first occurred I was using Windows 8.1, and the general consensus I had received on upgrading to '10 was "If it ain't broke, don't fix it." Now something was awry, so I tried solving the issue by upgrading to 10. That didn't work, and I now have Windows 10 and the same exact issues. Anyone have any idea of what's going on here? 

Much appreciated,

Cass

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Thank you for your interest in Windows 10.

From your issue description, I understand that you are not getting sound using HDMI cables.

In order to help you better, please provide us with the following information.

  • What is the make and model of the computer?
  • Did you try connecting different HDMI port and check if it works?
  • Which application are you using to stream movies on the computer?
  • Are you able to hear the audio from the computer (without the HDMI)?
  • Does this issue occur for a specific file?
  • Do you get any error messages/codes?
  • Did you make any changes to the computer prior to this issue?

HDMI cables do support audio signals, but not all HDMI-enabled video cards support audio. If your HDTV has an audio input, you might be able to connect a separate audio cable from your computer's sound card directly to the TV. Otherwise, you'll need to connect the audio signal to a different output device, such as external computer speakers or your home stereo system. Follow these methods and check if it helps:

Method 1: By default Windows does not route sound over the HDMI output. To change this we need to change the settings in control panel.

Note: This will turn off sound from the speakers or normal audio output on the laptop. To get that back you will have to reverse this process.

a) Press Windows key + X
b) Click on "Control Panel"
c) With the Control Panel in "Control Panel Home" view please click on "Hardware and Sound"
d) Where it says "Sound" in green letters there are three options below that are in blue click on "Manage Audio Devices"
e) This will bring up a window labeled "Sound"
f) On the "Playback" tab there is listed the sound options available to you. One should read "Digital Output Device (HDMI)" Click on that.
g) There should now be a check mark on that option, make HDMI sound output as default .
h) The Sound should then play through your HDMI hookups to the TV.

Method 2: Update the Sound driver

a) Press Windows key + X key when you are at desktop.
b) Select Device Manager.
c) Double-click Sound driver from the left panel to Update.
d) Right-click the device, and click Update driver Software
e) Windows will prompt you to confirm the device’s removal. Click OK to remove the driver.

Please reboot your computer

You may also refer to: Fix sound problems

Hope it helps. For any further Windows related assistance, feel free to contact us and we will be glad to help

80 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

  • My computer is an MSI CX61
  • It only has one HDMI port
  • I'm not streaming movies; this is solely for audio
  • I can hear the audio perfectly without the HDMI cable
  • The issue occurs for everything when I try the HDMI cable
  • I didn't get any error messages or anything; it just stopped functioning
  • I didn't make any changes prior to this

I know my video card (Nvidia GeForce 820M) supports audio because this setup has worked perfectly for the past six months up until recently. I'm not using an HDTV (this is just for audio), and the external computer speakers/home stereo are what I'm trying to connect to (though having difficulties with).

Method 1: I already provided a picture showing that the "Playback" tab doesn't display an option for HDMI audio. It only displays an option for the speakers built into the laptop.

Method 2: I already said that I updated all my drivers (sound, video cards -anything that would relate to this issue).

Sorry, my problem still stands.

189 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi someone please help I installed the Windows 10 Upgrade 2 days ago.  I watch netflix through my pc to tv via an HDMI cable it was working fine up until a few hours ago.  The only thing I did was I had to unplug my devices ie. hdmi cable from the back of my pc but plugged it back in.  Now I have no audio through my tv when watching Netflix.  I have checked for updated drivers from what I can tell they are all up to date.  I DO NOT have an option under control panel hardware and sound then under sound and"Digital Output Device (HDMI)"  I do not have this option under playback.  Please help

182 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Looks like we're in the same boat. This is the same exact issue I'm having. Please post back here if you find a solution or something.

62 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm in the same boat too

22 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Just fixed it I went to device manger, check out "sound,video and game controllers" updated AMD High Definition Audio Device. It done the trick

91 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'm not sure where to report this, but after I upgraded a Lenovo Y50 laptop to Win 10 64 Enterprise, the HDMI audio stopped working.

All the drivers were installed, and the correct options were selected in the audio panel.

After much research I stumbled upon a post on a message board which had a suggestion that didn't make any sense, but I tried it anyway, and it resolved the issue.

The suggestion was to uninstall Hyper-V.

Once the Hyper-V feature was uninstalled from Windows, HDMI audio started working again.

It seems that for whatever reason, Hyper-V is interfering with HDMI audio out in Windows 10.

This problem did not exist in 8.1

Can you guys look into this?

Regards,

JC

30 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Niranjan Manjhi

Do you know what? You are just making a lot of noise here there is a huge windows problem on HDMI-sound, it say that "its not plugged in" but it is! I have googled the **** out of the internet for many months now to try to find a solution to this problem. I have never ever worked so much on such a simple problem. SO MANY USERS HAVE THIS PROBLEM. Shame on you!!! that you don't fix this in a rush.  I have in the mean time installed Ubuntu i a dual boot, and with this OS its plug and play and works like a charm. What are you doing about it??? I had hoped that win10 would have solved it.... But no - no - no - no.

Pull your self together now... Try to google "HDMI-no sound windows" at the moment you get more than 5 million results!!!!!!!!!!!! Come on can you live with that??

2406 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have a msi gt70 connected to an lg8500 through  hdmi. Since upgrading to windows 10 audio through hdmi is not functioning. The playback tab shows the realtek digital output as not connected. Please advise on how to rectify the matter or haw to downgrade back to 8.1.

Unfortunately, I use a windows pc for more than watching movies and need this feature functioning for a presentation.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks a lot for bringing the Hyper-V up! Pretty incredible, but just stopping the Hyper-V service worked for me.

I could see the hdmi device on the sounds/playback devices list and set it to default playback device, but audio just wouldn't get through. Video worked fine, and the 'sound bars' on the playback devices list would flash when I was trying to play some audio.

I actually need the Hyper-V every now and then so couldn't just uninstall it. Fortunately, just temporary disabling it seems to do the trick as well. Just open Hyper-V Manager (type it in the global search) and select the service that is running (which probably has the name of your computer) and click Stop in the Actions.

Only Pro-editions have Hyper-V, so if you're running the standard edition, this isn't your solution. My laptop is a 2014 dell XPS 15 with GeForce GT 750M.

24 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated November 30, 2020 Views 404,780 Applies to: