Windows 10 external monitor with lid closed but only when connected

Hey there

I am using my Win 10 laptop either as a standalone laptop or in a desktop setup with an external monitor attached and my lid closed. What I want is that in my desktop environment, the computer doen't go to sleep when I close the lid (I know how to do that in the energy settings) and when I use my laptop without an external monitor attached, then it should go to sleep when I close the lid.

How can I condition the energy behaviour on whether an external display is attached?

Thx for the help

 

Question Info


Last updated July 19, 2019 Views 80,663 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

I suggest you to try the steps below and check if it helps.

Run the Power Troubleshooter.

Power troubleshooter will automatically fix some common issues with Power Plans. Run the Power troubleshooter to adjust your computer's power settings. The Power troubleshooter checks things like your computer's timeout settings, which determine how long the computer waits before turning off the monitor display or entering sleep mode. Adjusting these settings can help you conserve power and extend your computer's battery life.

  1. Press Windows key + W and type Troubleshooting.

  2. Select Troubleshooting and click on System and Security.

  3. Click on Power and follow the  onscreen steps.

Also, try to put the system in Clean Boot. This helps eliminate software conflicts that occur when you install a program or an update or when you run a program in Windows. It starts Windows by using a minimal set of drivers and startup programs.
How to perform a Clean Boot in Windows:
http://support.microsoft.com/kb/929135


Note: After troubleshooting, refer to this section "How to reset the computer to start normally after clean boot troubleshooting" in the above link.

Hope this helps in resolving the issue. If the issue persists, do get back to us. We will be happy to assist you.             

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I suggest you to try the steps below and check if it helps.

Run the Power Troubleshooter.

Power troubleshooter will automatically fix some common issues with Power Plans. Run the Power troubleshooter to adjust your computer's power settings. The Power troubleshooter checks things like your computer's timeout settings, which determine how long the computer waits before turning off the monitor display or entering sleep mode. Adjusting these settings can help you conserve power and extend your computer's battery life.

  1. Press Windows key + W and type Troubleshooting.

  2. Select Troubleshooting and click on System and Security.

  3. Click on Power and follow the  onscreen steps.

Also, try to put the system in Clean Boot. This helps eliminate software conflicts that occur when you install a program or an update or when you run a program in Windows. It starts Windows by using a minimal set of drivers and startup programs.
How to perform a Clean Boot in Windows:
http://support.microsoft.com/kb/929135


Note: After troubleshooting, refer to this section "How to reset the computer to start normally after clean boot troubleshooting" in the above link.

Hope this helps in resolving the issue. If the issue persists, do get back to us. We will be happy to assist you.             

Sometimes I wonder if you guys even read the questions you are asked.

275 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It looks like a BOT answer :(

R U there, Microsoft engineers????

45 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Go in control panel>power options. on left side f screen there is an option saying " when I close lid of laptop....", YOU MUST SELECT "DO NOTHING"...n thats it, problem solved

hope this helps !! 

189 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No, it doesn’t solve the problem Rohit,

When you select the “Do nothing” option for “Close the lid” action, the energy plan you’ve selected (e.g. turn of display after 10 minutes, sleep after 15 minutes with battery on) is completely lost, and it literally DOES NOTHING: the laptop never rests even if it’s not in use.


Haven’t you thought that the "Do nothing" option when closing the lid would lead to the DEFAULT SETTINGS OF THE SELECTED ENERGY PLAN?

Or if that conditional is too hard to write, would you let us select a fourth option: “Do Nothing and CONTINUE WITH SELECTED PLAN?

It’s common to use laptops as desktops with an external monitor. And it’s also normal to keep them with the lid closed for space matters and these settings won't help you; you either are forced to:

  • Maintain the laptop with the lid open, or
  • Putting it to sleep yourself after some minutes of no use, which is a nonesense.

Please improve this!

35 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think what we want here is:

With external display - Close the lid WON'T put the laptop into sleep mode.

Without external display - Close the lid WILL put the laptop into sleep mode.

So you can't just set the lid option to "Do Nothing" or something else because there are two different scenarios here.

I noticed that this question was posted in 2015 and it's 2017 now. I can't see anything in the recent updates. What I'll suggest here is go and buy a mac.

81 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think what we want here is:

With external display - Close the lid WON'T put the laptop into sleep mode.

Without external display - Close the lid WILL put the laptop into sleep mode.

This is an old good feature in the Linux world.

31 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In Windows 10 right-click on the desktop and select "Display Settings". Where it says "Multiple Displays" select your external monitor, for me I chose "Show only on 2". Check the box "make this my main display" for the external monitor. When you close the laptop the external screen will turn off but will come back on when you click the mouse.

P.S. You will have to have the Power & Sleep settings set to "sleep when I close the lid" for this to work properly.

171 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I wish none_ofyour_business identified themselves.  Than I could give a proper THANK YOU! for solving the issue.

32 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In Windows 10 right-click on the desktop and select "Display Settings". Where it says "Multiple Displays" select your external monitor, for me I chose "Show only on 2". Check the box "make this my main display" for the external monitor. When you close the laptop the external screen will turn off but will come back on when you click the mouse.

P.S. You will have to have the Power & Sleep settings set to "sleep when I close the lid" for this to work properly.

When I try to do this, the check box for "Make this my main display" is grayed out. I can't select the box. any advice?

18 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.