Windows 10 error 10016 from Run-time broker - cannot change permissions

I have tried all the solutions suggested on other (non-Windows-10) threads but cannot get rid of the floods of errors logged in my event viewer because Windows 10 (build 10240, with all updates) thinks the clsid does not have permission to run.

The errors have been reported on several versions of Windows and it's about time the problem was fixed.

Can anyone help me to stop them occurring?

I have tried to alter the owner & permissions in Regedit and via Component Services but am refused permission to save the changes I try to make. I was running as Administrator.

I think this needs to be fixed by Microsoft as a bug.

Answer
Answer

If you are seeing the following error use the fix that follows:

 Fix for Distributed COM RuntimeBroker (Error ID: 10016):

Because DCOM RuntimeBroker in Component Services won’t let you edit the security settings, you need to right click on the task bar Windows icon, click Run and type in regedit, and then press Enter. Do the instructions 1-4 below for each of these registry keys:

HKEY_CLASSES_ROOT\AppID\{9CA88EE3-ACB7-47c8-AFC4-AB702511C276}

HKEY_CLASSES_ROOT\AppID\RuntimeBroker.exe

HKEY_CLASSES_ROOT\CLSID\{D63B10C5-BB46-4990-A94F-E40B9D520160}

HKEY_CLASSES_ROOT\CLSID\{D63B10C5-BB46-4990-A94F-E40B9D520160}\LocalServer32

  1. Go to each key and back it up by doing a right click on the registry key and click Export and save the file to a documents folder (you should always backup any registry key you change). Now right click on the registry key again and click Permissions > Advanced.

  2. If Administrators has Full Privileges, then go to the next registry key and start with instruction #1 again. Otherwise change ownership to Administrators by clicking Change at the top where is says Owner then click Advanced > Find Now > Administrators > OK > OK > Apply > Yes.  If a message(s) comes up just click OK or Yes until back to the Permissions window.

  3. Click on Administrators and check off Full Control then click OK.

  4. Check "Replace all child objects...." and then Apply.  If a message(s) comes up just click OK or Yes until back to the Permissions window.  Then click OK to close the Permissions window.

  5. When done with all 4 registry keys, reboot.

  6. Go to Control Panel > Administrative Tools > Component Services > Computers (middle window)> My Computer > DCOM Config and then right click on RuntimeBroker and click Properties >  Security.  You’ll see 3 edit buttons.

  7. Make sure Customize is checked and then click on the top Edit under Launch and Activation Permissions and you may see this:

    If you see it click Cancel.

  8. In the Group or user names box highlight each and make sure that Local Launch and Local Activation are checked.  Make sure that you have in the Group or User Names window: All Applications Packages, Self, System, Administrators, and Interactive. If any are missing, then click Add > Advanced > Find Now > [Name]> OK > OK, and make sure that Local Launch and Local Activation are checked.

  9. Now click the middle Edit under Access Permissions (make sure Customize is checked off) then in the Group or user names box highlight each and make sure that Local Access is checked off.  When done click OK. Make sure that you have in the Group or User Names window: All Applications Packages, Self, System, Administrators, Local Network, and Network Service. If any are missing, then click Add > Advanced > Find Now > [Name]> OK > OK, and make sure that Local Access is checked off.

  10. Click the bottom Edit under Configuration Parameters (make sure Customize is checked off) then click Advanced. Each Principal should have Read Access except for Administrators, and TrustedInstaller who should have Full.  If you need to make any changes, highlight the one to change then click Edit, make any changes, and then click OK.   You should have the following principals listed: All Applications Packages, System, Administrators, Users, and TrustedInstaller. If any are missing then click Add > Advanced > Find Now > [Name]> OK > OK (make sure that Read is checked). Then click OK until all the Properties windows are closed. Now close up the Component Services window.

  11. Now go back to the regedit window and change ownership to SYSTEM on the same four keys previously changed. Do this by clicking Change at the top where is says Owner then click Advanced > Find Now > SYSTEM > OK > OK > Apply > Yes. If a message(s) comes up just click OK or Yes until back to the Permissions window and then click OK > OK.

  12. When done changing the owner to SYSTEM on all 4 registry keys like you did in #2 then close up regedit.

  13. Best to reboot at this point and then you are done.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

I seem to be able to change it no problem.

HKEY_CLASSES_ROOT\CLSID\{D63B10C5-BB46-4990-A94F-E40B9D520160}

right click / permissions     click full permission on Administrators

click advanced   on top of page change from trusted installer to  Administrators    search & ok it to your name.

Apply and exit and it should stayed checked in the properties window when you close it.   Reopen it and make sure.

Do same for next

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\{9CA88EE3-ACB7-47c8-AFC4-AB702511C276}

Then to the  component service RuntimeBroker and top item will ask something about improper other key/permission needs changed... ok that(same key in few other locations in regedit)    then you can give your self  full permissions.

~~~~~~~~

I had that 10016 runtimebroker issue in maybe 10525 and changed permissions to be rid of it....  but its not showing errors in 10532 here.

~
Microsoft Bob came back after a 20 year makeover, and with a new name. Cortana!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 24, 2020 Views 39,274 Applies to: