Web browser keeps opening to msn by itself randomly

Hi every now and then with no user interaction my default web browser firefox opens to the msn home page (my home page is google)(this also happens if edge is set as the default browser). It is completely random and comes up over whatever I'm currently doing on my computer stopping me in my tracks this is very annoying. I've run anti virus software and its come up clean, I reloaded my operating and it returned after a few weeks and I haven't added new apps or software that may have caused it. The only thing I've found that may be involved is a system restore point automatically created by windows module installer what its for I have no idea, so I tried a restore point prior to that date and the issue seemed to go away but alas it has returned this time there hasn't been a restore point created by anything that might indicate a change. Any ideas on what be triggering my web browser to open to msn?
 

Question Info


Last updated October 21, 2018 Views 5,192 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

stitches12 - THANK YOU!  After reading your post from 7/11/18, I checked and found that I was connected to both wireless and wired.  I simply disconnected the wireless and that has fixed the problem!  Thanks for taking the time to post this solution.  Ghost - thanks for posting in the first place and keeping the thread going!  

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Why would i want to install a linux based os. Was this just a piss poor attempt humour?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found a solution:  https://tutorials.ubuntu.com/tutorial/tutorial-install-ubuntu-desktop#0

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Don't listen to the MVP greg the guy is absolutely clueless malware a browser hijacker to MSN omg he had a go at me cause he can't read a question and come up with a relevant answer none of ms support could. To fix this there is 2 options as i see it the first is to look at the posts by stiches12 he seems to be onto it having the actual cause and second you can try what I've done which is to run a pre-anniversary update version of windows 10 and have windows update disabled permanently. Doing the second one my system has worked perfectly, no instability malware etc, for the last 9 months. Just so you know ms support have given up on this issue (they deny it exists) you wont hear back from them on this thread (as usual when they dont understand the problem and the usual answers dont work they just stop replying). great customer service by ms support round of applause please

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I suggest you read the last two pages. This doesn't have anything to do with malware.

Microsoft's support people are rarely useful, and typically they give canned answers without taking the time to understand the exact problem, so they give you an irrelevant answer. It's best to not take their posts seriously. I personally just skip their posts and read user responses first

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

  I use Chrome and mine is doing the same thing. It has nothing to do with my homepage.  I can leave the browser open all night and a couple times a week I wake up, and find a new tab open to MSN.  I have no add-ons, etc., I have run all virus and malware scanners.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are some simple and easy solution around which we are overlooking. You see now-a-days we all have multimedia keyboards which contains different key-binding to different programs. Some keys are set to open your default browser some are assigned to volume and some are assigned to open your emails. So at the very beginning we need to check the behavior by removing the multimedia keyboard from computer even the multifunctional Mouse. The cause may arrive from there only. In my case it happened. I removed my keyboard and attached another keyboard and the problem was immediately gone. I took the keyboard and installed at my Father's system to check if the same problem happens to my Father's system, and believe me that problem replicated itself there in my Father's computer.  So I am confirmed that the issue was causing for a faultier keyboard.

So try to do the same as I did. Check if the problem remain same or not.

Thanks

LASMOND

Interesting.

What would you suggest to test with a laptop? 

This behavior occurs with 3 different setups for me: Laptop, Normal computer (old ibm keyboard, it doesn't even have windows key!) and a very new expansive computer with a very new keyboard with leds .

Only common thing between them is Windows 10.

This solution doesn't suite the problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are some simple and easy solution around which we are overlooking. You see now-a-days we all have multimedia keyboards which contains different key-binding to different programs. Some keys are set to open your default browser some are assigned to volume and some are assigned to open your emails. So at the very beginning we need to check the behavior by removing the multimedia keyboard from computer even the multifunctional Mouse. The cause may arrive from there only. In my case it happened. I removed my keyboard and attached another keyboard and the problem was immediately gone. I took the keyboard and installed at my Father's system to check if the same problem happens to my Father's system, and believe me that problem replicated itself there in my Father's computer.  So I am confirmed that the issue was causing for a faultier keyboard.

So try to do the same as I did. Check if the problem remain same or not.

Thanks

LASMOND

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In the case of wifi, this can be fixed by simply disconnecting from the wireless network that has the captive portal. I'd also recommend unchecking the automatically connect option for any wifi network that has a captive portal, otherwise you'll be plagued by this.

Changing the registry setting is more of a nuclear option, so I recommend against using it unless you don't know what interface windows thinks has a captive portal. What you can try is disabling each network interface one at a time (including software interfaces, like tunnel or VPN interfaces.) Open the change network adapter settings applet (right-click the network icon in your systray, click view network connections, click change adapter settings) then try disabling those one at a time by right-clicking on the adapter icon and clicking disable.

Sure it is a 'nuclear' option but maybe that's what you want for a s**t feature like this. I don't have auto connect enabled, but manually disconnecting WiFi feels like dialing in and out on a 56k modem back in the days, nobody does that when you just leave work/airport and shut your computer - typically a notebook - down and leave the place.

On the other hand: Might be a loss of comfort for inexperienced user on airports,  but typically you would open a browser, hit your start page and get redirected in 99% of the cases where you connect to such networks anyways, so I don't see any downside of muting the behavior down via registry.

It's highly intrusive and the fact that even Microsoft support gets fooled by it tells me this is just bad design.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In the case of wifi, this can be fixed by simply disconnecting from the wireless network that has the captive portal. I'd also recommend unchecking the automatically connect option for any wifi network that has a captive portal, otherwise you'll be plagued by this.

Changing the registry setting is more of a nuclear option, so I recommend against using it unless you don't know what interface windows thinks has a captive portal. What you can try is disabling each network interface one at a time (including software interfaces, like tunnel or VPN interfaces.) Open the change network adapter settings applet (right-click the network icon in your systray, click view network connections, click change adapter settings) then try disabling those one at a time by right-clicking on the adapter icon and clicking disable.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.