South Africa's region settings are wrong. How can I report this?

The decimal symbol (for numbers and currency) should be a period, not a comma. This causes an astonishing number of problems for South Africans - for example, if you try to create a CSV file in Excel, it uses semi-colon as the separator, which doesn't work with anything. It breaks integration with a lot of software and is causing a great deal of confusion.

I know this is a simple thing for me to change, but Microsoft need to fix this for the entire country.

 

Question Info


Last updated September 20, 2018 Views 1,427 Applies to:

Hi Gary,

Thank you for posting in Microsoft Community, we appreciate your interest in Windows 10.

Please do let us know with the following to understand the issue and assist you better:

  1. What is the make and model of your device?
  2. Are you referring to keyboard language?
  3. Where exactly are you trying to type?
  4. Have you tried using On-Screen keyboard/ external keyboard and check if the issue persists?
  5. Have you made any changes prior to this issue?

Reply to the post with required information and brief description about the issue, we will be happy to assist you better.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1. This applies to every desktop PC running Windows 10 in South Africa. It is not device specific.

2. No. I am referring to number and currency formats. These are found here:

Control Panel > Clock, Language and Region > Change date, time or number formats > Additional settings > Numbers > Decimal symbol

Control Panel > Clock, Language and Region > Change date, time or number formats > Additional settings > Numbers > List separator

Control Panel > Clock, Language and Region > Change date, time or number formats > Additional settings > Currency > Decimal symbol

3. The problem is not related to typing.

4. Not applicable.

5. No.

The system default settings for South Africa are wrong and need to be fixed. The default setting is that the decimal symbol is a comma and the list separator is a semicolon. This is wrong. The decimal symbol should be a period and the list separator should be a comma.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is indeed incorrect - the regional settings for South Africa changed with Windows 10.  This is all regional settings as described as per above.  It's not a problem with hardware, the regional settings within the Windows 10 software have changed and are incorrect.

We cannot roll out Windows 10 to our Enterprise if the regional settings are incorrect.

Please advise if this will be changed back to how it was with all previous versions of Windows with an future update?

Thanks

Regards

Roelie

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is there anyway to temporarily change these values until Microsoft one day wakes up to the needs of the users in South Africa? Maybe they think there's so few people in SA who use Windows 10, that this just isn't a priority to them?
Jacques Raubenheimer
http://insight.trueinsight.za.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, I have answered my own question. Even though the lists do not show the correct values, they can be typed in manually.

I have summarised the process here:

http://insight.trueinsight.za.com/correcting-the-windows-10-number-formatting-settings-for-the-south-african-region/

Jacques Raubenheimer
http://insight.trueinsight.za.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well-written software should take the PC's regional settings into account when creating text versions of numbers.   That means, as long as a text version of a number stays on the same PC (or same logged-on user) it should all be OK.

For years though, we (South Africans and computer users?) have been using the "international" '.' decimal separator and ',' list separator.   To suddenly find (be reminded) that the South African standard is a ',' decimal separator (in numbers and currency) is a bit of a shock.   This has caused problems as a result of lazy program writing (e.g. bank statement downloads, and a lot of my own software!)

There is a good investigation into what is correct at

http://www.sadev.co.za/content/how-correctly-format-currency-south-africa

Andrew

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.