Screensaver and Sleep Mode not Working with Game Controllers Connected

I did not have this problem before upgrading to Win 10 from Win 7.

I have Saitek Rudder Pedals, a CH Fighterstick and CH Throttle connected to my computer, with any or all these devices connected the screen saver does not start and the computer never goes into sleep mode.  When all the controllers are disconnected from the computer the screen save works and the computer goes into sleep mode.

As a work around for this problem I have connected the game controllers to the computer through a USB hub and disconnect the hub when I do not need the game controllers.  While this solution is acceptable in the short term I feel a 'fix' is required that will allow my computer to operate normally with the game controllers connected.

Thanks,

Neil

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hey

As you guys said this affects all using the HID Compliant Game Controller. If it is connected and enabled Windows 10 will not suspend. So please leave a feedback and hopefully Microsoft would fix this bug. So I suggest all of you guys to leave a feedback.

Thanks.

Unemployed: Involuntarily leisured

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Ramesh,

I have the same issue as others here on Windows 10, and the problem does seem to be that any USB device using the driver 'HID-compliant game controller', dated 21/06/2006, version 10.0.10240.16384, provided by Microsoft stops the power options from working.

After spending months pulling my hair out trying to understand why my Windows 10 desktop won't ever go to sleep, I tried disconnecting all USB devices apart from the keyboard, and plugging them back in one by one, while testing the monitor off and system sleep on 1 & 2 minutes respectively, and found that devices using that driver were the problem.

These devices include my Mayflash Dolphin Bar, and also my Microsoft XBox controller for Windows!

I second what the others have said; it is extremely annoying to have to disconnect my devices to make the power plans work in Windows 10.

Can you advise if this driver will be updated to resolve the issue?

Regards,

p1X

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

was this ever resolved?

i've just had to buy a USB hub and connect all my game controller devices to it so i can switch it off, thus allowing windows to sleep. 

insanely annoying and inconvenient. 

how hard can it be for a patch to tell windows to allow sleep even if game controllers are plugged in?

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Oh,

I have the exact inverse problem on W10 Pro with my HID joystick (Thrustmaster T-Flight Stick X V4) ...

my monitor goes to sleep after 10 minutes during game (windowed or full screen) I have to manually change the power settings before launching the game ... or to move the mouse before it occurs.

very annoying

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same problem, but it only started with the Creator's update for Win 10. My X52 Pro keeps the monitors awake while plugged in. It used to work fine before the update though.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same problem here. Was fine prior to the Creator's Update for Win 10. TM Warthog and/or pedals connected.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same issue as everyone has previously mentioned.  The HID compliant device that is preventing my Win10 machine from sleeping is the PS4 Dual Shock controller.  

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same problem here and this issue is still not fixed and it is now 2018. Problem is Logitech 3D Extreme Pro Joystick on Windows 10 version 1709. Please MS come with the solution for this issue with the HID devices. Best regards, d.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Having the same problem with Saitek X56.

Seems M$ is asleep at the wheel.....after 3 years. O.o

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I just recognized that the same problem is now persistant also for Windows 7. Definetely some general update made a mess and brought that problem back again.

best, d.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated December 3, 2020 Views 9,214 Applies to: