Screensaver and Sleep Mode not Working with Game Controllers Connected

I did not have this problem before upgrading to Win 10 from Win 7.

I have Saitek Rudder Pedals, a CH Fighterstick and CH Throttle connected to my computer, with any or all these devices connected the screen saver does not start and the computer never goes into sleep mode.  When all the controllers are disconnected from the computer the screen save works and the computer goes into sleep mode.

As a work around for this problem I have connected the game controllers to the computer through a USB hub and disconnect the hub when I do not need the game controllers.  While this solution is acceptable in the short term I feel a 'fix' is required that will allow my computer to operate normally with the game controllers connected.

Thanks,

Neil

 

Question Info


Last updated September 25, 2019 Views 4,609 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

Thank you for posting your query on Microsoft Community and for being a part of Windows 10 family. 

 

As per the issue description your computer doesn't go to sleep mode if game controllers are connected to the computer. This could be an issue with the corrupt power plan settings. This issue might also occur due to outdated display driver or some other devices are responsible to keep it awake.

   

Try the below mentioned methods and see if it works for you.

Method 1

Try to run Power Troubleshooter which is built troubleshooter and you may follow the steps mentioned below to run it.

  1. Press the Windows key and X at the same time.
  2. Now click on Control panel.
  3. In the search box of Control Panel type Troubleshooter, and select troubleshooting among the list.
  4. Under System and Security, click Improve power usage.
  5. Now try to run the troubleshooter and check if it helps.

Note: If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

Method 2

If issue persists I would suggest you to Reset and restore the power plans to default.

  1. Press Windows key and X at the same time.
  2. Choose Command Prompt (Admin) from the context menu.
  3. In the command prompt, type powercfg –restoredefaultschemes and hit Enter.
  4. Exit command prompt.

Note: This would reset the power plan settings to default. Any customized power plans would be removed.

Method 3:
If that does not help, delete the power plan and create a new power plan and check.

Please follow these steps to change the power plans:

a) Press Windows Key +X key together.
b) Select Control Panel. Select Power Option.
c) From the left hand side panel select Create a Power Plan.

You can refer to the following link.

Power plans: Frequently asked questions

http://windows.microsoft.com/is-is/windows-8/power-plans-faq

 

Note: The article is for Windows 8/8.1 but steps holds good for Windows 10 too.

 
Method 4 

The issue could also be related to the Display drivers and other updates. I want to inform you that updates will be released by Microsoft. So, I would suggest you to keep checking your Windows updates not only important one but optional too. If any available try to install them and see if it helps you to fix the issue.

 

First try to install all of the Windows updates available and if issue persists, try to update the Display drivers by following the steps provided in the article mentioned below.

 

How to: Install and Update drivers in Windows 10

  

If issue still persists, then install the drivers for Windows 8/8.1 from the manufacturer's website in compatibility mode and check if that works.

Make older programs compatible with this version of Windows
http://windows.microsoft.com/en-in/windows-8/older-programs-compatible-version-windows

 

Reference:  

http://windows.microsoft.com/en-us/windows/network-connection-problem-help#network-problems=windows-81&v1h=win81tab5&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

 

Hope this would help. If issue still persists post back with current status of your computer and result of the proposed suggestion, we will be happy to assist you.

 

Regards,

Ramesh Kumar.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Method 1

I don't have an option to "Improve power usage".  I clicked power and the power trouble shooter started, it indicated that I had screen saver enabled and it thought it was a problem, I am a bit confused by this.  I also ran the trouble shooter with the game controllers connected - same result.

Method 2

"powercfg –restoredefaultschemes" is not a valid command so I couldn't complete this step.  I used powercfg /list, I have Balanced, High Performance and Power Saver, it is set to Balanced.

Method 3

Made a new power plan.  As before power plan works when joysticks are disconnected does not work when joysticks are connected.

Method 4

I'll work on this but but am mystified as to how video drivers are effecting how my joysticks prevent my computer from going to sleep.  When my joysticks are disconnected the same video drivers allow my computer to go to sleep. 

You wrote this "This issue might also occur due to outdated display driver or some other devices are responsible to keep it awake." Just a thought maybe the other devices are the joysticks and this is where I need help.

Edit:

Just installed the latest nvidia video drivers (355.60) - no change system will go to sleep when joysticks are disconnected will not sleep with joysticks connected.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Neil,

Thanks for your reply.

What is the make and model of the computer?

This issue seems to be due to drivers, I suggest you to install all the pending Windows Updates and also download and install the latest Chipset drivers for the computer.

Also, download and install the latest drivers and software’s for your devices from the manufacturer website if any are available.

Hope this information is helpful. Please do let us know if you need further assistance, we’ll be glad to assist you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

All my joystick and chipset drivers are up to date, there were no pending updates for the computer.  While trying to troubleshoot the problem I had hard disc error that messed things up to the point I had to do a clean install.  I tried Win 10 but even cleanly installed I am getting the same error.  Decided to go back to Win 7, am in the middle of a clean install, means lots of reloading software but in the long run I feel it is the only solution.

So I suppose you could say the problem has been resolved.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'd like to mention I am having similar issues with my rudder pedals.  It appears that the inputs from the pedals/joysticks/game controllers are being used to keep the system awake.  For the rudder pedals the toe brakes are analog and it's enough to keep Windows from going to sleep as it is getting constant input from the pedals.  This behaviour can be replicated with joysticks or game controllers that are sensitive enough that there's movement outside the deadzone.  

The solution here would be for Microsoft to cause motion inputs (analog or axis) from keeping the PC awake.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Could someone from MS please post here when they come up with a resolution to this problem so that I can install Win 10.

Thanks,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There is nothing wrong with anybody's power settings.  I was pulling my hair out due to this problem as well.  It is any device that is recognized as "HID Compliant Game Controller", if it is connected and enabled Windows 10 will not suspend no matter what.  In my case, it's my Thrustmaster HOTAS Warthog flight stick and throttle set.  It's extra annoying because the USB cables are plugged into my desktop on the floor under my desk.

I'm just not willing to be constantly unplugging these things under there, so either I have to remember to shut down or suspend this PC manually every time I'm done with it or I have to dig out a hub, connect them to the hub, and connect and disconnect the hub whenever I feel like using these controllers.

Alternatively I may write a system tray app that will give me a one click solution to enabling and disabling all HID Compliant Game Controllers in the system.  If I do write this, I'll try to remember to post back and share that utility in case anybody else would find that useful until this problem gets sorted on MS end.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

How has this not been fixed yet?  This has been such a major PITA that it has actually cut back on the amount of gaming I do because of the hassle.

For some of the games I play, I've used a combination of AHK(AutoHotKey) to capture certain joystick buttons to perform "macro" tasks, etc.  The problem is that it relies on Windows Joystick ID assignment.  Of course, every time you unplug, disable a device, and/or restart, there's a chance that this order can get screwed up and all those AHK scripts can go out of whack.  The only way to ensure this doesn't happen is to keep them plugged in and enabled all the time, but then you have to manually put the computer to sleep.  But oh wait, the computer doesn't want to stay asleep with the joysticks connected.  I've tried every power option/config setting(everything you could possibly suggest to me so don't, and I've easily spent about 20 hours total troubleshooting this), it doesn't work.  So the only other option is to shut down the computer every time I'm not using it for more than like 20-30 min.  I really don't want to hear those idiots tell me to just leave the computer running all the time because I guess they really don't have any idea or care how much power a computer like mine uses even at idle.  It adds up!

MS - get your head out of your...

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is also an issue on my computer, it will not activate the screen saver, turn off the monitor, or sleep if either my Saitek X52 Pro HOTAS or Crosswind MFG pedals are connected. Works fine if both are disconnected.

From what I've read on different forums this seems to be a problem with every game controller in Windows 10 so it isn't a problem with anything the MS Support Engineer suggested, but a problem with Windows 10 itself. I had no similar problems with Windows 7.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

+1 for this on my X55.

I agree with KCH42, having to get on the floor and reach around the back to plug in 2 USB cables every time I want to use my joystick and throttle seriously reduces the amount of time I spend using them.

It is clear from many online threads this affects all using the HID Compliant Game Controller. Can't believe this is still a problem and that "MS" are still replying with such generic, useless troubleshooting suggestions. It's almost like they are not in fact experts in the products they are supporting and do not follow any of the online forums etc. where these things are discussed.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.