Runtime Broker high CPU usage

This has become quite a long thread so I'll try to summarize it:

Issue:

A process called Runtime Broker has a high CPU usage in Windows 10 (final release version).

Cause:

Unknown, there seem to be multiple causes and multiple solutions. May be related to OneDrive, permissions for metro apps, Background Task Infrastructure Service, Windows spotlight thingy, windows tips and a number of other apps.

Solutions thar work for some:

  • Registry hack: run regedit.exe, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker, change "Start"=dword:00000003 to dword:00000004. This will affect parts of Cortana, like new apps not showing up and you can't set reminders.
  • Switch your lock screen background (Settings -> Personalization -> Lock Screen) from Windows Spotlight to Picture. Preferably but not necessarily a picture of a ninja cat on a dinosaur ;-) Additionally disable the live tile of your photo app by right clicking on it.
  • Settings -> System -> Notifications & actions -> Disable "Show me tips about Windows"
  • Disable (at least to test) the P2P sharing in all settings>update>advanced>chose how updates are delivered. Set "updates from more than one place" to off.

If these don't work, your odds of finding a fix have dropped considerably, but you could try:

  • Try disable background Apps:  go to "Start->Settings ->Privacy -> Background Apps" and Turn-off those apps.
  • Deleted Groove music using powershell. Used these commands: Get-AppxPackage -name "Microsoft.ZuneMusic" | Remove-AppxPackage     Get-AppxPackage -name "Microsoft.Music.Preview" | Remove-AppxPackage    (To bring up powershell, press win+r and type powershell. Hit enter, copy and paste one at a time).
  • Disable/delete OneDrive / SkyDrive
  • Disable Google Drive if you use it
  • Remove .Net 3.5
  • Remove any external drives / NAS locations from your Photos and Music libraries 
  • Close all programs and restart them one by one to try to find the culprit, uninstall the culprit. Yes, we're in the desperate stage.
  • Do a full refresh of Windows 10. But note: many people have the problem persist, even after a vanilla install of Windows 10.
  • Send MS an angry e-mail. Wait for them not to respond. Throw a brick through the Windows(R) of your local MS office. Won't fix the problem, will fix your frustration for a while.

Thanks to everyone who posted a solution i incorporated in this post. Please let us know if any of these fixes worked for you.

If none of that works for you

See instructions below by ZigZag3143 to create a report. Please create a new thread with your report and e-mail ZigZag by using the link to the thread on his profile. Do not e-mail the trace.

Edit: i went through the thread a few times to aggregate plausible solutions in this post. Latest was 14-8. Also, i removed the comment that after resetting the registry hack, the issue was still fixed for me. Turns out I had misnamed my registry files. After resetting the registry the issue came back after all.

original post:

I have just upgraded my pc to Windows 10. After install, I reset it to get a fresh clean installation. That made a huge difference in responsiveness of the start menu, which before used to take 20-30 seconds to open. However, now a process called Runtime Broker is taking up 20-40% of my CPU. I googled that this app is about permissions for metro apps or whatever they're called. I've found several threads about either high memory usage or antivirus, but I don't have any antivirus installed except windows defender and Runtime Broker only uses a few MB of memory. But it does hog my CPU. I did try manually ending it with the End Task button, but then it restarts within seconds and keeps hogging my CPU.

For now i applied a registry hack. Changed [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003 to dword:00000004. While that stops the process from hogging my cpu, i have no idea what i've done and what the consequences are.

Specs:

- Windows 10 build 10240, pro with all updates installed, upgraded from a genuine 8.1 pro.

- No additional Metro apps installed. I tried uninstalling a bunch of them but they just get reinstalled

- Computer: Samsung Ativ Pro convertible XE700T1C, multiboot with Windows 8.1 home oem that came with it (so two genuine licences on different partitions on one system)

Please help me! What can i do to get this properly fixed based on understanding the cause of the problem rather than random registry hacks.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I also have this problem. I used the band-aid registry fix for now. No problems so far. I also get 4x Service Control Manager error 7031 and 2x DistributedCOM 10010 errors whenever I shut down. Anyone else get these or know if there's any relation? I also get an error sound when I log in. Are these symptoms or unrelated?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I noticed that with the registry hack, Cortana can't set reminders.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is what fixed it for me.

Go to Settings -> System -> Notifications -> Disable "Show Windows Tips"

72 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is what fixed it for me.

Go to Settings -> System -> Notifications -> Disable "Show Windows Tips"

YES! This worked, at least for now!

Thank you so much!

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I noticed that with the registry hack, Cortana can't set reminders.

For me, uninstalling the 'Microsoft .NET framework 3.5 (include .NET 2.0 and 3.0)' feature seems to have tamed the beast. I've since set the registry (hack) back to it's original value (DWord '3'); Cortana is happy again. I did also turn off "Windows Tips" notifications. Everything else including live tiles, etc. is back to what was in place before.

What I still experience... Runtime Broker jumps to 48-60% CPU when I open the Photos app, still apparently trying to process everything it finds in my pictures library, which is still very frustrating. Upon closing the Photos app, the Runtime Broker process continues to burn for a few more minutes but then settles back down to 0%.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

... almost going out of my mind with this damn runtime broker using 20-30 % cpu... so I ended up with this powershell-script... as a "solution"... Haven't had any side effects off of it yet:

Filename: kill_broker.ps1

Contents:

------Cut here--------

while ($true) {
 stop-process -processname runtime*broker
start-sleep 2
}

------To here ----------

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Found the problem. At least I think I did...anyway! Runtime broker uses 0%cpu 3.5mb memory 0%disk until Windows Backround Spotlight (Something like that) opens. This causes runtime broker to use 20% of my cpu and about 80mb memory. What is that process? Can someone find a fix for it? Already tried registry trick and disabling windows using my pc to deliver updates through internet using my bandwith. 

Great job!

You nailed it!

With task manager open and runtime broker at ~14% CPU, I switched my lock screen background (Settings -> Personalization -> Lock Screen) from Windows Spotlight to Picture, and voila... CPU went to 0%!

Switched it back and runtime broker shot right up!

I think I'll survive with switching my pic manually when I get bored...

Kudos to all who chimed in here, especially SavvasS.

Me too! My RuntimeBroker was constantly at 15-20% of CPU, but after choosing picture instead of Windows Spotlight it's back to 0 (zero).

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is what fixed it for me.

Go to Settings -> System -> Notifications -> Disable "Show Windows Tips"

it work for me

thanks a lot 

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Excellent find!

This has worked for me as well.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I was go back to win 7..

Love win 10 but, too many bugs..

I think that all this will not be fixed until some 6-7 months..

I was experience  high cpu everywhere, from 20-50%, when i use search box in settings, when i use store, also broker service has high cpu (but i disabled this), this is not what cause all problems ..

I faced with others: when i use cortana it somethimes just closes itself, when i try to install something  (adobe reader ex.), then windows defender starts to use cpu -30%, and it wont stop untill i restart comp ..

I can't even disable windows defender!

Also it seems that window position doesn't remembered, all windows opens in random position..

Too many bugs, and high cpu usage everywhere. Why?.. No thanks!

I will wait that microsoft fix this, or i will not use this product...

My comp. specifications is quite good, i don't need this..

I am disappointed :(

Will microsoft give as some answer?

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated February 23, 2021 Views 156,569 Applies to: