Runtime Broker high CPU usage

This has become quite a long thread so I'll try to summarize it:

Issue:

A process called Runtime Broker has a high CPU usage in Windows 10 (final release version).

Cause:

Unknown, there seem to be multiple causes and multiple solutions. May be related to OneDrive, permissions for metro apps, Background Task Infrastructure Service, Windows spotlight thingy, windows tips and a number of other apps.

Solutions thar work for some:

  • Registry hack: run regedit.exe, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker, change "Start"=dword:00000003 to dword:00000004. This will affect parts of Cortana, like new apps not showing up and you can't set reminders.
  • Switch your lock screen background (Settings -> Personalization -> Lock Screen) from Windows Spotlight to Picture. Preferably but not necessarily a picture of a ninja cat on a dinosaur ;-) Additionally disable the live tile of your photo app by right clicking on it.
  • Settings -> System -> Notifications & actions -> Disable "Show me tips about Windows"
  • Disable (at least to test) the P2P sharing in all settings>update>advanced>chose how updates are delivered. Set "updates from more than one place" to off.

If these don't work, your odds of finding a fix have dropped considerably, but you could try:

  • Try disable background Apps:  go to "Start->Settings ->Privacy -> Background Apps" and Turn-off those apps.
  • Deleted Groove music using powershell. Used these commands: Get-AppxPackage -name "Microsoft.ZuneMusic" | Remove-AppxPackage     Get-AppxPackage -name "Microsoft.Music.Preview" | Remove-AppxPackage    (To bring up powershell, press win+r and type powershell. Hit enter, copy and paste one at a time).
  • Disable/delete OneDrive / SkyDrive
  • Disable Google Drive if you use it
  • Remove .Net 3.5
  • Remove any external drives / NAS locations from your Photos and Music libraries 
  • Close all programs and restart them one by one to try to find the culprit, uninstall the culprit. Yes, we're in the desperate stage.
  • Do a full refresh of Windows 10. But note: many people have the problem persist, even after a vanilla install of Windows 10.
  • Send MS an angry e-mail. Wait for them not to respond. Throw a brick through the Windows(R) of your local MS office. Won't fix the problem, will fix your frustration for a while.

Thanks to everyone who posted a solution i incorporated in this post. Please let us know if any of these fixes worked for you.

If none of that works for you

See instructions below by ZigZag3143 to create a report. Please create a new thread with your report and e-mail ZigZag by using the link to the thread on his profile. Do not e-mail the trace.

Edit: i went through the thread a few times to aggregate plausible solutions in this post. Latest was 14-8. Also, i removed the comment that after resetting the registry hack, the issue was still fixed for me. Turns out I had misnamed my registry files. After resetting the registry the issue came back after all.

original post:

I have just upgraded my pc to Windows 10. After install, I reset it to get a fresh clean installation. That made a huge difference in responsiveness of the start menu, which before used to take 20-30 seconds to open. However, now a process called Runtime Broker is taking up 20-40% of my CPU. I googled that this app is about permissions for metro apps or whatever they're called. I've found several threads about either high memory usage or antivirus, but I don't have any antivirus installed except windows defender and Runtime Broker only uses a few MB of memory. But it does hog my CPU. I did try manually ending it with the End Task button, but then it restarts within seconds and keeps hogging my CPU.

For now i applied a registry hack. Changed [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003 to dword:00000004. While that stops the process from hogging my cpu, i have no idea what i've done and what the consequences are.

Specs:

- Windows 10 build 10240, pro with all updates installed, upgraded from a genuine 8.1 pro.

- No additional Metro apps installed. I tried uninstalling a bunch of them but they just get reinstalled

- Computer: Samsung Ativ Pro convertible XE700T1C, multiboot with Windows 8.1 home oem that came with it (so two genuine licences on different partitions on one system)

Please help me! What can i do to get this properly fixed based on understanding the cause of the problem rather than random registry hacks.

 

Question Info


Last updated December 5, 2018 Views 126,761 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

For a possible solution check this post

http://answers.microsoft.com/message/be5ef38b-2681-4fcd-ac81-edf3f9be40ce?threadId=4302a4dd-44c1-474e-8e6a-3c00889c65a7

First it is local to your environment.  Runtime broker is using 6Mb here

In order to diagnose your problem we need to run Windows performance toolkit the instructions for which can be found in this wiki


If you have any questions feel free to ask

Please run the trace when you are experiencing the problem

You can email me the link to the thread by using the email on my profile page.  DO NOT email the trace.


Cat herder
Windows Insider MVP
MVP-Windows and Devices for IT
http://www.zigzag3143.com/

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

First it is local to your environment.  Runtime broker is using 6Mb here

In order to diagnose your problem we need to run Windows performance toolkit the instructions for which can be found in this wiki


If you have any questions feel free to ask

Please run the trace when you are experiencing the problem

Thank you for the very rapid reply. Since i'm going on a holiday trip tomorrow i wanted it fixed so my battery won't insta-drain. I tried a registry hack i found for Win8.1 and that worked. I edited it into my first post, not expecting such a rapid response. Apparently a registry edit to disable the TimeBroker ( TimeBrokerServer.dll ) service fixes the cpu drain. Well, Runtime Broker still keeps using ~1% cpu but i guess that's normal?

Will the ADK provide additional useful info? I feel i haven't really fixed it because who knows what functionality i broke by disabling this service. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm very interested in the solution as well.  I started to download the ADK, but it said it needed 6GB of space!  Is that for real?  And it also says it's for Win 8.1, will it work for Windows 10?

I'm in the same boat, ever since my upgrade, the Runtime Broker has been running at about 40% of my CPU on a Surface Pro 3.  I did the retail update this morning through Windows Update.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Runtime broker handles start menu apps/store/etc.  WPR will probably tell you what is causing it or at least point towards where to look.
Cat herder
Windows Insider MVP
MVP-Windows and Devices for IT
http://www.zigzag3143.com/

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You do not need the entire ADK (as it says in the wiki).  The bits you need are about 200 Mb
Cat herder
Windows Insider MVP
MVP-Windows and Devices for IT
http://www.zigzag3143.com/

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have this exact problem as well. Whenever the Time Broker service starts running, CPU usage for RuntimeBroker.exe jumps to about 40-50% from an idle 3-7%. It doesn't stop until I forcibly end the process in Resource Monitor, and the service can only be permanently disabled through the above-mentioned registry edit.

Here's what it looks like when it's running on my system:

Note the ridiculous number of recently started/terminated backgroundTaskHost instances. It just keeps creating these nonstop, and each one terminates almost as soon as it begins.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I solved this by doing a full refresh.  Once I went through and had a vanilla Windows 10, whatever app was having trouble ceased to exist, and the CPU stopped spiking.  I am in the process of adding apps to see if I can isolate the misbehaving one.

I have a guess that it's related to the removed functionality from OneDrive.  I had a lot of apps that sourced OneDrive on the local computer for data, but in Windows 10, you don't get a list of all your OneDrive data, only your locally synched data (which is dumb, what's the point of OneDrive if I can't see all my online files?).  So there was a whole lot of folders my apps could no longer see, even though they had stored their stuff there.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having a similar problem with constant  8% cpu utilization from Runtime Broker since upgrading to Windows 10 yesterday. I hope I created the ETL correctly and moved it to my onedrive as a zip file:

https://onedrive.live.com/redir?resid=7EDA945541BEF561!113&authkey=!AJaaRMEoz0VuGTY&ithint=file%2czip

I would appreciate help in determining what is causing the problem.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ach... you say that solved the problem for you? I sure would hate to lose all of my programs...

I'll run the performance toolkit first and see what I can find.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well that certainly is strange. I just went to record the phenomenon, and thought to myself "I should probably close all these unnecessary programs to lighten the load for the recorder." And guess what? RuntimeBroker's nonsense stopped as soon as I closed out OneDrive.

Hopefully it won't return, but if it does, my advice is to close all your background programs (OneDrive, Google Drive, Rainmeter, etc.) and see if the problem evaporates on its own.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.