Right Click crashes Explorer on Windows 10 Pro

Every time I right click at any place on my Windows 10 Pro, Explorer crashes and closes all my Windows Explorer windows. How t fix that?

Thanks!

 

Question Info


Last updated September 18, 2019 Views 12,662 Applies to:
Answer
Answer
The cause for this problem seems to be third party shell extensions. To get rid of culprit extension, you can download ShellExView. ShellExView is a free third-party application that can be used to manage, disable and enable all of the shell extensions that you have on your computer

Download ShellExView - http://www.nirsoft.net/utils/shexview.zip

Extract the zip file

Launch ShellExView by right-clicking on the application named shexview and clicking on Run as administrator

You will be met with a list of all the shell extensions installed on your computer once the program is done compiling it. Once you see the list, click on Options > Filter by Extension Type > Context Menu.

In the newly compiled list, you will see entries that have pink backgrounds. All of these entries are shell extensions installed on your computer by third-party applications.

Hold down the Ctrl key and click on each of the “pink background” entries to select them.

Once all of the “pink background” entries have been selected, right-click on them and click on Disable Selected Items to disable all of them.

Click on Options > Restart Explorer. Try right-clicking on your Desktop, and File Explorer should no longer crash.

Once you have fixed the problem, next comes identifying the culprit and disabling it for good. To do so, you are going to have to:

Right-click on any one of the “pink background” shell extensions that you disabled and click on Enable Selected Items to enable it.

Click on Options > Restart Explorer, right-click on your Desktop and see if File Explorer

If File Explorer does not crash, keep on repeating steps 1 and 2, enabling a different third-party shell extension every time, until File Explorer crashes and you start experiencing the problem again.

The third-party shell extension you enabled just before the problem returned is the culprit. You can go ahead and enable all of the “pink background” shell extensions you disabled except for this one as this one is the culprit. Keep this shell extension disabled for good – in fact, it is recommended that you uninstall the third-party application that installed this shell extension on your computer altogether.

(Source - https://appuals.com/file-explorer-crashing-afte...)
Best regards
Vijay Verma

Timezone: UTC+05:30, PST+12:30
Availability Hours (UTC) : 05:00 AM - 05:00 PM

58 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.