Remote Desktop Connection not workin after Win 10 upgrade

With my upgrade to Window's 10, my RDP's no longer work.  It won't even allow me to begin the log in process.

I immediately get the

"Remote Desktop can't connect the remote computer for one of these reasons:

         1) Remote access to server is not enabled

         2) The remote computer is turned off

         3)  The remote computer is not available on the network

Make sure the remote commuter's turned on and connected to the network, and the remote access is enabled."

I have checked my PC Settings and remote controlled is checked. 

It worked just fine on W8.1 and I need it working on Win 10 as well.

Any help would be much appreciated.

Matt

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Matt,

Thank you for being part of Windows 10.

Here are some possible solutions to common problems you might encounter when trying to connect to a remote PC.

The remote PC can’t be found. If you see this error, talk to the system admin of the remote PC to make sure you have the right PC name, and then check to see if you entered the name correctly. If you still can't connect, try entering the IP address of the remote PC instead of the PC name.

  • There’s a problem with the network. Make sure that:

    • Your router is turned on (home networks only).

    • The Ethernet cable is plugged into your network adapter (wired networks only).

    • Your PC’s wireless switch is turned on (laptops on wireless networks only).

    • Your network adapter is working.

    Do get back to us for any issues pertaining to Windows in the future. We will be happy to help.

  • 10 people were helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Hi Matt,

    Thank you for being part of Windows 10.

    Here are some possible solutions to common problems you might encounter when trying to connect to a remote PC.

    The remote PC can’t be found. If you see this error, talk to the system admin of the remote PC to make sure you have the right PC name, and then check to see if you entered the name correctly. If you still can't connect, try entering the IP address of the remote PC instead of the PC name.

  • There’s a problem with the network. Make sure that:

    • Your router is turned on (home networks only).

    • The Ethernet cable is plugged into your network adapter (wired networks only).

    • Your PC’s wireless switch is turned on (laptops on wireless networks only).

    • Your network adapter is working.

    Do get back to us for any issues pertaining to Windows in the future. We will be happy to help.

  • Hey I have another angle to add to this issue!

    My setup is as follows -

    two computers both connected to the same router (pre-upgrade RDP was still successful - even to the point where one machine running the windows 10 was still accessing the other windows 7 pro machine). Post second machine upgrade to windows 10 pro (both machines are windows 10 pro) neither are able to connect to each other.

    Router/network is there and setup I'm able to access the login screen but the login credentials come back as invalid - 

    both networks ARE set to private (not public) 

    credentials are up to date and correct (PC name / login password)

    I can't seem to figure it out but I am going to keep trying. Is there a local file that needs to be deleted/forgotten before I try and establish a new connection?

    oh and I should also add that I do NOT save login credentials I re-enter every time.

    Any thoughts / guesses would be appreciated

    9 people were helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Thank you Jessen P but as I stated I have checked to verify that the Remote Control access is enabled.  This seems to be my issue.  Although it is checked as Enabled,  it won't even open for me to attempt to connect. 

    So,  I am not receiving the Remote PC Can't Be Found  error nor am I receiving There's A Problem With Your Network error. 

    Prior to Windows 10 upgrade,  I could click on my RDP icon and it would open (showing the IP Address it would connect to)  and I would click Connect and then enter my credentials.

    Now,  I click on my RDP icon and immediately get the Can't Connect error I previously posted.  After the upgrade it acts as if it is not enabled although it shows that it is.

    Any ideas???

    Thank you,  Matt  

    1 person was helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Hi Matt,

    Please try to do the following checks and see if this is helping:

    1. Please check if the Windows 10 computer is accepting RDP requests from other network computers. You need to ensure that you are accepting requests from all devices, not just from the ones that know about Network Level Authentication.

    For this, please right-click on This PC, click on Properties. From the System window that is opening, please press on the Remote Settings link, from the left part of the page.

    On the System Properties window, Remote tab, select the Allow remote connections to this computer (you mentioned that this is already selected), but also uncheck the Allow connections only from computers running Remote Desktop with Network Level Authentication (recommended) check-box.

    2. Please ensure that you are connecting to the correct PC name (or IP address) the Windows 10 computer has at this point.

    a. For this please connect to the Windows 10 computer and:

    • right-click on This PC and click on Properties. From the System window that is opening, please check the value listed on the Computer name field.

    or

    • right-click on the Start button and press Run. On the Run window please type cmd and press OK. In the new Command prompt window that is opening, please type ipconfig and press Enter. Please check what IP address is assigned to the network adapter that you know it is connected (Wired or Wireless).

    b. On the computer from where you want to connect to the Windows 10 machine, please:

    • press the Start button and type mstsc and open the Remote Desktop Connection application. In the Computer name field, please type the Computer name (or IP address) of the Windows 10 machine (that you get at point 2.a.) and press Connect.

    or

    • right-click on the .rdp file (that you mentioned you have on the desktop of the computer from which you wanted to connect to Windows 10 machine) and press Edit. Please ensure that in the Computer name field is typed the Computer name (or IP Address) of the Windows 10 machine (that you get at point 2.a.). Ensure that the User name field is empty or you have a correct user typed in and press Connect.

    When you'll be asked to type the credentials, please type credentials for an user that is member of Administrators (or at least Remote Desktop Users) group on the Windows 10 machine.

    Kind regards,

    Cristian.

    10 people were helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    I'm just throwing this out there as a possibility, since it resolved my problem.  I was trying to connect to the Windows 10 Remote Desktop Server using a very old RDP client on a Windows Mobile 6.5 phone (don't laugh...).  This worked with no error on Windows 8.1, but the connection was rejected on Windows 10.  I had to do the following to get it to work:

    1. Open a Run dialog using Win-R.  Type "gpedit.msc" and hit Enter.
    2. On the left tree view, click on Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Security
    3. Double-click on the "Require use of specific security layer for remote (RDP) connections" setting on the right.
    4. Select the "Enabled" radio button
    5. Select "Negotiate" from the "Security Layer" drop-down and click OK.

    After doing this, I was able to connect to my Windows 10 Remote Desktop Server with no issues.  I hope this helps (you or someone else).  Thanks.

    -JNP

    31 people were helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Thank you Cristian but still not working.  I also do not have the box to uncheck  the Allow connections only from computers running Remote Desktop with Network Level Authentication (recommended) check-box.  See the picture below:

    Here's a thought:  the remote server I'm connecting to a few states away is running Windows Server 2008 R2.  Could this be the problem?  Windows 8.1 is compatible but Win 10 is not yet compatible?

    Matt

    1 person was helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Matt,

         Christian may be able to give you a better answer, but based on the information in your last message I think the problem is likely with the configuration of the Windows 2008 R2 Server, your firewall, and/or the network rather than with your Win10 machine.  I think I had it backwards (I didn't read your post carefully), as I assumed that you were trying to configure your Win10 computer to accept incoming RDP connections (which Win10 Home cannot do) rather than use the RDP client in Win10 to connect to a remote server (which Win10 Home  should be able to do).

         There should be no difference in your ability to connect to the Windows 2008 R2 Server using the RDP client in Win8.1 Home or the RDP client in Win10 Home (I have a Win2008 R2 server on my home network that I can connect to fine from both Win 8.1 and Win10).  However, the Windows 2008 R2 Server must be configured to accept connections from the account you are using to connect.  If you have control over the configuration of the Windows 2008 R2 Server, you can add an account to the allowed Remote Desktop Users as shown below (or alternately, you can just select "Allow connections from computers running any version of Remote Desktop (less secure)"):

    Christian described how to get to this dialog in his pervious post:

    "For this, please right-click on This PC, click on Properties. From the System window that is opening, please press on the Remote Settings link, from the left part of the page.

    On the System Properties window, Remote tab."

         If you do not have control over the Windows 2008 R2 Server, I would try to speak with someone who does (someone in your IT department, a System Administrator, etc.) to try to get them to make the necessary changes.  Also, you may want to confirm that your firewall is not blocking port 3389 (the default RDP port).  I had some issues with this when I first set up my network.  The easiest way to rule out firewall issues is to temporarily disable your firewall entirely and see if the problem goes away.

         I am by no means an expert on setting up remote desktop (I'm more of a hack), but I have a fair amount of practical experience getting it working on my home network.  If the above does not help, let me know soime more details of your situation and I will attempt to help further.  Thanks.

    -JNP

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    Hi Matt,

    Thank you for the details you provided.

    First of all, as also JNP mentioned, we need to understand what exactly you want to achieve, and is not working.

    1. If you want to connect from any PC to your Windows 10 computer, unfortunately this is not possible, as you have Windows 10 Home Edition (as per the printscreens you provided). More details can be found in the Compare Windows 10 Editions article, on Business Experiences tab:

    2. If you want to remotely connect from your Windows 10 PC to another PC (like a Windows 2008 R2 Server), and you cannot do that, it can be a network related issue, or a server issue, that is not accepting the remote request.

    My understanding is that you are in the 1. scenario. But, please let me know if not, and if you'll need further investigation on this.

    Kind regards,

    Cristian

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    My problem is similar. I have 4 computers in a home network. I have one desktop that had Win7Pro and now upgraded to Win10. I can remote desktop into it from two other Win7 machines no problem.

    On my Win8.1 laptop that I just upgraded to Win10, I used to be able to remote into the pro machine but cannot now after the Win10 upgrade. I can't figure it out. Every time I try I get asked for my credentials but the username/password that always worked before doesn't now. I get the error message "Your credentials did not work".

    1 person was helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    For what its worth. I solved problem with help from Microsoft tech on chat. On the Remote-To Win10 machine I had to change my user credentials to my Microsoft Account username/password. Then with both Win10 machines (the RD-to and RD-from) both logged in with my same Microsoft username/password the RD worked.

    When I went back to my Win7 machine, I had to change the RD login to the MicrosoftAccount Username/Password and the RD-to worked. 

    2 people were helped by this reply

    ·

    Did this solve your problem?

    Sorry this didn't help.

    Great! Thanks for marking this as the answer.

    How satisfied are you with this reply?

    Thanks for your feedback, it helps us improve the site.

    How satisfied are you with this response?

    Thanks for your feedback.

    * Please try a lower page number.

    * Please enter only numbers.

    * Please try a lower page number.

    * Please enter only numbers.

     
     

    Question Info


    Last updated October 20, 2020 Views 89,863 Applies to: