Problem with Region settings Win10 CU

In Windows 10 Home (x64)  settings...Time & language...Region & language...Country or region , the default is "Afghanistan", when I change it to "Canada" , it always reverts back to Afghanistan.     How do I resolve this issue?
Answer
Answer

I'm working with a laptop which I had run "Reset this PC" because any new accounts created were not set up correctly e.g. no "Start Menu" plus the region was set to Afghanistan and couldn't be changed in "Settings" and search would not work in Cortana. The "Region" setting In control panel didn't work either.

Anyway a partial success - I opened REGEDIT but was unable to find the GEO key under 

Computer\HKEY_CURRENT_USER\Control Panel\International

So I thought I try and create one but was denied access - "no permissions".

So I right clicked on the key, selected "permissions" ADDED my user ID, "Checked Names", and set the permissions to FULL CONTROL.

Low and behold the GEO key appeared - :) like magic!! - and was set to the UK (242)

However, I needed to sign out and in again before it took effect.

I was then able to open "Region" in the control panel and set it up for UK, keyboard, dates etc.

Update - after the reboot all seems well with Regional settings.

Also, check "Related Settings" and select "Region" and the "Administrative" tab "Copy Settings" and check both boxes at the bottom to make sure new accounts are created correctly"

BEST OF LUCK! cookinpro

I'm still unable to get Cortana to search

Hi George,

I finally figured out how to resolve my issues.

I went to Tweaking.com and installed Windows Repair v 3.9.31 (Free Version)
Under the “Repair” tab (located on the top row) set only these repairs

01-Reset Registry Permissions
02-Reset File Permissions
03-Reset Service Permissions
04-Register System Files
09-Repair Hosts File
10-Remove Policies Set by Infections

Make sure all other repairs are not selected (unless, of course you are positive that they apply to your situation)

Make sure to do a registry backup and also set a restore point (both can be set up within Windows Repair v 3.9.31 (Free Version)- this step is very important

Make sure to run this in Windows “safe mode with networking”

You will be prompted to reboot when the repairs are finished running-(you may have to run the repairs twice)

This fixed : HKEY_CURRENT_ USER\Control Panel\International\Geo (previously, "geo" was not listed) upon rebooting "geo" magically appeared and I was able set the identifier to "Canada"

Also, searches worked in Cortana, the clock works properly, region settings work in Control Panel and Microsoft Store finally works.

38 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 29, 2020 Views 13,562 Applies to: