problem with my intel rapid storage technology

hi all

i was having win 8.1 and i upgraded to win 10 but after upgrading i noticed that the intel rapid storage technology icon  which should appear in the system tray icons isn't appearing i tried to reinstall the driver but keeps telling me "The installation source for this product is not available verify that the source exists and that you can access it "  i tried once and more and this massage keeps appearing pls someone help me

thanks

 

Question Info


Last updated September 7, 2018 Views 5,946 Applies to:

Hi,

Welcome to Microsoft Community and thank you for posting your query. Your interest in Windows 10 is much appreciated. 

This issue might be due to corrupted or missing System files.

I suggest you to perform the below troubleshooting steps and check.

Method 1: Run the SFC.

System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files.

Follow the below steps:

  1. Right click on the Start button, click on Command Prompt (Admin).

  2. Type “sfc /scannow” without quotes and hit Enter.

Now check for the issue.

Method 2: Run the DISM Tool.

If the issue persists, I would have you run the DISM tool to check the system health and will try to restore the files. 

  1. Right click on the Start button, click on Command Prompt (Admin).

  2. In the Administrator: Command Prompt window, type the following commands. Press the Enter key after each command:

  • DISM.exe /Online /Cleanup-image /Scanhealth 

  • DISM.exe /Online /Cleanup-image /Restorehealth

   3.  To close the Administrator: Command Prompt window, type Exit, and then press Enter. 

Note: The tool might take 15-20 minutes to finish running, so please do not cancel it.

 

Method 3: Check if you are able to access the system tray icon using different user account.

Get Started with Windows 10

Hope this information is helpful. Perform the above troubleshooting steps and kindly update the status of the issue, we will be happy to help you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

thanks very much for ur help but unfortunately i tried ur solutions with nothing changed pls tell me if  there is something else i can do

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is exactly what the Windows 10 Th2 upgrade has done to my PC. I (used to) have RST service, with that tray icon. According to my preliminary investigation Windows has removed the RST files, but left the registry entries for it. My guess is the package folder is gone. The tray icon folder is not on disk anymore either, though still mentioned in the registry. Windows has also replaced the drivers that came with RST with some ancient drivers from 2006. Essentially, everything is messed up. RST requires that the RST service, the drivers are all the same versions. You cannot overinstall or repair using another version, you cannot run mismatched versions.

Here's what I've been able to do so far--How to get the drivers back that match your nuked RST software:

1)  First a word of caution: only use the RST version that was installed on your PC and was working before the upgrade(Don't install the latest and greatest drivers/RST software, it will create a mess and make your PC unbootable).
2) Do a full disk image of your entire PC. (Command line works for Windows 7,8 and 10. http://www.howtogeek.com/167984/how-to-create-and-restore-system-image-backups-on-windows-8.1/) In case you make your PC unbootable you can always go back.

3) Check Intel Chipset SATA Raid Controller or Intel-"A bunch of old controller names"-Controller in Storage Controllers in Device Manager-- It's been probably downgraded. This is not the version you want to use. We will update those drivers.

4) Get the RST installer ("SetupRST.exe"), you may already have it in your downloads folder if you're lucky or you can get it off Intel's website.--- Just make sure its version matches the RST software you used to have.

5) Unzip the SetupRST.exe, then unzip the MSI files until you find the "iaStore**.inf" file. Make sure you use the 64bit MSI if your PC is 64bit, and 32 if it's a 32bit PC. Use 7Zip to unzip-- Other unzippers may not do a proper job.
6) Go back to Device Manager. Click on Storage Controllers > Your "Intel Controller" > Driver Tab > Update Driver. Choose "Have Disk" Browse to your "iaStore**.inf" file, select it, and the driver should install. (If you don't have RAID but have the AHCI setup choose "iaAHCI**.inf" instead.)

7) IF the driver fails to install because of the "signing error": 

-Open the Windows command promt as “Run as Administrator”.

-Run “bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS” (without the “”).

-To finalize the process run “bcdedit -set TESTSIGNING ON” (without the “”).

-Reboot and repeat Step 6 again, and reboot.
8) Ok... so you should now have the driver that matches your RST service software. I've got to this point. Now we need to figure out how to fix the "package not found error" so we can run SetupRST.exe and repair the install. I'll update this post, when I do. :)

Update: ...OK, I think I've done it.
9) Open regedit as Administrator. Search for "Rapid Storage Technology".
You should find the key for RST product in the installer folder. It will look something like this.
[HKEY_CLASSES_ROOT\Installer\Products\D04EA5027DA892F44A03DD1286AD65D2--yours may be different]
"ProductName"="Intel(R) Rapid Storage Technology"
"PackageCode"="849CE8AEECEAAF44CA235715D37DD1A1--yours may be different"
Locate the subfolders "SourceList"--key LastUsedSource, "SourceList\Net"-- keys 1 and 2....
There will be various references to the RST package locations...
Since our package is missing, replace all the references with the paths to the install package you've extracted in step 5. For example, change

C:\Users\Pasha\AppData\Local\Temp\IIFB711.tmp\
C:\ProgramData\Intel\Package Cache\{409CB30E-E457-4008-9B1A-ED1B9EA21140}\RST_x64.msi\
to

n;1;C:\Users\Pasha\Downloads\SetupRST_works\

C:\Users\Pasha\Downloads\SetupRST_works\
C:\Users\Pasha\Downloads\SetupRST_works\RST_x64.msi\


There are 3 places where you can change the path.
10) Run SetupRST.exe. and choose "repair". It should repair the installation and your RST service should start right away and ask for a reboot.
11) You will get a blue screen with a driver IRLQ not equal error... and your PC will reboot itself again and boot into Windows 10 on the second try.

Your RST service and the tray icon will now work.
I'm going to back up this System to another drive and see if I can disable the driver signing without ruining the system. What a hack, huh!

Update: Yes, it seems like turning off the test mode and integrity checks is safe.

Run:

“bcdedit -set loadoptions ENABLE_INTEGRITY_CHECKS” (without the “”)

“bcdedit -set TESTSIGNING OFF” (without the “”)

reboot

Looks like SFC and DISM gave me a clean bill of health:
Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

C:\WINDOWS\system32>DISM.exe /Online /Cleanup-image /Scanhealth

Deployment Image Servicing and Management tool
Version: 10.0.10586.0

Image Version: 10.0.10586.0

[==========================100.0%==========================]
No component store corruption detected.
The operation completed successfully.

C:\WINDOWS\system32>

Tip: If you don't know your version you can look at the remnants of the RST product in the registry.
Look at the "Version"(look at step 9) key. In my case, the key value 0x0e050000 (e-5-0 in hex) means 14-5-0. My version was 14.5.0.1081. I don't know why the build number isn't there... Better than nothing.

Follow-up: So, now you've got your RST up and running and everything is working as it should(i hope). However, since we have modified the registry to point to OUR extracted package, located in the "Downloads" folder, the repair isn't exactly clean. If you delete those files you'll be back to square one if you want to uninstall or reinstall RST. To finalize our repairs you need to uninstall RST again. Go to "Add/Remove Programs" aka "Programs and Features" in Win 10 and uninstall "Intel Rapid Store Technology"(It will/should keep the actual drivers, just install the RST service). It will ask you for a reboot, and while rebooting you may see another blue screen (Interrupt_not_handled)-- not sure if it's related to our exercise, since it gives no additional helpful information of any sort. Fortunately, the system self-reboots, and loads windows on the second try. Mind you, it will take a long time to boot and there will be a lot of hard drive churning going on. But, once you're in windows, simply install RST again and reboot, and the install packages will be in their right places and the registry entries you had made will be pointing to them instead.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The RST Service and Tray Icon is missing on my set-up after the W10 Th2 upgrade but the storage controller device drivers are still the Intel 12.9.0.1001 I had installed so I'm assuming I can run the 12.9.0.1001 installer again to get my services and tray icon back?  Essentially just reinstalling the Intel Rapid Storage Technology software.  What do you think?

My registry is also pointing to the correct installer package location so I guess in my case it is just the Intel RST software and service that has been uninstalled.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Does the install package still exist there? If yes, I think you should be good to go-- just run the installer(double click the RST entry in Add/Remove Programs) and choose "repair". In my case, I had the left-over registry, a downgraded driver, and no install package to uninstall/repair from.

But I would do a system image first, just to be on the safe side :).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just see the name of the responding rep. and I know the answer must be meaningless.

Reading further out of curiosity was a great satisfaction then. (For me, not for the folks asking the question.)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That's why it's important to have a community, even if just for your personal entertainment value :)

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.