iCloud account settings

Every time I go to Windows 10 mail app for my icloud email, I receive a message, "Your icloud account settings are out-of-date".  A chance to Correct or Dismiss.  Everytime I correct, I am asked for my icloud password which I give and then get to my email/  However, nothing is ever updated and I go through this routine everytime.  What is going on with Window 10 email app?

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated April 13, 2019 Views 35,752 Applies to:
Answer

I had this problem too, and after 4 days of trying all sorts of fixes (ranging from changing firewall settings, reinstalling the Windows Mail app, applying different config settings), here's what worked for me.

My iCloud email is protected with Apple's two step verification, so I needed an 'app-specific password' to sign into an app that's not provided by Apple, like Windows Mail which doesn't support entering verification codes. 

Here's the steps (I did this via my MS Surface Book laptop):

  • sign into Apple ID with your iCloud email and password: https://appleid.apple.com/account/manage
  • if you're a two step verification user, your device (for me, my iPhone) will give you a verification code to enter after you put in your iCloud email password
  • in the 'Security' section, hit 'Edit'
  • in the 'App-Specific Passwords' section, hit 'Generate Password...'
  • enter a label for this password (I typed 'Windows 10 mail app')
  • hit 'Create'
  • an app-specific password will be created for you, in this format (case sensitive) tmah-jdbq-rdyy-gdes
  • copy the password and hit 'Done'
  • now open up Windows Mail > settings (cog icon) > manage accounts > select your iCloud account and enter your app-specific password then 'Save'

Your iCloud email should now start to appear. Despite spending days looking at the config settings, it seems Windows Mail pre-set config is correct, so you shouldn't need to change the incoming or outgoing email server settings:

Incoming email server: imap.mail.me.com:993:1

Outgoing (SMTP) email server: smtp.mail.me.com:587:1

I hope this helps someone. A word of warning though. If you change your primary Apple ID password, all your app-specific passwords will be automatically revoked and you'll need to generate a new one for any apps you want to keep using.

456 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

I also had this issue.

Mail worked perfect in Windows 8.1 but not in 10.

The problem for me was that the outgoing mail settings was wrong.

Correct settings should be (found in advanced settings):

  • Incoming server: imap.mail.me.com:993
  • Outgoing server: smtp.mail.me.com:587
  • Use the same username and password to send and receive email: True
  • Outgoing server requires authentication: True
  • Require SSL for incoming e-mail: True
  • Require SSL for outgoing e-mail: True

Hope this is of some help.

/Christian

82 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.