Question

Q: How to force Windows 10 time to synch with a time server?

The time displayed by WIndows 10 is over 30 seconds slow even though I shut it down and restarted my computer less than 15 hours ago. I can't find a way to force W10 to synch the clock with a time server.

I had a program (SocketWatch) I had used for years to update the clock with the NIST time server, but it no longer works in W10.



* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Dave,

Thank you for posting in Microsoft Community.

Method 1:

Follow the steps mentioned below.

  1. Press Windows key + r and type services.msc and press enter.
  2. Right click on Windows Time and select properties to check the status of the service.
  3. Restart the Windows Time service.
  4. Click on OK.
  5. Restart the computer

Method 2:

a.       Click on clock and select “Change date and time settings”.

b.      Click on the “Internet Time” tab.

c.       Check if it is set to “synchronize the time with time.windows.com”

d.      If the option is selected, click on change settings to check the option “Synchronize with an Internet Time server”

e.      Click on OK.

 

Method 3:

Follow the steps mentioned below.

Press Windows key + X and select Command prompt(Admin).

Type each one of the command below and press enter.

net stop w32time

w32tm /unregister

w32tm /register

net start w32time

w32tm /resync

Restart the computer to test the issue again.

W32tm.exe is used to configure Windows Time service settings. It can also be used to diagnose problems with the time service. W32tm.exe is the preferred command line tool for configuring, monitoring, or troubleshooting the Windows Time service.

Hope it helps.

Thanks.

Did this solve your problem?

Sorry this didn't help.

145 people were helped by this reply


I don't think any of these methods will help because the service is running, but it doesn't seem to update (by referring to a time server) very often.

I looked at Method 1 and found the service to be running. Even if I did stop and restart the service, and restart the computer, that won't change its behavior for the future. I certainly don't want to restart my computer every hour!

As for Method 2, Windows 10 doesn't even show an Internet Time tab.

Again, Method 3 is not going to be useful because I certainly won't be doing that every hour!

I appreciate your trying to answer my question, but I need a different kind of answer.

Dave

Did this solve your problem?

Sorry this didn't help.

15 people were helped by this reply


It turns out there is an easy way to resynch manually. Click on clock and select "Change date and time settings". Turn off "Set time automatically" and then turn it back on. This forces a resynch. Doing this automatically (periodically) is what I really want to do. There are dozens of programs available to do this, but none that I have found work with W 10. Apparently Microsoft has done something in W 10 that blocks all programs from accessing the time port. Thanks for nothing.

Did this solve your problem?

Sorry this didn't help.

35 people were helped by this reply


Did not work. The time is still 2 hours fast.

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply


Dave,

If you are still interested in an automatic time sync, I use this solution by Rob van der Woude on both Windows 7 and Windows 10.

TimeSyncWeb.vbs

I have it set up to run with Admin permissions in Task scheduler.  I have removed the WScript.Echo lines and replaced them with writes to a log file instead.

Try*3 - a user
Dell Inspirons 7779, 1545, 9300; Windows 10 Home x64 & Pro x86; Office Pro 2007; HP DJ2540; HTC UPlay [Android 6.0], MyPhoneExplorer

Did this solve your problem?

Sorry this didn't help.


I too have noted the @30+ second discrepancy. This appears to be a permissions issue. 

I have a little utility called "AboutTime" that I have been using for 15+ years to sync time across my networks and with internet time servers.  This util has been rock solid for all that time and still runs under Win 10. 

However even using this to sync with a local SMTP server, I was still getting a 30000+ ms offset.

Just for the **** of it, I tried running AboutTime under "Run as Admin..." and low and behold, my offset was now under 2 ms. This was syncing to either NIST or my local server.

The strange thing is that I generally run that util from an admin account. So I should not need to "Run as Admin..." but there it is. 

Clearly a bug, err... I mean "feature" in Windows 10. 

Did this solve your problem?

Sorry this didn't help.

5 people were helped by this reply


About "generally run that util from an admin account. So I should not need to "Run as Admin..." " - that is not how Windows works. 

An Admin account needs to invoke its Admin privileges to have any effect. 

An Admin account is just a Standard user account except where this is done.

Denis

Try*3 - a user
Dell Inspirons 7779, 1545, 9300; Windows 10 Home x64 & Pro x86; Office Pro 2007; HP DJ2540; HTC UPlay [Android 6.0], MyPhoneExplorer

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply


Thanks to both you and tryx3 for these solutions. Very helpful.


Dave

Did this solve your problem?

Sorry this didn't help.


Method 2:
a.       Click on clock and select “Change date and time settings”.
b.      Click on the “Internet Time” tab.
c.       Check if it is set to “synchronize the time with time.windows.com”
d.      If the option is selected, click on change settings to check the option “Synchronize with an Internet Time server”
e.      Click on OK.

I would like to amend Method 2 to include the latest Windows-10 directions:

1) Right-Click on the time clock in the bottom right-hand corner.

2) Click Adjust Date/Time

3) Under (Related Settings) Click Additional Date, time & regional settings

4) Now Click 'set the time and date'

     a) You'll find this the familiar part, with the 'internet time tab' mentioned above.

5) Click on the 'Internet Time Tab'...

Then you'll be able to follow the method 2 instructions above, and even 'update the clock' immediately.


Did this solve your problem?

Sorry this didn't help.

60 people were helped by this reply


My computer clock loses time frequently (often as much as 2 or 3 minutes) and I have to keep resetting it, which is a real nuisance. It's currently set to synchronise to "time.windows.com".  However, I live in the UK and the other choices in the drop down menu are all based on US time zones - which are no use to me!  How can I find a way to keep my clock accurate and what about people who live in other parts of the world who have the same problem?    

Did this solve your problem?

Sorry this didn't help.

3 people were helped by this reply


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.