How to Disable Touchscreen Gestures on Windows 10 (Action Center & Virtual Desktop)

Hi all,

Is there a way of disabling touch screen gestures from windows 10? We have a full screen Kiosk system, but we don't want people swiping the side of the screen and playing around with pc settings. I've searched the device manager / mouse & touchpad settings and there is no way to disable gestures. Any suggestions? Is there anything in regedit I can change?

Or disable Action Center & Virtual Desktop.

Thanks,

 

Question Info


Last updated November 10, 2019 Views 23,800 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Adam,

Thank you for posting your query in Microsoft Community.

We are working on your issue, we will get back to you soon.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Eeshwar,

About that reply that you deleted, I'm guessing that you don't want me to do it?

Adam

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

I have the same problem developing a Self Checkout application for customers using Windows 8.1 or 10.

Please publish a solution to this issue.

Thanks.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Azmarel,,

The Microsoft Engineer originally replied.....

"Step 1Copy the following registry code in Notepad and then save the file as Touch.reg file. Make sure that you save the file with .reg extension.

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull]
“ActionType”=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Left Edge Pull]
“ActionType”=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull Extended Zone]
“ActionType”=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Top Edge Pull]
“ActionType”=dword:00000000

Step 2Double-click on Touch.reg file, click Yes for the prompt, and then click Ok.

Step 3: Reboot your Windows 10 PC to disable the above mentioned gestures.

To enable these disabled gestures again, follow the steps provided below:

Step 1Copy the below registry code in Notebook, save it as TouchEnable.reg file.

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull]
“ActionType”=dword:00000002
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Left Edge Pull]
“ActionType”=dword:00000002
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull Extended Zone]
“ActionType”=dword:00000002
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Top Edge Pull]
“ActionType”=dword:00000002

Step 2: Double-click on the file, click Yes, and then click Ok when you see confirmation message.

Step 3: Reboot your computer.

Hope the information is helpful. Feel free to write to us for any other assistance with Windows, we’ll be glad to assist you."

Then he deleted the reply an hour later, I havn't had a chance to try this on our demo system. Use at your own risk.

Adam

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello everyone,

the solution adamedney provided it's not working.

I correctly followed the steps but after rebooting the PC, nothing changed. Have you tested it?

I need to make a kiosk device too, so if anyone knows how to disable the gesture touch related to the notification bar, it would be very appreciated.

Hope for a replay asap.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Microsoft really needs to add an easy way to disable these gestures. Half the time I scroll with my left finger, the screen to switch apps appears. Concerning that particular gesture, they should've had a lefty on their QA team!       

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

FANTASTIC!!!

adamedney - thanks a million. I have been suffering trying to find a solution to this for months. your registry update works perfectly!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It is not working for me too

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think that method only works with touch pads. I still haven't found a method for touch screen. 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've noticed it does not work after all. false alarm!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.