File associations in Windows 10 not working

Many of my file extensions are not pointing to the programs I need them to point. For example I create script files that are used by AutoCAD. The script file has an extension of .scr that I use a text editor program like Notepad to create it. When I upgraded to Windows 10 the .scr extension was set to open using the AutoCAD Script Editor. I tried to change the default program using a right click "Open With". However the "Open With" option was not available for this file type. I then tried: Right click on Start > Control Panel > Programs > Default Programs > Associate a file type or protocol with a program. I clicked on the .scr extension, clicked "Change Program" and it would not change. The only way I could get the file association to not be "AutoCAD Script Editor" was to Right click on Start > Run > regedit and delete all occurrences of the key .scr. After this I was able right click on the file and use "Open" to associate the file to Notepad. This worked, however, I think I'm missing a step. The "Open with" option is not available when I right click the file, like it is for other files. I would like to know what step I missed to get "Open with in the right click options.

Also, many of the file extensions indicate "Unknown application" so I suspect this issue may be affecting over 350 file extensions. Does Microsoft have a fix to fix all these "Unknown application" issues?

Hello, 

Thank you for posting your query in Microsoft Community.

Let me answer your query about File associations and .scr file type.

Please be informed that the “Open With” menu option is not available when you right-click executable files (.cmd, .bat, .pif, .scf, .exe, .com, or .scr), or shortcuts to executable files.

When you tried to change the default program to Notepad from control panel (Associate a file type or protocol with a program), did you get any error message?

Which file types indicate "Unknown application"?

Please check if you get the “Open with” option for other file types like .PDF or .JPG.

If you are not able to use “Open with” option with other file types, you may create a new user account and check.

http://windows.microsoft.com/en-us/windows-10/getstarted-set-up-accounts

Hope the information helps, do reply if you need further assistance.

Thank you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

How to change SCR file association to AutoCAD script file instead of Windows screen saver | AutoCAD | Autodesk Knowledge Network : https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/How-to-change-SCR-file-association-to-AutoCAD-script-file-instead-of-Windows-screen-saver.html

ex-MVP (2003-2012) (Windows Client)

10 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

1. When I tried to change the default program to Notepad from control panel (Associate a file type or protocol with a program), I did not get any error message.

2. I have over 300 file types that indicate "Unknown application".

3. I do get the “Open with” option for other file types like .PDF or .JPG.

If I set up another account, will the file associations be the same as the root registry keys?

Do you know if Microsoft has a fix to resolve all the "Unknown application" issues?

6 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The .scr files had the Description "AutoCAD script file" with the Current Default "Unknown application" in the file association list. This method might work, but I had already deleted the scr keys and then associated them with Notepad.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

>> Do you know if Microsoft has a fix to resolve all the "Unknown application" issues?

This is not at all an issue. Certain files types don't have ProgID mappings and not associated by default, but the extension is registered for other purposes.. For example, .asp files aren't associated with any program by default, but Windows sets a Search Filter DLL reference for this file type so that Windows Search finds text within this file (using the HTML filter)


[HKEY_CLASSES_ROOT\.asp\PersistentHandler]
@="{eec97550-47a9-11cf-b952-00aa0051fe20}"

Such file entries are listed as "Unknown application". That's just an example.

Another case would be when a program is uninstalled and its file type registration is intact in the registry, pointing to a non-existent executable, that's is classified as "Unknown application".

ex-MVP (2003-2012) (Windows Client)

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

>>  but I had already deleted the scr keys and then associated them with Notepad

Ok. Here is another way.. and easier too.

To associate .scr files with Notepad, open a Command Prompt (Administrator) and type in:

assoc .scr=txtfile

to revert back to defaults, type:

assoc .scr=scrfile

.scr files are Screensaver files (executable) files in Windows, and that's the reason "Open with" is not there in the right-click menu. Same for .exe / .com etc.

ex-MVP (2003-2012) (Windows Client)

18 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Despite the problem in the gif below, it actually worked correctly for me. I had to restart explorer.exe for my .py Python file to change on my desktop. 

14 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

It doesn't work, Windows 10 constantly changes file associations, it changes several times a day.

9 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This is not just an ACAD issue but is associated with the green bar of death/"working on it for hours issue".

this is the second time this has happened to me, happened after major update over a year ago, and seems to be back after the last update.

Please fix - extremely annoying, loss of productivity and a BASIC function of the OS.

FIX IT!!!

7 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

There is four  things below The (Choose the Programs that windows uses by default) in windows 10 .

1) (Set your default programs) , which has a green check mark in the little icon on the left side , next to the (Set your default  programs .)

2)( Associate a file type or protocol with a program) does

not have green check mark on the left hand side .

3) (Change Auto play settings) has a green check mark .

4) (Set Program access and computer defaults) has a green check mark next to it on the left side.

When I click on number 2 above nothing happens . It will not open or let me do anything .  

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated October 31, 2020 Views 23,781 Applies to: