Disable / Remove Windows 10 Sleep Study

Please tell me how I can Disable / Remove Windows 10 Sleep Study

Windows 10 incorrectly identifies my desktop as a tablet, most likely because I am using a Dell touch screen monitor.  I want to disable and remove the "Sleep Study" and all components as it is an unnecessary drain on system resources.  Please note, this is a DESKTOP system with no battery, no need to monitor screen on times or sleep times.  I have tried everything I can find including stopping "ScreenOnPowerStudyTraceSession" in Performance Monitor and setting output files to Read Only.  Nothing works.  Please help.

Hi,


You may disable all Sleep-related settings by following these steps:

  1. Type Control Panel from the Cortana search bar, then choose the Control Panel app from the best match result.
  2. Choose the Large icons option from the View by drop-down list found on the upper-right part of the Control Panel window.
  3. Locate then select Power Options.
  4. Click the Change plan settings link beside the selected Preferred plan.
  5. Click Change advanced power settings.
  6. Locate and open all the options under Sleep.
  7. Turn OFF all the options that is under Sleep.
  8. Click the Apply button, then OK.

Let us know the result.


Regards.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

As suggested, I reviewed settings at:

Control Panel -> Power Options -> Change Plan Settings -> Change Advanced Power Settings -> Sleep

SETTINGS BEFORE:
Sleep after: Never
Allow hybrid sleep: On
Hibernate after: Never
Allow wake timers: Enable

SETTINGS CHANGED TO:
Sleep after: Never
Allow hybrid sleep: Off
Hibernate after: Never
Allow wake timers: Disable

Then I deleted these files:
Windows\System32\SleepStudy\UserNotPresentSession.etl
Windows\System32\SleepStudy\ScreenOn\ScreenOnPowerStudyTraceSession-####-##-##-##-##-##.etl
(About 20 files here in the last two days)

And then rebooted...

Since then I have had five new .etl files appear.  Apparently the fix we tried didn't work.  (But obviously thank you very much for giving me something to try!)  Any other suggestions?

PS - I did recheck all settings; they held / did not revert back to previous values.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We appreciate you providing us those information.

Have you tried using a different user account and still getting the same issue? If not, here's how to create another administrator account in Windows 10.

You may also run the following scans to repair missing or corrupted system files:

  • System File Checker
    The System File Checker or SFC is a utility in Windows that allows users to scan for corruptions in Windows system files and restore these corrupted files.
  • DISM or System Update Readiness tool
    The DISM or Deployment Image Servicing and Management can help you fix some Windows corruption errors as well.

Let us know the result.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think we really should try to escalate this issue to someone who specifically knows about the sleep study application.  No, running under a different user will have no effect (DOES NOT, actually - I've already tried)  And no, there is noting wrong or corrupt with this installation.  My current build is 10.1709.16299.125  It doesn't really matter; the problem has survived several recent upgrades.  I guess I am wondering why we would keep trying things that really have no chance of solving the problem.. Do you have access to information about the application?  Why don't we try to look up the correct information rather than just guessing?  Since the last time I posted here there are more than 19MB of new but completely useless information stored on my computer...  Why?  Could we please try to find the actual information on how to disable the sleep study application?  Please?

25 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Should probably mention that even a Desktop System usually has a battery.

It helps your clock keep the correct time. 😉

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Your suggestions have absolutely noting to do with the original question.

There is no reason for this "SleepStudy" to be creating an endless list of .etl files on my computer. I want to remove it completely from MY computer. Let me say that again: it's MY computer. I should have complete freedom to remove anything from it that I don't want on it! If doing so bricks my PC, so be it. That's MY problem since it's MY PC!

The takeown and ICACLS commands get me ownership of the folders but access to the ScreenOnPowerStudyTraceSession file is still denied. The takeown and ICACLS  don't work.

How do I unlock the SleepStudy folder and files so they can be deleted permanently?

"It is no measure of health to be well adjusted to a profoundly sick society". – Jiddu Krishnamurti

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, if you are able to take full control of the folders, you can completely delete the Sleep Study folder from the System 32 folder.  I have done so many, many times.  But that is of no real importance, because the Sleep Study folders and a new batch of *.etl files will reappear overnight.

The Sleep Study process is smart enough to create the necessary folders if they do not exist, and promptly begins filling them with more files.  I would still like to find a permanent fix for this issue but to be honest, I have not spent a lot of time on it lately.  I've thought about adding a simple batch file to my start up that will delete the files, but that would make it difficult to know if the files were still being produced.  It would remove the incentive to find a way to terminate and remove the process that is creating the mess.

I will look at it again as time permits, but if anyone actually KNOWS how to curtail the Sleep Study process, don't be shy about sharing your success.  :)


2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Having taken ownership of the 2 folders, I tried something I saw in another post.

"I found a solution for this problem, by setting "UserNotPresentSession.etl" to Read-only.

  1. Go to: "C:\Windows\System32\SleepStudy".
  2. Click the right mouse button on file: "UserNotPresentSession.etl" and then "Properties" from the list.
  3. Check "Read-only" checkbox and save changes.
  4. IMPORTANT: Restart your computer."

This didn't work when I tried it b4 taking ownership of the folders. When I tried to set the files to read only I got one of the usual you can't do that messages. However, having taken ownership of the folders, for some reason, when I set the files to Read-only it stuck.

When applying Read-only status I did NOT click the Apply button, just OK.  I restarted my computer with the explorer window still open. Don't really know if that matters. Now both files are maintaining the Read-only status and it seems no more ScreenOnPowerStudyTraceSession.etl files are being written. This may prove to be wishful thinking as I'm actually expecting the files to reappear at some point. Just a hunch. I'll confirm one way or the other in a little while.

"It is no measure of health to be well adjusted to a profoundly sick society". – Jiddu Krishnamurti

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What worked for me is removing the SleepStudy folder with pchunter (the quick and dirty method)

And then make a symbolic link with the same name to my ramdisk.

I was expecting my ramdisk filling up with these files but sleepstudy seems to have stopped making these files totally :)

Hope this works for you.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 17, 2020 Views 18,134 Applies to: