Can't delete a keyboard language after update to version 1803 of Win 10

Hi, everyone

My laptop automatically updated to version 1803 a week ago. After the update I noticed that I have an extra language installed for my keyboard - English (UK). I use English (US) and a few other languages. I tried removing English (UK) from the Region & language settings, but the option is greyed out like this: 

 

I suspect that this has something to do with my original software version. Back when I bought the Windows 8 installation disc, it was for the United Kingdom, because that's all the store had to offer me. However until now I never had a problem with removing unwanted languages and adding new ones. The drama is that my laptop keyboard has an American layout, so when I want to type in something and English (UK) is on, I mess up and have to check the selected keyboard language every time.

Is there any fix for this? 

Thanks in advance, guys. 

Answer
Answer
Hi Dikran, there is a known bug in the 1803 version of Windows 10. Microsoft are aware of this issue and hopefully are working on a patch . . .

For the moment, please try this workaround to set your preferred input language:

Right click your Start Button, choose Powershell (admin)

Run this command to get a list of installed languages on your PC

Get-WinUserLanguageList

Note down the LanguageTag of your preferred language

If say, your preferred language is US English, run this command and hit Enter:

$1 = New-WinUserLanguageList en-US

Then run this command to set the order of installed input languages

Set-WinUserLanguageList $1

Close Powershell and restart your PC
___________________________________________________________________

Power to the Developer!

MSI GV72 - 17.3", i7-8750H (Hex Core), 32GB DDR4, 4GB GeForce GTX 1050 Ti, 256GB NVMe M2, 2TB HDD

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
You should do following -

Right click on Windows Start > Windows Powershell (Admin)

Copy and paste below and Enter in Powershell
Now, Copy and paste below and Enter in Powershell
Set-WinUserLanguageList en-US

This will make other languages disappear. (In case, you want to add again or other languages, you can add again from language settings)

Source - https://www.tenforums.com/windows-updates-activ...

Disclaimer - This is a non-Microsoft website. The page appears to be providing accurate, safe information. Watch out for ads on the site that may advertise products frequently classified as a PUP (Potentially Unwanted Products). Thoroughly research any product advertised on the site before you decide to download and install it.
Best regards
Vijay Verma

Timezone: UTC+05:30, PST+12:30
Availability Hours (UTC) : 05:00 AM - 05:00 PM

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated November 11, 2019 Views 2,005 Applies to: