3 second delay when using shortcut key to launch program

I have set up a few shortcut keys in order to use the keyboard to launch programs, e.g. ctrl + alt + w to launch Windows Media Player. Directly after booting Windows 10 these shortcut keys launch the programs instantaneously.

However after a few hours, when pressing the shortcut keys, Windows waits exactly 3 seconds before loading the program, even when the machine is completely idle. After rebooting, the shortcut key then launches the programs instantaneously again, but only for a few hours.

Anyone else seeing this?

 

Question Info


Last updated November 8, 2019 Views 3,760 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Donny,

Thank you for posting your question in the Microsoft Community.

Sorry to know that you are facing this issue.

Ensure to install any pending updates and also update all device drivers through Device Manager. Once this is done restart the computer to check if this helps.

You may boot the computer in a clean boot state and check if the issue persists. When you start Microsoft Windows, typically there are several programs that start automatically and run in the background that may interfere with the program. These programs may include antivirus and system utility programs. When you perform a clean startup procedure, you prevent these programs from starting automatically.

How to troubleshoot a problem by performing a clean boot in Windows: (Applies to Windows 10) http://support.microsoft.com/kb/929135

Note: After you have finished troubleshooting, follow the steps under “How to reset the computer to start as usual after troubleshooting with clean boot” in the article to boot to normal startup.

Reply with the status of the issue and we will be glad to offer our assistance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Srimadhwa,

Thank you for your reply.

I have checked Windows Update and there are no pending updates. I have also checked Device Manager and all drivers are installed, updated and operational.

I have also disabled all startup programs and non-Microsoft services as you suggested, and rebooted. I will now monitor the loading speed of my program shortcuts to see if the 3 second delay returns within the next few hours.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi again,

I have now run Windows for a few hours and the problem has re-occurred despite implementing your suggestions. When I launch a program with a Shortcut key, Windows is inserting a 3 second pause. There are no pause issues when launching the program from the start menu.

Can you investigate further please?

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Since I haven't heard from you for a while I have done some more testing. I have narrowed this problem down to two in-built Microsoft processes belonging to the built-in Mail and Calendar app. These are:

HxMail.exe and HxTsr.exe

When these processes are in a running state or are not running at all, Shortcut keys for Shortcuts operate at full speed.

When these processes are in a suspended state, for instance after the Mail and Calendar app has been minimized for a few seconds, there is a 3 second delay added to Shortcut keys for Shortcuts.

Can you formally raise this as a bug report please?

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are a few things that can cause this problem in earlier versions of Windows too, but the number of potential causes has increased in Windows 10. The problem and its solutions have gotten some discussion at the Stack Exchange SuperUser site.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Version 1511 build 10586 has not fixed this issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This intermittent keyboard shortcut delay problem - which also prevents macros from completing - is a bug that survives in public Pro build 1511-10586 here.  Microsoft Level II support is well aware of it, and allegedly has kicked it up to development.  Perhaps it is history in later preview/enterprise builds.

For those who still experience it, here's the workaround, which should not impair performance...

In the search bar type SERVICES.  Click on "Services Desktop App."

In the list that appears scroll down to the "Superfetch" entry and double-click it.

STOP the service.

DISABLE the service.

REBOOT.

This is a serious performance hit that needs to be fixed.

To avoid further frustration, ignore the suggestions from MS techs in this thread.  They've been tested and won't help.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for the visiting Microsoft Community.

If you have any feedback related to Windows and want some changes in the next version or update then you need to post them on the Feedback app. For providing your findings, issue, bugs and comments on the feedback app you may refer to the steps provided below.

 

  • Press the Windows key.
  • Type Feedback in the box.
  • Click on Windows Feedback (Trusted Windows Store app).
  • Then follow the on screen instruction to provide feedback.

 

Hope the information provided is helpful. Do let us know if you have any queries related to Windows, we will be happy to assist you.

 

Regards,

Ramesh Kumar.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried your suggestion to disable the Superfetch service but it didn't work.

It's clear the issue is caused by certain metro apps in the "suspended" state (as reported by the "Process Explorer" application). The 3 second shortcut key launch delay can be cured by killing all suspended metro apps, but certain apps keep re-spawning by themselves which make this a constantly recurring issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Donny,

Just for a diagnosis you may check the issue in new user profile and see if it helps.

For creating new user profile you may refer to the steps provided below.

 

  • Press Windows key + R

  • Type control userpasswords2 and click OK

  • Click on add under users tab

  • Click the option, "Sign-in without a Microsoft account

  • Click on Local account 

  • Choose a name for the account

  • Add password if you want to

  • Apply and click OK.

 

For more information you may refer to the article mentioned below and see if it helps.

Create a local user account in Windows 10

Do keep us updated.

Regards,

Ramesh Kumar.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.