Windows keeps automatically adding EN-US keyboard layout

For some reason, Windows seems to regularly check to see if I'm using the EN-US keyboard layout, and adds it if I'm not. (Normally, I use a variety of other layouts.) This ends up adding another entry to my already long list of layouts to cycle through.

It appears without an entry in the add/remove keyboards settings screen. In order to delete it, I have to first add it via the normal method - then, if I delete the normally-added keyboard, the erroneous entry goes away. It then reappears sometime later, requiring me to go through the process again.

I might have thought that it's being added because I'm not using the 'default' layout, but my system language is not English (it's Japanese). It's not the 'default' anything unless Windows as a whole treats it as somehow more default than all other things. Windows seems quite fine with me not using the default Japanese layout (I use Google's, not Microsoft's) - the Microsoft one reappeared after the Anniversary Update, but hasn't come back after having been sent away.

This seems like an odd bug. Any workarounds, so my layout list doesn't keep having a useless entry taking up space?

 

Question Info


Last updated October 16, 2019 Views 53,614 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

To disable windows from automatically adding EN-US keyboard layout, we suggest you to disable automatic keyboard layout change. To do so, please follow these steps:

  1. Go to Control Panel.
  2. Click Language and select Advanced settings.
  3. Under Switching input methods, uncheck Let me set a different input method for each app window.

Let us know how it goes.

Regards.

45 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply! It seems that that option is already unchecked, though.

24 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you would like too you can do system restore to restore some settings on your PC.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That seems rather drastic compared to the scale of the problem, and if this isn't the result of a setting being changed badly in the past, I doubt that would solve the problem. If the problem is a wrong setting or bug that's been here the whole time, restoring will just restore back to an earlier point that still had the bug/setting.

28 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Now, after having tried the Vietnamese Black Ci keyboard (which seems pretty buggy in general), Vietnamese now also continually gets its own entry, also with the EN-US layout. I now have two automatically returning entries in my keyboard switcher list.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

To resolve your concern regarding keyboard layout, follow the steps below:

  1.  Go to Control Panel.
  2.  Click on Clock, Language, and Region.
  3.  Select Region.
  4.  Click on the Location tab.
  5.  Under Home location, select Japan so that it won't add any English keyboard layout.
  6.  Click Apply, and then OK.
  7.  Restart your computer.

Let us know how it goes.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the reply! Unfortunately, it seems my location is already set to Japan. I could change it and then change it back, but that might well not solve the problem.

Also, now it seems I have two duplicate entries in my switcher for the EN-US keyboard, one grouped with the other two English keyboards and one at the end. Adding and removing English (US) deletes the one at the end, but not the one in the group.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here is another set of steps that you could follow:

  1.  Go to Settings.
  2.  Click on Privacy.

    

     3. Select Location.

     4. Make sure that Location is Off.

Keep us updated.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

sjiveru wrote on 29 Sep 2016:

« For some reason, Windows seems to regularly check to see if I'm using the EN-US keyboard layout, and adds it if I'm not »
Actually Microsoft in 2008 added to Windows an "improvement" where a PC when booting, changes the Language and Keyboard Layout set on this PC, to the one of a nearby other PC on the network, which of course is often US, but also can be US-International, French, German, or any of the ~150 others. Of course this behavior, being full unexpected and full hidden, puts the user in a long period of doubt and fruitless search for solution.
Diego gave on 07 Oct 2012 a Total protection against these Keyboard Layout changes from nearby computers, which is immediately, totally, and reliably effective:

In RegEdit, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout, in right pane right-click and choose "New" then "DWORD Value", name it "IgnoreRemoteKeyboardLayout", then double-click it and under "Value data" type "1" (don't mind "Hexadecimal" or "Decimal", either will do).

Versailles, Thu 29 Jun 2017 17:42:10 +0200

The whole object of science is to synthesize, and so simplify -- Percival Lowell

70 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried  Michel method by adding the DWORD in the regedit, as well as check the Preload in HKEY_CURRENT_USERS, but I still have Vietnamese Keyboard automatically adding to my language bar, even though in my language or keyboard setting there is no Vietnamese added. The only way to get rid of it temporally is adding Vietnamese Language and then remove it, the Vietnamese Keyboard Layout come out with it. 

Is there anyway to solve my problems? Thanks a lot.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.