Windows 10 Task Manager shows 100% CPU but Performance Monitor Shows less than 2%

Hi 

Today,I have updated my PC to Windows 10 from Windows 8.1 pro.

Everything is working fine except Task Manager in Windows 10. Task Manager always shows 100% CPU , which is incorrect as per the Performance Monitor application. I have verified CPU usage with other 3rd Party application as well, which all show CPU usage as indicated by Performance Monitor. Someone please help me if there is a fix for this issue.

CPU:Intel Core i7 2600K @ 3.40GHz

RAM: 12GB

Motherboard:Intel Corporation DH67CL

GPU: NVIDIA GeForce GTX 550 Ti 

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

CPU:Intel Core i7 2700K @ 3.50GHz @ 4.4GHz

RAM: 8GB

GPU: NVIDIA GeForce GTX 770

This makes it very difficult to accurately diagnose issues.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Im also having the same isuse with the following computer spec:

CPU:Intel Core i7 2500k @ 4.3 GHZ

RAM: 8GB

GPU: NVIDIA GeForce GTX 570

Wonder if it has some weird interaction with Sandybridge chipset.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Could you please suggest what further info i can gather to detail this issue futher..i will try to fetch those...

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I think I can explain this problem but I don't have a fix. Perhaps the explanation will spur someone to figure out a fix.

The System Idle Process is missing from the task manager. As a result, 100% usage is always shown because the sum total of actual processes excluding idle time will always be 100% by definition. Therefore what you see instead is 100% total usage, and the individual processes in the list are reflecting a percentage of processor usage of what would normally remain after idle time is excluded.

For example, suppose this is the actual usage that would normally be shown:

System Idle 96%

Process Explorer 2%

Task Manager 0.2%

Total CPU: 4%    (100% possible - 96% idle = 4%)

But we don't see System Idle. Instead we see the following:

Process Explorer 50%

Task Manager 5%

Total CPU: 100%    (100% possible - 0% idle = 100%)

and so on. In other words the total possible CPU is 100%, so if System Idle is 96%, this leaves 4% being actually used by processes. In this example Process Explorer is using 2%, so it displays as 50% because 2% is half of 4%. In effect, total CPU us being miscalculated because System Idle is missing and so programmatically it is being treated as if it is 0%. This then breaks the calculations for total CPU time as well as the percentage calculations for each individual remaining process.

To resolve the problem, it must be understood why System Idle is not being displayed by the task manager, which probably involves some damaged registry setting. If anyone can figure this out, please post a fix.

p.s. This problem appeared for me in Windows 10 preview after one of the final pre-release updates. I was hoping it would be fixed by updating the RTM release of Windows 10 but that did not do it. No doubt a clean re-installation of Windows 10 would fix it but I'd rather avoid that. Googling the issue reveals that this problem has been seen before in Windows 7 and Vista, though the conversations are minimal probably because it is a difficult problem to frame for a search engine. The fix no doubt is extremely simple once it is located, and that would be preferable to a full reinstallation of the operating system.

149 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for isolating and explaining the issue.

I observed this issue 1st time in preview build 10130 , I was under the assumptions that this might be due to  Driver compatibility issue, after the upgrade. So I did a clean installation but it didn't fix the issue. after the RTM was release, I again did an upgrade then a clean installation . still the issue didn't go. So  I don't think clean installation would fix this. we might have to wait for a fix from MS.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

My machine have the same issue. I did a clean installation but it didn't solve the issue. How solve it?

Thanks,

Jefeson Alves

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Unfortunately I do not have a fix for the problem, but I do have workaround and that is to use Microsoft's Process Explorer instead of Task Manager:

https://technet.microsoft.com/en-us/sysinternals/bb896653

Process Explorer does not suffer the same bug so it will show an accurate depiction of CPU usage. It is a more powerful and detailed tool than Task Manager and can be customized to show only the information that you want.

9 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you that finally confirmed this is just a Task Manager bug however, I still think its more than that because my dynamic CPU speed never drops below 3.06ghz like it does on other Windows 10 PCs when idle.  So Task Manager falsely displaying 100% CPU utilization is really just symptomatic of another problem.  I'm thinking maybe a power management issue?  I don't know.

Dell Inspiron 620 i5-2320 8GB mem

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have fixed the issue with my computer, This issue was due to outdated BIOS, Downloaded the latest BIOS(though it was of the year 2012) from Intel website and updated motherboard BIOS and the issue is gone now.

Hope this helps someone!

7 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Ooohh... I've returned here frequently, to see if someone came up with an answer.

Just happened that I found one on another site :)... So here goes... Solved my problem.

After much debugging, I was able to come to the conclusion that my specific case was related to a bug in the Oculus Rift software. Because the Rift, a virtual reality headset, requires low latency, their software seems to set the IDLEDISABLE power configuration to "1". In certain cases, after taking the headset off, the setting is not changed back to the default of "0".

IDLEDISABLE prevents the CPU from throttling itself, causing heat and the fan noise I observed. Additionally, this manifested in the Task Manager as "100% CPU usage". Process Explorer seems to always discount the System Idle Process and not include it in the total CPU usage, which is why it displayed a lower total CPU usage than Task Manager did.

To fix this, you can run the following two commands, which sets the IDLEDISABLE setting back to "0" and then re-applies the power management configuration.

C:\WINDOWS\system32>PowerCfg /SETACVALUEINDEX SCHEME_CURRENT SUB_PROCESSOR IDLEDISABLE 000
C:\WINDOWS\system32>PowerCfg /SETACTIVE SCHEME_CURRENT

A small note. Even if you don't have an Oculus Rift, the above could solve your problem.

Hope it helps others than me... 

Cheers

280 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated May 5, 2021 Views 54,200 Applies to: