Windows 10: Daylight Saving Time Adjustment not working

With the recent DST change, I had to turn off the Setting, "Adjust for daylight saving time automatically," to get my Windows 10 clock right.

I never had to do this with previous Windows. Is something broken?
Answer
Answer

Hi,

Welcome to Microsoft Community.

In general, "Adjust for daylight saving time automatically" should always be on. Turning it off is for a few legacy edge cases and a couple of places in the world that don't currently have an appropriate entry in the list of time zones.

Most likely, the system clock isn't set to the correct time. Perhaps there's a problem getting the correct time from the Internet, which is enabled or disabled from the first "Set time automatically" option.

1. Check that your Internet Time settings are correct. Try a different time server if necessary. 

Follow the below to check Internet Time settings

1.    Go to Control Panel.

2.    Search for "Date and Time".

3.    Click on "Set the time and date".

4.    Click on the "Internet Time" tab.

Click on "Change settings…”.

2. Turn on all options, being sure to turn on "Adjust for daylight saving time automatically" before turning on "Set time zone automatically".

Hope the information helps, if you have any further queries, feel free to post. We are here to assist you.

Regards,

Guru Kiran

170 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 16, 2020 Views 54,162 Applies to: