Runtime Broker high CPU usage

This has become quite a long thread so I'll try to summarize it:

Issue:

A process called Runtime Broker has a high CPU usage in Windows 10 (final release version).

Cause:

Unknown, there seem to be multiple causes and multiple solutions. May be related to OneDrive, permissions for metro apps, Background Task Infrastructure Service, Windows spotlight thingy, windows tips and a number of other apps.

Solutions thar work for some:

  • Registry hack: run regedit.exe, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker, change "Start"=dword:00000003 to dword:00000004. This will affect parts of Cortana, like new apps not showing up and you can't set reminders.
  • Switch your lock screen background (Settings -> Personalization -> Lock Screen) from Windows Spotlight to Picture. Preferably but not necessarily a picture of a ninja cat on a dinosaur ;-) Additionally disable the live tile of your photo app by right clicking on it.
  • Settings -> System -> Notifications & actions -> Disable "Show me tips about Windows"
  • Disable (at least to test) the P2P sharing in all settings>update>advanced>chose how updates are delivered. Set "updates from more than one place" to off.

If these don't work, your odds of finding a fix have dropped considerably, but you could try:

  • Try disable background Apps:  go to "Start->Settings ->Privacy -> Background Apps" and Turn-off those apps.
  • Deleted Groove music using powershell. Used these commands: Get-AppxPackage -name "Microsoft.ZuneMusic" | Remove-AppxPackage     Get-AppxPackage -name "Microsoft.Music.Preview" | Remove-AppxPackage    (To bring up powershell, press win+r and type powershell. Hit enter, copy and paste one at a time).
  • Disable/delete OneDrive / SkyDrive
  • Disable Google Drive if you use it
  • Remove .Net 3.5
  • Remove any external drives / NAS locations from your Photos and Music libraries 
  • Close all programs and restart them one by one to try to find the culprit, uninstall the culprit. Yes, we're in the desperate stage.
  • Do a full refresh of Windows 10. But note: many people have the problem persist, even after a vanilla install of Windows 10.
  • Send MS an angry e-mail. Wait for them not to respond. Throw a brick through the Windows(R) of your local MS office. Won't fix the problem, will fix your frustration for a while.

Thanks to everyone who posted a solution i incorporated in this post. Please let us know if any of these fixes worked for you.

If none of that works for you

See instructions below by ZigZag3143 to create a report. Please create a new thread with your report and e-mail ZigZag by using the link to the thread on his profile. Do not e-mail the trace.

Edit: i went through the thread a few times to aggregate plausible solutions in this post. Latest was 14-8. Also, i removed the comment that after resetting the registry hack, the issue was still fixed for me. Turns out I had misnamed my registry files. After resetting the registry the issue came back after all.

original post:

I have just upgraded my pc to Windows 10. After install, I reset it to get a fresh clean installation. That made a huge difference in responsiveness of the start menu, which before used to take 20-30 seconds to open. However, now a process called Runtime Broker is taking up 20-40% of my CPU. I googled that this app is about permissions for metro apps or whatever they're called. I've found several threads about either high memory usage or antivirus, but I don't have any antivirus installed except windows defender and Runtime Broker only uses a few MB of memory. But it does hog my CPU. I did try manually ending it with the End Task button, but then it restarts within seconds and keeps hogging my CPU.

For now i applied a registry hack. Changed [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003 to dword:00000004. While that stops the process from hogging my cpu, i have no idea what i've done and what the consequences are.

Specs:

- Windows 10 build 10240, pro with all updates installed, upgraded from a genuine 8.1 pro.

- No additional Metro apps installed. I tried uninstalling a bunch of them but they just get reinstalled

- Computer: Samsung Ativ Pro convertible XE700T1C, multiboot with Windows 8.1 home oem that came with it (so two genuine licences on different partitions on one system)

Please help me! What can i do to get this properly fixed based on understanding the cause of the problem rather than random registry hacks.

 

Question Info


Last updated August 20, 2019 Views 139,632 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Yeah, I saw that one on my wife's computer, but good luck making it stay "ended"

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found the process that makes runtime broker using CPU intensively

open task manager and find process called "From Microsoft Background Task Host" End it and you will see Runtime Broker back to normal state.

I don't think this is a proper solution. Unless people report this as a permanent fix without side effects.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've tried all of the ideas in this thread, and then some...

..but nothing works!

3 GB and counting this afternoon!!!

3 out of 4 upgraded computers work (mostly) OK, but the 4th is giving me trouble!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't think this is a proper solution. Unless people report this as a permanent fix without side effects.

You right, but it is temporary solution, and if you use unlocker 1.9.2 to rename process file to stop using it, it works and for me it stops suck out my laptop battery, and until now I have no noticeable side effects. you can try.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've tried all of the ideas in this thread, and then some...

..but nothing works!

3 GB and counting this afternoon!!!

3 out of 4 upgraded computers work (mostly) OK, but the 4th is giving me trouble!

If you also have high ram usage you could try the threads about high ram usage of this process, including the ones on Win8. The behavior of high cpu without high ram usage seems more specifically related to the Win10 release build. 

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was do clean install, and I didn't touch any settings in windows at all, now I don't have any problem.. Cpu is 0%-3%.

This is a second day:

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After doing more than 2 dozen traces there seems to be something in common with these runtime broker issues.   The commonality is that backgroundtransferhost.exe is causing runtime to consume huge amounts of cpu cycles.

It could be as simple as something downloading in the background OR it may be windows built in P2P sharing the files across the internet.

I would

1-run the system file check just to find the state of the OS

2-Check your network traffic

3-Disable (at least to test) the P2P sharing in all settings>update>advanced>chose how updates are delivered

This is a sample of what it looks like

Cat herder
Windows Insider MVP
MVP-Windows and Devices for IT
http://www.zigzag3143.com/

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Your efforts are greatly appreciated. 

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

have you tried checking windows store?

some apps might be downloading there,

mine got fixed after updating all the apps.

it seemed like runtime broker was triggered by those apps downloading in the background.

hope this helps.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I would like to get to the bottom of this as well.  It has me curious. 

Don't know if this is definitive yet but with more than a dozen similar results it is a lead in the right direction.

Happy to help.

Cat herder
Windows Insider MVP
MVP-Windows and Devices for IT
http://www.zigzag3143.com/

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.