Windows shows no internet access but my internet is working fine.

When I am connected to my home wifi, Windows keeps telling me that I have no internet even though I can browse the internet through Chrome, Firefox and even Edge works fine. As a result, Windows apps such as Mail and Security either do not work or do not work fully. I have to do a network reset every time this happens and it fixes the problem for anywhere between 2 mins and 1 week. And again the same problem occurs. I am on Windows 10 Home 1903 Build 18362.418. System: Acer AN515-42.
|
Answer
Answer

This is a common problem across tens of thousands of people. Any Google search will show you the same thing. I'm a MSP and I've got a new client that's been hit with this and I can't find a solution for it.

Note: Reinstalling Windows is a stupid tier-1 suggestion no one should ever toss out for stupid stuff like this. This is a KNOWN windows glitch lately and to my knowledge there's still no guaranteed fix. (I found this thread myself while searching for a new answer too.)

In my case, brand new machines - all Acer, all six machines having the same problem, plus about 3 other Dells.

Some are Win10 Pro. Some are Win10 Home 1903 build 18326.449.

Symptoms Include:

Trying to launch word/excel results in "Let's try that again" errors saying "Please connect your device to the internet." Obviously it's connected to the internet, because I'm remotely connected to it via Team Viewer.

The Windows Task Bar icon says "No Internet Access." This too is incorrect because I can browse the network with no problem. (See below). 

Network is fine, obviously.

I'm remoted in to the machine AND can load a browser fine, so it's not the internet.

Network reset used to fix this issue most of the time, but that's not worked on any of these machines.

We need a fix for this...

Best Regards,

Tommy Jordan

103 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

Hello,

Please try these steps after creating a System Restore point:

1. Press Windows + R keys.

2. Type regedit, click OK.

3. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet.

4. Make sure following values exist in right pane of Internet:

"ActiveDnsProbeContent"="8.8.4.4"

"ActiveDnsProbeContentV6"="2001:4860:4860::8844"

"ActiveDnsProbeHost"="dns.google"

"ActiveDnsProbeHostV6"="dns.google"

"ActiveWebProbeHostV6"="www.msftconnecttest.com"

"EnableActiveProbing"="1"

5. Restart your Computer or disable/enable your connection and reboot your router.

If you need more help with above mentioned steps, check this video:

https://www.youtube.com/watch?v=v3CkXHgj6Ig

Hope this helps!

Referenced from: Arash.Dargahi's post on page 4 of this thread.

___________________________________________________________________________________________________

Microsoft MVP (Windows IT Pro), since 2014 · Windows Insider MVP · Windows Help (www.kapilarya.com)

232 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 14, 2021 Views 145,140 Applies to: