Windows 10 pc keeps disconnecting from internet

My pc has been disconnecting from the internet since i got it. It cut out when i worked, when i play games and especially when i watch anything on youtube.

I have researched this all over the internet and tried so many things to fix this, such as "network adapters>power management>unchecked allow this computer to turn off this device to save power", setting power options to "balanced" and a couple other things. I am not on a proxy, tried troubleshooting the network adapter and so on.

The weird thing is, all of the other devices in the house will stay connected while i disconnect, but occasionally while i stay connected, the other devices disconnect. This gets very annoying very quickly, and it has been an ongoing issue since i got my pc.

It has even costed me a comfy, work at home job. Any info or fix related to this issue would be greatly appreciated.

|
Open Start > Settings > Update & security > Troubleshoot
Scroll down
Click Network adapters
Click Run the Troubleshooter

When complete, restart to see if the problem is resolved.

If that does not work

Press Windows key + X
Click Device Manager
Expand Network Adapters
Select the Network card listed,
Select “Update Driver”
This should give you a choice of drivers - select the oldest one
Wait a few minutes while it installs the old driver

or

press Windows key + X
Click Device Manager
Expand Network adapters

Right click your adapter
Click Uninstall


Exit Device Manager, restart. Windows 10 should detect the network adapter then reinstall it. Check if you can connect and browse.

also try:

Open Start > Settings > Network & Internet > Status


Scroll to the bottom then click Network reset.

Click Start > Settings > Network & Internet > Wi-Fi > Manage known networks > select the Cloud wireless network
Click Forget

Restart

Click the Network icon in the Taskbar
Try connecting again.

Disable Energy Efficient Ethernet in "Client for Microsoft Networks"
Press Windows key + X
Click Device Manager, expand Network Adapters, right-click the adapter > Properties > Power Management, and then clear the Allow the computer to turn off this device to save power check box.

If you don't have that option, see other ways to disable it:

https://blogs.technet.microsoft.com/exchange/20...
Best regards,
Andre Da Costa
Independent Advisor for Directly

146 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Tyram, Please try this:

Click your Start Button, type cmd and choose Command Prompt

Run this command and hit Enter:

ipconfig /flushdns

Close Command Prompt

Open the Settings App

Go to Network and Internet

Click the Network Reset button

Wait for your PC to automatically restart after 5 minutes
___________________________________________________________________

Power to the Developer!

MSI GV72 - 17.3", i7-8750H (Hex Core), 32GB DDR4, 4GB GeForce GTX 1050 Ti, 256GB NVMe M2, 2TB HDD

104 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated September 20, 2021 Views 149,354 Applies to: