WiFi issues with Creators Update

Hi everyone! 

im running lenovo x1 carbon 3rd gen with all new installed drivers and updates. 

after installing Creators Update (Microsoft Windows [Version 10.0.15063]) i have extremely slow wifi. i have installed 19.50.1.5 ver of the driver for Intel 7265

so i check that im using latest intel driver (from march 2017), ran netsh winsock reset, trying to reinstall drivers and wireless software, trying to do network reset - all with no result.

also i have try to turn off firewall and antivirus software, and the same no result..

i have stable connection, good ping response, but pages in all the browser are opening extra slow. 

so i do some test in the same network with other laptop without CU installed - and im pretty sure that is no internet problems in my place. 

could you please help with any suggestion? 

 

Question Info


Last updated November 8, 2018 Views 70,611 Applies to:
Answer

Microsoft has recently announced a fix for this particular “RSC” (Receive Segment Coalescing) issue, with OS Build 15063.447

Try installing the latest Windows 10 cumulative update (KB4022716, OS Build 15063.447) to see if it helps. To install the update, go to Start >Settings > Update & security > Windows Update >Check for updates. To confirm OS Build, go to Start > Settings >System > About. More information on the update is in the Windows 10 update history page here.

For reference, the issue they fixed states:

“Addressed issue where, after updating to the Creators Update, devices that have Receive Segment Coalescing (RSC) enabled have significantly low wireless throughput.”

Note about previous workarounds:
If you had manually changed RSC or MTU or installed older drivers.... and now have Build 15063.447 or later, you should undo those workarounds, restart the PC, and test that wireless performance works as expected.

7/7/2017 Update: For my particular testing scenario, it looks like the network administrators must have implemented a workaround on their end. I say this because things were working correctly, even when I reverted the workarounds and had not yet installed 15063.447. I suspect they disabled Rsc or lowered MTU ranges, on the Wi-Fi switches. Therefor, I am unable to test Microsoft's fix, as I am unable to reproduce the problem.

I will still list the story and workarounds, below, for reference.

==============================================================

I found 3 workarounds! Please read my entire post!


Also, if you are having this issue, please copy/paste this Feedback Hub link:

https://aka.ms/Pna0p3

... then click "Upvote"! (That way, Microsoft can know it is widespread, while getting your PC's details).

==============================================================

My story:

My wife's HP Spectre x360, which has a "Intel(R) Dual Band Wireless-AC 7265", has this issue caused by the Windows 10 Creators Update version 1703. On our home network, everything runs great, but on the work network... Web pages load extremely slowly, or stop loading altogether, even though signal is great and ping is great. It is easily reproducible, even if Windows Defender and the Windows Firewall are both completely disabled; netsh reset doesn't help. Uninstalling Wireless Display (Wi-Di), did not help the situation.

All these Intel PROSet drivers had the same problem:
Wireless_19.50.1_PROSet64_Win10: 18.33.6.2 (2/19/2017): Has problems
Wireless_19.40.0_PROSet64_Win10: 18.33.5.1 (10/9/2016): Has problems
Wireless_19.30.0_PROSet64_Win10: 18.33.5.1 (10/9/2016): Has problems
Wireless_19.20.3_PROSet64_Win10: 18.33.5.1 (10/9/2016): Has problems
Wireless_19.20.0_PROSet64_Win10: 18.33.3.2 (5/3/2016): Has problems
Wireless_19.10.0_PROSet64_Win10: 18.33.3.2 (5/3/2016): Has problems
Wireless_19.2.0_PROSet64_Win10: 18.33.3.2 (5/3/2016): Has problems
Wireless_19.1.0_PROSet64_Win10: 18.33.3.2 (5/3/2016): Has problems
Wireless_19.0.1_PROSet64_Win10: 18.33.3.2 (5/3/2016): Has problems
Wireless_18.40.4_PROSet64_Win10: 18.33.3.2 (5/3/2016): Has problems
Wireless_18.40.0_PROSet64_Win10: 18.33.0.2 (1/28/2016): Has problems
Wireless_18.33.0_PROSet64_Win10: 18.33.0.1 (1/5/2016): Has problems
Wireless_18.32.0_PROSet64_Win10: 18.32.0.5 (12/22/2015): Has problems
Wireless_18.30.0_PROSet_64: 18.30.0.9 (11/3/2015): Has problems

Fortunately, I found some workarounds!

==============================================================

Workaround #1 (Recommended by Microsoft):

Disabl"Receive segment coalescing" (Rsc) on your wireless adapter

Tripp Parks [MSFT], provided an excellent workaround, that is recommended by Microsoft, and appears to resolve the issues. Thanks Tripp! And Tyler [MSFT] has provided a tool that automates it. Thanks Tyler!

Steps to disable Rsc using Microsoft's automated tool:

1) Download the ".diagcab" file located here:

https://aka.ms/diag_cssemerg11005

2) Run it, and let it see if it can determine the problem and fix it.

3) Re-test your wireless internet connection.

If you'd rather do it manually, then I have those steps below.

Steps to disable Rsc manually:

1) Open an Admin Command Prompt window:
Start > All Apps > Windows System -> Right-click "Command Prompt" > More > Run as administrator
... Note: If you want this available on your Start's Right-click menu, you can go to Settings > Personalization > Taskbar > Replace Command Prompt > Set to Off

2) Get your network adapter name:
powershell Get-NetAdapter

3) Note your adapter's name (mine is: Wi-Fi)

4) Get your network adapter "Receive segment coalescing" (Rsc) settings:
powershell Get-NetAdapterRsc
... Mine listed a table that had 1 row, for adapter name Wi-Fi, that had IPv4Enabled True, and IPv6Enabled True

5) Disable Rsc for your network adapter:
powershell Disable-NetAdapterRsc -Name ADAPTER_NAME_FROM_BEFORE
... Be sure to replace ADAPTER_NAME_FROM_BEFORE with whatever your network adapter name is, without quotes

6) Verify Rsc is disabled for ipv4 and ipv6, on your network adapter:
powershell Get-NetAdapterRsc
... Should now show IPv4Enabled False, and IPv6Enabled False, for your network adapter

7) Re-test your wireless internet connection.

So, did this workaround work for you?
Upvote that Feedback Hub item, click "Solved my problem" here, then hit Reply here and let us know!
Microsoft and Intel, can you please fix this? Thanks.

==============================================================

Workaround #2:
Change MTU to 1400 (from Default, which may be 1500)

PB.Anton noticed the following, which I confirmed -- Thanks PB.Anton!

17.15.0.5 driver: MTU=1400: WORKS

17.15.0.5 driver: MTU=1500: WORKS

19.50.1.5 driver: MTU=1400: WORKS

19.50.1.5 driver: MTU=1500: DOES NOT WORK

To VIEW your MTU:
Right Click Start > Command Prompt (Admin) > Type or right-click-paste the following command:

netsh interface ipv4 show subinterfaces

.... make a note of your wireless one, it might be called "Wi-Fi" or "Wireless Network Connection"

To CHANGE your MTU to 1400:

Right Click Start > Command Prompt (Admin) > Type or right-click-paste the following command:

netsh interface ipv4 set subinterface "YOUR_WIRELESS_CONNECTION_NAME" mtu=1400 store=persistent

.... and use the VIEW command to make sure the change was accepted. Then test this workaround - Good luck!

So, did this workaround work for you?
Upvote that Feedback Hub item, click "Solved my problem" here, then hit Reply here and let us know!
Microsoft and Intel, can you please fix this? Thanks.

==============================================================

Workaround #3:
Revert to driver
17.15.0.5 (2/22/2015)

Basically, after doing some more experimentation, I found: 17.15.0.5 (2/22/2015): Works just fine

Get driver 17.15.0.5 (2/22/2015):
- In Settings > Apps > Apps & features, Uninstall Intel PROset completely
- Open Device Manager

- In Network adapters, find your Wi-Fi network adapter

- Right-click, Uninstall (choosing Yes to uninstall other software if prompted)

- Click the "Scan for hardware changes" button at the top of Device Manager

- Let it reload the Wi-Fi network adapter

- Keep Uninstalling, until it reloads the same version it had last reloaded.

...

- If you have 17.15.0.5, great! Read further down this post, to prevent Windows Update from changing it!

- If you do not yet have 17.15.0.5, try this:

- Right-click, Update driver

- Browse my computer for driver software

- Let me pick from a list of available drivers on my computer

- If 17.15.0.5 is available, choose it.

- If you have 17.15.0.5, great! Read further down this post, to prevent Windows Update from changing it!


If you go to Settings > Update & security > Windows Update > Check for updates

... it will offer (and auto-install) the following driver that does NOT work:

18.32.1.2 (12/30/2015): Has problems

This link:

https://support.microsoft.com/en-us/help/3073930/how-to-temporarily-prevent-a-driver-update-from-reinstalling-in-windows-10

... describes how to hide a Windows Update driver. I guess the Anniversary Update makes it easier than before -- Instead of running the Troubleshooter to manually hide it, it's smart enough to know that "Roll Back Driver" will prevent it from being re-offered from Windows Update.

Prevent Windows Update from updating driver 17.15.0.5 (2/22/2015):

- Get driver 17.15.0.5 installed, per instructions above

- Settings > Update & security > Windows Update > Check for Updates

- If it updated the driver version, then go to Device Manager, right-click, Properties, Driver tab, "Roll Back Driver"

- Verify 17.15.0.5 is installed again

- Settings > Update & security > Windows Update > Check for Updates

- Verify the driver does not get updated

So, did this workaround work for you?
Upvote that Feedback Hub item, click "Solved my problem" here, then hit Reply here and let us know!
Microsoft and Intel, can you please fix this? Thanks.

==============================================================

Jacob Klein

320 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Having had poor performance with multiple adaptors - with Media Tek and Realtek chips using Humax and Netgear routers, I found that changing the router to a Cisco router restored the performance.

Note that the Intel driver performed well with the Humax router, and also with the Cisco router.

It therefore may be an issue between the "combination" being used

34 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.