Wifi internet slower after upgrading to Windows 10

Hi everyone, so after I upgraded my hp laptop from Windows 8.1 to 10 the wifi internet has becomes much slower.  I have tested on Edge, Firefox, and Chrome but in all of them pages load very slowly and videos buffer every couple of seconds for a long time.  I have updated my laptop's driver but that only seemed to have helped for about 30 minutes and then went back to having slow internet again.  Every other device in my house that is uses the wifi loads internet pages and videos as fast as it always had.  Has anyone else ran into this same problem and found a solution yet?

I appreciate any assistance.

 
Question Info

Last updated August 1, 2018 Views 9,894 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Welcome to Microsoft Community.

I understand your inconvenience. We will assist you with it.

Follow the steps provided below.

Method 1:

Configuring DNS server address:

  1. Press Windows key + X key, and click on Control Panel.
  2. Click Network and Internet and click on Network and Sharing Center
  3. Click Change Adapter Settings on left pane.
  4. Click the Wi-Fi connection you want to configure.
  5. Click Change the settings of this connection on the top of the window.
  6. Scroll down to Internet Protocol Version 4 (TCP/IPv4) and Double click on it.
  7. Click Use the following DNS server address, fill the DNS server information for your ISP.
  8. Click OK and close all windows.

If the issue still persist, follow method 2.

Method 2:

Try resetting TCP/IP and check if it works.

  1. Press Windows key + X key, and click on Command Prompt (admin).
  2. Type the following command in Command Prompt and press ENTER:

netsh int ip reset c:\resetlog.txt

If you do not want to specify a directory path for the log file, use the following command:

netsh int ip reset resetlog.txt

  1. Reboot the computer.

 

If the issue still persist, follow method 3.

 

Method 3:

If issue persists, kindly follow the steps given in below link and check if it helps:

http://windows.microsoft.com/en-IN/windows/network-connection-problem-help#network-problems=windows-81&v1h=win81tab2&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

 

Hope it helps. Do let us know if your issue is resolved. For any further query, feel free to contact us.

Thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for the assistance.  I tried the methods you provided but it only worked temporarily.  After shutting down my laptop for the night and testing it again in the morning the internet was slow again.

42 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am also having the same issue. I have lenovo Yoga 3 14 Laptop which is giving very low browsing speed after upgrading to Windows 10. Also, while playing online videos in youtube or in any other platform it keeps on buffering even though it is connected to a high speed wifi whereas another laptop running on windows 8.1 is perfectly fine with the same wifi connection at the same time at the same place.The smartphone that I use when connected to the same wifi is also not having any internet speed issue. The Yoga 3 14  laptop when earlier running on Win 8.1 was also not having any browsing/buffering issue. I updated all drivers from lenovo website , whatever update is available I updated but nothing helped. It all started after upgrading to Windows 10. I applied Method 1, Method 2 and Method 3 but all in vein.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Alerpio,

I apologies for the delay in response.

I understand the inconvenience caused to you. I will be glad to assist you with your issue.

Method 1: Update network drivers and check if it helps:

Follow the steps below.

1) Press Windows + X, click on Device Manager.
2) Expand Network adapter, right click on device and select Uninstall

Method 2: Install the Network drivers in Compatibility Mode.

Compatibility mode runs the program using settings from a previous version of Windows.

Follow these steps to install the drivers in compatibility mode and check if that helps.

a. Download the driver from the manufacturer’s website.

b. Right-click on the driver setup file and click on ‘properties’.

c. Click on the ‘compatibility’ tab and check the box ‘Run this program in compatibility mode for’ and select Windows operating system from the drop down menu and proceed with the installation. Once this is done, restart the computer and check if the issue persists.

For reference:

How to: Install and Update drivers in Windows 10

Hope this information is helpful. Do let us know if you need any further assistance, we'll be glad to assist you.

Thank You.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

hp recently released updates to the drivers so I have updated them and with the newer Windows update my internet is now back to normal.  Thank you for your assistance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Syed,

Thank you for the suggestions.  Unfortunately none of this worked.  Unless I can find a solution, I'm going to downgrade to Windows 7. I've really enjoyed the new interface, but my connection is too important for my business.

HP Pavilion dv6 Notebook PC

Intel Core i-5-3210m

64 bit OS

Intel Centrino Wireless N-2230

We have other computers and devices that are running fine, including 2 desktop PCs that are running Windows 10.

Am I just out of luck at this point?

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi 

I am using Windows 10 on my HP Pavilion 

After upgrade my wifi speeds are ridiculously low 0.2 mbps

i am supposed to downgrade them back to windows 8

Thanks and regards

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have a Dell Venue 11 pro tablet and have the same problems. Down to 0,2 mb download speed. When downgrading to Win 8 I am back to 10 mb download sped.

To bad, really liked win 10. But it is not ready yet.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Welcome to Microsoft Community.

I understand your inconvenience. We will assist you with it.

Follow the steps provided below.

Method 1:

Configuring DNS server address:

  1. Press Windows key + X key, and click on Control Panel.
  2. Click Network and Internet and click on Network and Sharing Center
  3. Click Change Adapter Settings on left pane.
  4. Click the Wi-Fi connection you want to configure.
  5. Click Change the settings of this connection on the top of the window.
  6. Scroll down to Internet Protocol Version 4 (TCP/IPv4) and Double click on it.
  7. Click Use the following DNS server address, fill the DNS server information for your ISP.
  8. Click OK and close all windows.

If the issue still persist, follow method 2.

Method 2:

Try resetting TCP/IP and check if it works.

  1. Press Windows key + X key, and click on Command Prompt (admin).
  2. Type the following command in Command Prompt and press ENTER:

netsh int ip reset c:\resetlog.txt

If you do not want to specify a directory path for the log file, use the following command:

netsh int ip reset resetlog.txt

  1. Reboot the computer.

If the issue still persist, follow method 3.

Method 3:

If issue persists, kindly follow the steps given in below link and check if it helps:

http://windows.microsoft.com/en-IN/windows/network-connection-problem-help#network-problems=windows-81&v1h=win81tab2&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

Hope it helps. Do let us know if your issue is resolved. For any further query, feel free to contact us.

Thank you.

I followed your steps in Method 1 and Method 2.  After completing Method 2, my browsers can't even load any pages although the internet is connected.  

How do I solve this?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 May not work on yours but worth a try. I have a N router and N wireless card in my laptop but was running at G speed. The protocol on laptop network card was set to Auto. I found B protocol disabled in laptop network card property's says to self what do I have to lose. Enabled B and believe it or not N speed increased to full speed. You won't believe how much googling and poking around in settings took place before I found that.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.