VPN issue with KB4343909

Hello,

I usually use MSFT VPN client in my Windows 10 laptop to connect to a Meraki MX 64 as the VPN hub to get access to my resources. Everything has been running smoothly (more or less) till today.

No matter how I tried, I never got a VPN connection following the same steps and I didn't receive any error. VPN client just said "Trying to connect" for ever, w/o an error message or success message.

As there should be something different I started to think about it and suddenly I realized that this morning some fixes from MSFT Update have been installed in my computer so I took a look. I saw two fixes, "KB4343909 and KB4343902". Second one was related to Adobe while the first one seemed to be more important.

So I decided to uninstall the first one and after some reboots, now I can connect again using VPN client. So it seems there is a problem between this fix and the VPN client or at least, there are some side effects.

I've been looking for some additional information about that fix, but I have found nothing relevant to this issue.

Have you heard anything related to this? Is there anything I can do to apply the fix while using the VPN client w/o problems?

Thank you very much.

Moved from: Windows 10 / Security & privacy

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Dan,

Since the issue started after installing the latest build, we don't have much information yet as to what might be causing your VPN connection to stop working. However, we would like to troubleshoot the issue to determine what triggers it and how it can be solved. 

By the way, have you tried troubleshooting the VPN connection issue while the KB4343909 was still installed on your computer? If so, what were the steps you've performed? Did you get other error messages aside from the "Trying to connect" message? 

If it's okay with you, I would like to suggest to reinstall the KB4343909.  Once reinstall, you may run the Network Troubleshooter and perform the Network Reset to help us to further diagnose in case the issue persists. Below are the steps:

Network Troubleshooter

  1. In the Cortana search, type in Network Troubleshooter, then select Identify and repair network problems from the list of results.
  2. Follow the on-screen instructions.

Network Reset

  1. Navigate to the Windows key > Settings > Network & Internet > Status > Network reset.
  2. On the Network reset screen, select Reset now.
  3. Click Yes to confirm.

If the above steps doesn't help, then I encourage you to submit this issue using the Feedback Hub so our software engineers will be able to look into the problem and conduct further investigation regarding the matter. Please follow these steps to submit a feedback.

  1. In Cortana search, search for Feedback Hub, then launch it.
  2. In the left panel, navigate to Feedback, then Add new feedback.
  3. Select the Problem, and share any relevant information. Choose also the appropriate category and subcategory regarding the issue.
  4. If possible, reproduce the problem(s) after clicking Begin monitoring (or Start capture) near the end of the form, and Stop monitoring when done.
  5. Click Submit once the form is complete.
  6. Click Continue using Feedback Hub.
  7. Click My Feedback at the top, then find the item you submitted.
  8. Open the item that you have submitted, then click Share.
  9. Click Copy link, then paste the link here in your response.

I'm looking forward to your response.

Regards.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Vanessa,

Yes, happy to help with this issue. Patch has been reinstalled automatically as windows update did "notice" it wasn't installed. So now, my system has the patch again. Today I'm at home so I can't connect but tomorrow I'll be OoO and I will try to connect again.

If I see any problem I will follow your steps and report it properly.

Thank you very much.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks you as well, Dan. We'll be looking forward to hearing from you.

Regards.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have not seen anything in the community posted regarding VPN issues but I'll keep an eye out. https://support.microsoft.com/en-us/help/4343909/windows-10-update-kb4343909  Is the Merak up to date on patches?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello,

Sorry to report that......everythig remains the same, and the problem is still there.

Path was reinstalled and today I tested the vpn again.

 

As you can see, the message "Connecting" or "Trying to commect" is the same (I don't know how it's translated in the English version). No error, no message, it keeps forever doing whatever it's doing.

Regarding Meraki, I'm currently using MX 13.33. that seems to be the latest version. Moreover, it doesn't report any problem while trying to connect. I also did that Vanessa asked me to do, but there is no difference.

So I'll open the feedback request to see what's going on. In the meantime I can troubleshoot my VPN connection if that helps, but I will need some help or guidance in order to perform useful tasks and diagnosis.

Thank you for your help

 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Ooops, I can't report the issue with "feedback hub". It seems that need to set diagnostic level, at least, to minimum, while my company has disabled that feature in my computer. I can't raise the level and thefore I can't log the issue.

Sorry!!!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'd recommend contacting your company's help desk, seeing if others are reporting the same thing, and having them open up a support case as the quickest way to get a resolution.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you but I don't think it's going to work because it's outside their scope. Anyway I appreciate your efforts.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Isn't there some division in your company that deals with patching side effects?  Bottom line Microsoft can't just fix something without log files.  

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Susan,

I totally agree with your comments, that's the reason I'm asking for help and I'm willing to provide you with log files or whatever you may need. That's what I said from the beginning and that's what I've been doing.

Unfortunately I've been googling how to log the VPN connection with no success. I found this article (https://support.microsoft.com/en-us/help/325034/how-to-troubleshoot-a-microsoft-l2tp-ipsec-virtual-private-network-cli) but it's quite old!!!

So if you or someone else can point me to the right direction to track and diagnose my VPN connection, I will do.

Thank you!!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated July 25, 2020 Views 3,268 Applies to: