SOLVED: Homegroup lost - Problem found in troubleshooting: "One or more network protocols are missing on this computer"

Our main PC(desktop) which is the one I'm using right now had a homegroup set up on it with two other PC's(1 desktop & 1 laptop) connected to it. Shortly after installing "Cumulative Update for Windows 10 Version 1511 for x64-based Systems (KB3118754)" (for the two desktop PC's), I noticed that Steam went offline and said "NO CONNECTION" at the bottom, although the internet itself was still working as I was able to visit websites and such. After restarting Steam and seeing that the probelm still wasn't fixed, I decided to just restart my PC since the majority of problems tend to be temporary and fix themselves upon restarting(from my experience anyways). 

When my PC booted back up and I got to my desktop(on the Admin account), I checked Steam and saw that the problem was fixed. However, I then noticed that when I went to the Homegroup tab on the sidebar in "This PC," I was no longer being counted as being in or as the host of the homegroup, but instead it's giving me the option to join a homegroup but doesn't mention who set it up.

So I decided to open "Troubleshooting" and after using "Windows Network Diagnostics" for "Homegroup/Network" it came up with the below error:

And not sure if you need it but here's the first two tabs of the more detailed info on the problem.

I also checked the other two PC's, both of which are also now disconnected from the homegroup too, however only my main PC and the other desktop PC come up with the above mentioned error when running diagnostics. The laptop seems fine with the exception of being disconnected from the homegroup as well. Another thing to note is that the laptop is the only one that actually states the name of the PC which the homegroup originates from(my main PC). Also, when attempting to connect to the homegroup from the other desktop PC, it comes up with an error saying that the homegroup is no longer available on the network(not exact wording, but similar to that).

Things I've tried:

- Restart of the main PC.

- Restart of router.

- Windows Network Diagnostics

- Cmd command "netsh int ip reset" which I found while googling a solution to this problem.

- Joining the homegroup which is still recognized as a homegroup but somehow isn't available.

Having a homegroup is quite useful to us, especially when it comes to remote printing since only one of the PC's has a printer. Any solution besides a factory reset will be welcome, and hopefully I provided enough information but if not, just ask for more. Also, if you need to see the system specs of any or all of the PC's then I can provide them. 

Update: I just now updated the laptop with the newest Windows update to see if diagnostics would come up with the missing protocols error on there too, but it didn't. However, the laptop has now stopped displaying the name of the PC that the homegroup originates from.

 

Question Info


Last updated December 16, 2018 Views 18,218 Applies to:
Answer

SOLVED: After finding an article and following its instructions, it seems the problem is fixed now. Although there's a catch. If you have multiple computers on a homegroup(which I assume you do), then after deleting those files( on all of the computers you need to shut down all computers completely(NOT restart. Please note the above mentioned 'Services' are left on). Then turn on only the computer which you want to host the homegroup from. Then go to either 'Homegroup' in the control panel or go to it from within 'File Explorer' in the side panel. Now instead of giving you the option to only join a 'ghost' homegroup, it should now give you the option to 'Create a Homegroup.'

You must create the homegroup before turning on any of the other computers. And if when you turn on the other computers, your host computer seems to "disconnect" from the homegroup again, then what you need to do is go to 'Homegroup' in control panel and change the homegroup password. That should officially reconnect your host computer. Now if that's taken care of, you can now go get the other computers to join. And just to be extra safe, only connect one computer at a time - don't try to connect all the other computers at the same time(It might work but you don't want to risk it).

I hope this fix(or the one mentioned by Geethu B) works for anyone else having this problem :)

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.