Question

Q: Router NOT showing up in Network Infrastructure

Hi,

I have three computers on my home network. Computer #1 is connected to my Cisco DPQ3925 router via ethernet, as is computer #2 via WiFi. I can logon to the router’s web administration page via a web browser on both of those computers.  Computer #3 is also connected to the same router via ethernet, and, up until recently, I was able to access the router’s admin page on it as well; no problem. But now, on computer #3, when I type 192.168.0.1 (or 192.168.1.1) in the address bar of the web browser (or use the “router123” web page,) I am redirected to the Microsoft Windows Internet Information Services web page. I’ve used Edge, IE, Firefox, and Google Chrome, all with the same result.

            There is no entry in the “Hosts” file causing this redirection. I’ve consulted my ISP’s technical support twice and they have been unable to solve the issue (Cisco says the ISP owns the router and it uses the ISP’s software.) I’ve exchanged the router for an identical substitute and have the same problem. I’ve reset both the old and the new routers to factory defaults, and upgraded the firmware: No improvement. I’ve reset the winsock, and released and renewed the IP address (although I’m using static IPs on all my devices.) Clearly, something has changed on computer #3, but I have no idea what or when, and, since everything else works fine, I’m hesitant to do a restore to an earlier time.

            I’ve come to suspect that the problem lies in the fact that, despite being able to access the both my home network and the internet, computer #3 is not “seeing” the router. For example, both computers #1&2 list “Cisco DPQ3925” under Network Infrastructure in their respective Network Explorers. However, computer #3 does not. It can ping the router, and private network discovery and file/printer sharing are turned on. I’ve turned off the Windows firewall and Windows Defender. The Server service, all the Network services, and all three “Peer” and all three “Diagnostic” services are running. Still the router does not appear in #3’s Network Explorer.  I’ve typed “\\Cisco DPQ3925”, but am told “Windows cannot access \\Cisco DPQ3925,” which, as I understand it, means, as far as computer #3 is concerned, the router does not exist. However, I am also given error code 0x80004005, which, according to various sources, could mean a missing DLL or corrupted Registry (I update the computer, run Windows Malicious Software Removal Tool, and clean the Registry with CCleaner regularly.) And, when I ran the diagnostics, I was told “the DNS server might be unavailable.” However, the DNS service is up and running.

I’m at my wits end. Can anyone help me?

·       Is there a connection between this failure to list the router in the Network Explorer and my inability to access the router’s admin page?

·       What could be making the router “invisible” to the Network Explorer, and how can I change that?

·       Does the fact that Windows “cannot access \\Cisco DPQ3925” confirm that it cannot see the router because it doesn’t think it’s there? If so, what can I do?

·       Does error 0x80004005 mean there’s a missing/corrupt DLL or Registry file? If so, how do I go about finding/repairing the problem file?

·       Is it caused by a missing “share,” and if so how do I create one?

·       Do I need to “mount” the router on the C:/ drive? If so, how?

·       Any other ideas?

Please help, I’m at a complete loss and nobody I’ve consulted has a clue! Thanks in advance for any advice/guidance you might give.

Answer

A:

Hi,

Majority of the times, this error is caused in a Virtual box or when you try to access the shared folders. If you are one of those who is facing the Error 0x80004005. If you are facing this error in Virtual Machine, the main cause behind this is a registry key issue. Just follow the below-mentioned steps and your issue will be solved.

Method 1

  1. Open the Run dialog box. For that press Windows Key and R .
  2. In the dialog box, type regedit and select OK.
  3. In the Registry editor, you need to go to the following registry path:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers] “C:\Program Files\Oracle\VirtualBox\VirtualBox.exe”=”DISABLEUSERCALLBACKEXCEPTION”

Here you need to check whether the key is present there or not. In case the key exists there, delete the key and try to run the Virtual Machine.

Method 2

  1. Hold Windows Key and Press R
  2. Type regedit and click OK
  3. You need to navigate to the following Registry path: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  4. For 32 bit Windows system, you need to create a new DWORD value called LocalAccountTokenFilterPolicy.
  5. For a 64 bit Windows system, make a QWORD (64-bit) called LocalAccountTokenFilterPolicy.

In either case, set the value to numeric 1 (meaning on), and remember to click OK.

Usually, the LocalAccountTokenFilterPolicy remains auto set but if it isn’t just click on it and change the value to 1 from 0. Once this is done, restart your computer and see if you can now access the shared drives.

Let us know how it goes.

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 1,972 Last updated: March 1, 2018 Applies to: