Qualcomm Atheros AR9485 compatibility with Windows 10

I have an Asus X series laptop which came with Windows 8 and Qualcomm Atheros AR9485 Wireless adapter and driver installed. It worked perfectly for the last year. I have now upgraded(?!) to Windows 10 and it now won't connect with the Internet. My attempts to diagnose the problem suggest that there is a problem with the adapter and/or its driver. Luckily my PC, on which I am writing this, is still working, but obviously I cannot now use the laptop to download new driver software. How do I resolve this problem please?
 

Question Info


Last updated July 28, 2019 Views 37,716 Applies to:
Answer
Answer

Hi James,

Thank you for posting your query in Microsoft Community.

From your description I understand the issue might due to the incompatible drivers. Try to download the latest compatible drivers on your PC and use any external Storage device to transfer and install them on your Laptop.

If no updated drivers available on the Manufacturer’s website for windows 10, then trying installing drivers in compatibility mode. Compatibility mode runs the program using settings from a previous version of Windows.

Follow these steps to install the drivers in compatibility mode and check if that helps.

a. Download the driver from the manufacturer’s website.

b. Right-click on the driver setup file and click on ‘properties’.

c. Click on the ‘compatibility’ tab and check the box ‘Run this program in compatibility mode for’ and select Windows 8/8.1 operating system from the drop down menu and proceed with the installation. Once this is done, restart the computer and check if the issue persists.

Let us know if problem still persist, we're glad to assist you. Hope this will address your query.

156 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.