Mobile hotspot is not working in Windows 10 after anniversary update

Need help!

I use the command prompt "netsh wlan start hostednetwork" to turn my laptop ( with windows10) into a wifi hotspot. It used to work pretty well, until a recent updation of windows 10 ( the anniversary update). The in-built mobile hotspot ( the latest feature) is not working...It just reads "we can't setup mobile hotspot". And when I try to use my old command prompt way, wifi signal of this hosted network is shown on other devices but it also says no internet access.

Note: My ethernet is shared

I feel there is a conflict between the ip addresses of hostednetwork and the new update's driver.

What should i do to resolve this? I just can't manage without the hotspot option.

Sruthi.N

 

Question Info


Last updated June 16, 2019 Views 67,916 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Need help!

I use the command prompt "netsh wlan start hostednetwork" to turn my laptop ( with windows10) into a wifi hotspot. It used to work pretty well, until a recent updation of windows 10 ( the anniversary update). The in-built mobile hotspot ( the latest feature) is not working...It just reads "we can't setup mobile hotspot". And when I try to use my old command prompt way, wifi signal of this hosted network is shown on other devices but it also says no internet access.

Note: My ethernet is shared

I feel there is a conflict between the ip addresses of hostednetwork and the new update's driver.

What should i do to resolve this? I just can't manage without the hotspot option.

Sruthi.N

Hi Sruthi,

For step-by-step instructions on how to troubleshoot your Mobile Hotspot issue, kindly refer to the post of Pratiksha on this link.

For more information regarding network connection concerns, visit this link.

Let us know if you need further help.

Thank you.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved this problem by removing the manual settings of wifi hotspot:

* in "Network Connections", disable the sharing of ethernet

* delete registry key HostedNetworkSettings in: (the key name is the same as folder name - be careful)  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WlanSvc\Parameters\HostedNetworkSettings\

Then use the built-in "Mobile Hotspot" for sharing the wired internet, it should work OK.

465 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Woot !

Beautiful, that fixed it for me too!

I had exactly the same symptoms (had previously used netsh to create hotspot, did the anniversary edition upgrade, saw the mobile hotspot option appear in network settings, saw that my netsh connection had stopped working, tried to create a hotspot with the new option but only got a hotspot through which remote devices could not access the internet). 

Your solution fixed that, and now the new hotspot option creates a hotspot that does share internet access. 

Many thanks for sharing.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Deleting registry keys didn't work for me.. I still cannot get an IP from a mobile connected to the mobile hotspot network.

After Annyverssary update I discovered the WiFi network was not able to connet too since the update (I think) set option on IPv4 setting to "use  the following IP" without IP and "use the followin DNS" without DNS.

So I changed it to get IP and DNS dynamically on WIFI, LAN and hotspot too..

But it doesn't solve the problem on the hotspot (even on the shared WIFI I'm able to connet to internet)

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

worked like a charm!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This worked, but later I have report of identity theft attempt.  I am worried (1) did registry edit cause that, or (2) is hotspot not secure?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This worked, but later I have report of identity theft attempt.  I am worried (1) did registry edit cause that, or (2) is hotspot not secure?

There is no way in the world that doing this change in the registry can make you more (or less for that matter...) skeptical to be hacked/ID stolen.

Also, a hotspot is as secure as your network is in general, not less and not more. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Using the device that you're trying to connect, try manage network settings and add change the IP settings to Static then add an IP address of your choice.

That fixed the IP problem but it did not fix the internet sharing problem 

I also tried deleting the reg file.. and that didn't work ether. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


windows 10 mobile phone hotspot issue  "We can not share the internet connection because ......"


Solution :


Step 1 : At first contact with your network operator for your internet settings details. Such as : Profile name, APN ( Access Point Name) etc. Normally need only these two rest you can keep those as it is or left blank/null. For some operator end user can get internet setting through SMS.


Step 2 : Settings > Cellular & SIM > For e.g SIM 1 us being used for cellular data > scroll little bit below and select to SIM 1 Settings > scroll little bit below and select to Internet APN ( just manually add new apn)


Step 3: Enter Profile name and APN scroll little bit below and Save it. Normally need only these two rest you can keep those as it is or left blank/null.


Step 4: Settings > Cellular & SIM > enable Data connection


Step 5: Settings > Mobile Hotspot and switch it on.


Step 6: Issue will resolve. You can do the same for MMS.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved this problem by removing the manual settings of wifi hotspot:

* in "Network Connections", disable the sharing of ethernet

* delete registry key HostedNetworkSettings in: (the key name is the same as folder name - be careful)  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WlanSvc\Parameters\HostedNetworkSettings\

Then use the built-in "Mobile Hotspot" for sharing the wired internet, it should work OK.

Amazing, thanks a lot. I was trying everything but this was the only option that worked! It works in the Fall Creators Update

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.