Microsoft Edge Won't Open for me only Other Browser Works

I have Windows 10 Home.  Everything worked fine until yesterday.  The last updates were on the 8th.  I checked because I thought that maybe an update was causing the issue but everything worked since the last update.  I click on the blue e to open Microsoft Edge browser and nothing happens.   So at this point I updated the computer to see if the Edge browser would work after updating and it didn't.  I completely shut off my computer restarted it and still nothing.

I have chrome and it opens just fine.  That is the browser I am using to post this.

I am the administrator and there is one other standard user on this computer.

The Microsoft Edge browser works for the standard user on this computer only.

I also have seen other posts where others are having the same issue and the only response has been to run SFC/scannow.   My user account is the administrator account and when I clicked the start button + R to get the run command typed cmd for the command prompt then typed SFC/SCANNOW  I got the error that I had to be an administrator to run that command.  I am the administrator and it wouldn't work.   I can do other tasks on the computer that only the administrator can do except this.

I would think if there was an issue that the SFC/SCANNOW could fix wouldn't the problem be with both users and not just me?

I have also seen where other users have the same problem and ran the SFC/SCANNOW and found no errors and that is where the discussion ends.  What is the next step past running the SFC/SCANNOW if no errors are found?

Is it possible to uninstall just the Microsoft Edge browser and then do a fresh install?

Computer information:

HP Pavilion 500-023w Desktop PC  

Processor Intel Core i3-3240 CPU @ 3.40 GHz

Installed Memory 8.00 GB  7.89 GB usable

System type  64-bit operating system, x64-based processor

There are 2 User Accounts 

Administrator Account = Microsoft Edge doesn't work

Standard Account = Microsoft Edge works just fine

 

Question Info


Last updated December 8, 2018 Views 20,242 Applies to:
Answer

Exact same problem.  Found this answer on another thread, which fixed the problem (not even a restart is required).

Follow these steps:

  1. Open PowerShell, right click in the left corner when the Start window appear and select Windows Powershell (admin).
  2. Copy the below command and press Enter:

Get-AppxPackage | % { Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppxManifest.xml" -verbose }

117 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.