How to change from public to private network (Ethernet - *not* WiFi) in Windows 10

See screen shots - I want to *change* the active network profile from Guest to Private - I can't find any way to do that?  I am not running WiFi - this is RJ-45 Ethernet.  I can't connect to my Homegroup without doing this (second screen shot).  Changing discovery options does *not* solve this problem - before anyone suggests that.

Any ideas?

 

Question Info


Last updated April 4, 2020 Views 19,499 Applies to:
This could be what you're wanting to do:  go to Settings - Network & Internet - Ethernet - click on your Internet connection (Connected) icon - tick the box at Find Devices and Content.   This should make your Private profile your current profile.   

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Chriso747 - Not sure what you mean - when I click on the "icon" for the local area connection I get the second screen shot - nothing to "click", "select", or otherwise take action on.  And yes, I am an admin of the PC.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

you may have to do this on all computers, and reset router, shut down all computers and apply fix one at a time

did you try uninstall adapter from device manager

then try


HAD TO UNINSTALL AND INSTALL CLIENT FOR MICROSOFT NETWORKS AND FILE AND PRINT SHARING FOR MICROSOFT NETWORKS

 NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>UNINSTALL CLIENT FOR MICROSOFT NETWORKS

NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>UNINSTALL FILE AND PRINT SHARING FOR MICROSOFT NETWORKS

NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>INTERNET PROTOCOL VERSION 4>INSTALL>CLIENT>INSTALL CLIENT FOR MICROSOFT NETWORKS

NETWORK AND SHARING>CHANGE ADAPTER SETTINGS>RIGHT CLICK ADAPTER>CHOOSE PROPERTIES>INTERNET PROTOCOL VERSION 4>INSTALL>SERVICE>INSTALL FILE AND PRINT SHARING FOR MICROSOFT NETWORKS

SHUTDOWN

you can also try:

RUN>CMD (AS ADMIN)>NET VIEW /ALL

RUN>CMD (AS ADMIN)>NBTSTAT -r

RUN>CMD (AS ADMIN)>NBTSTAT -n

RUN>CMD (AS ADMIN)>NBTSTAT -c

RUN>CMD (AS ADMIN)>NBTSTAT -s

RUN>CMD (AS ADMIN)>NBTSTAT -S

RUN>CMD (AS ADMIN)>NBTSTAT -RR

RUN>CMD (AS ADMIN)>NBTSTAT -R

RUN>CMD (AS ADMIN)>NBTSTAT -A (ip address)

RUN>CMD (AS ADMIN)>net use

RUN>CMD (AS ADMIN)>net use (\\share name)

NET VIEW gives error 1231 !!

Discovered that this new Windows build has magically become CASE SENSITIVE to machine names!!

IF you have missing shares or completely disappeared machines on your LAN, make sure their machine names are not mixed-case. If they are mixed case, rename them to ALL CAPS and then reboot.

Problem SOLVED, they will no longer be invisible on your network.

Just posting this for the benefit of anyone else who may have machines that are ping-able, and have good  DNS name resolution, but it seems that NETBIOS resolution is 'somehow' broken, even though it is properly enabled. What I discovered today was that somehow the latest Win10 build has become slightly CASE-SENSITIVE - and this breaks the old NETBIOS standard going back to antiquity.

So rename your "invisible" shares or machine names to UPPER-CASE, and they will magically appear on your WORKGROUP again.

and:

problem with NAS' (in this case Synology) and SMB 3.11.
This maybe the correct solution.

http://forum.synology.com/enu/viewtopic.php?f=49&t=106924

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

reboot


7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try this

 1.Open "This PC"  or any folder  and click on network

2. If network discovery is disabled, it will show a message notifying you about it ,click on the message and "turn on network discovery"

3.Then  it will show the dialog below , click on the first option (No,make the that I am connected....) ,after this the network should now have been set to private

Another way  is typing the next command in powershell (you have to run powershell as a administrator)

Set-NetConnectionProfile -InterfaceAlias "Ethernet" -NetworkCategory Private

Where -InterfaceAlias  is the name of the adapter network that you want to change its profile.
If you want to return to "Public" just change the -NetworkCategory to "Public"  (-NetworkCategory Public)   


79 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You have other suggestions above.   Though to add to your reference to mine:  I have the following text above Properties:

Find Devices and Content

Allow your PC to be discoverable by other PCs and devices on this

network.  We recommend turning this on for private networks at

home or work, but turning it off for public networks to help keep

your stuff safe.

A toggle for On or Off at this location

This toggle changes my default from Public to Private - but you seem to be missing this action.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So this gets weirder and weirder.  I clearly am connected to the Internet, but *none* of the Metro apps sense an Internet connection but non-Metro stuff is fine.  First screen shot - I have this forum up in IE11 and Steam running looking at my Steam library on the right, and Edge upper left and the App store lower left - Edge can't find the Internet, neither can the App Store:

And even weirder - I can clearly see all the devices on my network - even my printers - yet it says I am not connected to a network.  Guess it's time for a reset:

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This works in WiFi, but I think the same should work also in Wired (no wire right now to check):

# Open Windows PowerShell in admin mode. Start -> PowerShell -> Right-click -> open as administrator

# Get current profiles. Make sure you are logged on to the network you want to change.
Get-NetConnectionProfile
# Change the network in your list to be private
Set-NetConnectionProfile -Name "MYWIFINETWORK" -NetworkCategory Private
# Check that everything went fine
Get-NetConnectionProfile

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.