Help: Post-HomeGroup File Sharing Troubleshooting

I need some help, please, figuring out why we're having issues accessing files previously shared with HomeGroup following the April features (1803) update.  I'm optimistic I'm missing something simple & that there's an easy fix.  I do understand that HomeGroup was removed in 1803.

Since I'm not sure how to explain, I'll boil it down to one concrete example -- please ask if more info is needed -- between a wired Win 10 Pro desktop (Ethernet to a switch to the router) and a Win 10 Pro SP3 (wi-fi to a WAP that connects to the router via Ethernet).  You could multiply this problem by 8 or so because we have a 7 wired desktops and 8 wi-fi Surface Pros & laptops (all running Win 10 Pro) and all in the same workgroup, which IIRC, is left over from pre-HomeGroup times. 

Files from all were shared with each other through HomeGroup prior to the 1803 Update.

The first snag was that the update didn't hit all the machines at the same time, which broke our HomeGroup.  Yikes.  So, then I updated all the machines & thought that would resolve things.  It didn't.

So, the simple example is this.  On PC1, going to File Explorer, Network, the SP3 1 shows up as a Computer -- double-clicking it takes me directly to all the shared resources with no problem.

But, on SP3 1, going to File Explorer, Network, no Computers show up -- there isn't even a Computer category.  The only categories are:  Media Devices, Multifunction Devices, Other Devices, Printers, Scanners 😢  PC1 shows up as a media device, but clicking on it only opens Media Player -- it doesn't show the shared files. 

Why isn't there a Computer section in File Explorer, Network on the SPs & laptops like there is on the desktop computers?  I'm suspecting it has something to do with the fact that the laptops & SPs are using wi-fi rather than Ethernet, but I have no idea what to do.

As described towards the bottom here, I think (haven't tried all the folders) I can get to the shared files on the wi-fi laptops & SPs "in File Explorer by typing the name of the PC and the shared folder name in this format: \\homePC\SharedFolderName."  Honestly, though, it's not at all practical for anyone here other than me to remember all those paths.

TIA for any assistance. 

As you noted, Homegroup has been discontinued with the release of Windows 10 1803. Your best option is to use a basic peer to peer workgroup network with Public File Sharing and Permissions. Learn more:

https://www.groovypost.com/howto/connect-netowr...

and

https://www.groovypost.com/howto/share-files-st...

https://www.groovypost.com/howto/change-network...

There are some further configurations you will need to adjust...

Open Start > Settings > Network & Internet > Status
Scroll to the bottom
Click Network and Sharing Center

Click Change advanced sharing settings
Expand All Networks
Under Password protected sharing

Switch between 'Turn on password protected sharing and Turn off password protected sharing'

Then choose 'Turn off password protected sharing'

Then click 'Save changes'

Also:

Press Windows key + R
Type: optionalfeatures.exe
Hit Enter

Scroll down to SMB 1.0/CIFS File Sharing Support
Tick the SMB 1.0/CIFS Client
Untick SMB 1.0/CIFS Automatic Removal and
Untick SMB 1.0/CIFS Server


Click OK
Restart if prompted.

Microsoft apparently has a workaround which does not require enabling SMBv1, for those who rely on the ability to 'browse' the network.

https://support.microsoft.com/en-us/help/403431...

Explorer Network Browsing

The Computer Browser service relies on the SMBv1 protocol to populate the Windows Explorer Network node (also known as "Network Neighborhood"). This legacy protocol is long deprecated, doesn't route, and has limited security. Because the service cannot function without SMBv1, it is removed at the same time.

However, if you still have to use the Explorer Network in home and small business workgroup environments to locate Windows-based computers, you can follow these steps on your Windows-based computers that no longer use SMBv1:
Start the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services, and then set them to Automatic (Delayed Start). When you open Explorer Network, enable network discovery when you are prompted.

All Windows devices within that subnet that have these settings will now appear in Network for browsing. This uses the WS-DISCOVERY protocol. Contact your other vendors and manufacturers if their devices still don't appear in this browse list after the Windows devices appear. It is possible they have this protocol disabled or that they support only SMBv1.

Additional troubleshooting steps you can apply:

- Try browsing to some of the computers manually, press Windows key + R, type: \\computername, hit Enter
- Press Windows key + R
Type: services.msc
Hit Enter

1. Start the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services, and then set them toAutomatic (Delayed Start).
2. When you open Explorer Network, enable network discovery when you are prompted.

Press Windows key + X > computer management-->shared folders--> choose the shared folder, right click it then click Properties > Share Permissions -->protection that everyone can read and execute, see folder contents and read permissions.
Best,
Andre
Windows Insider MVP
MVP-Windows and Devices for IT
twitter/adacosta
groovypost.com

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Andre, thanks for your detailed response.

I thought I'd read somewhere that MS strongly advised not to enable SMBv1, so I'm confused about the . . . wisdom of having to enable it to regain a functional network?

Another question, if I might.  Back in the Dark Ages <g>, our network was originally set up using workgroups (that is, all computers were in the same workgroup) to share files & resources like printers, scanners, NAS, and the like.  Then along came HomeGroup, and we switched to that . . . and it worked flawlessly.  Now, HomeGroup is gone.  I'm wondering if the problem is that somehow settings (or whatever) have become hopelessly messed up & that's why the instructions MS provides here aren't working in our environment?

If that's the case, is there a way to basically start from scratch and see of that gets functionality back?  Is there some way to unshare everything on all the computers, get rid of the old workgroup, create a new workgroup (if that's even needed in Windows 10), and then set all the shares up from scratch?  I really am just getting pretty desperate to get things working again.

I've forgotten more than I ever knew about networking -- back in the old days, I was pretty good at configuring things, but since switching to HomeGroup back with W7 (IIRC), I've just not had to think about process.

Thanks

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

This option is the best option to start with:

Press Windows key + R
Type: services.msc
Hit Enter

1. Start the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services, and then set them toAutomatic (Delayed Start).
2. When you open Explorer Network, enable network discovery when you are prompted.

and

Open Start > Settings > Network & Internet > Status
Scroll to the bottom
Click Network and Sharing Center

Click Change advanced sharing settings
Expand All Networks
Under Password protected sharing

Switch between 'Turn on password protected sharing and Turn off password protected sharing'

Then choose 'Turn off password protected sharing'

Then click 'Save changes'
Best,
Andre
Windows Insider MVP
MVP-Windows and Devices for IT
twitter/adacosta
groovypost.com

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated August 7, 2020 Views 1,476 Applies to: